Banner
Views: 790,761,721
Time:
11 users online: AntiDuck, Darolac,  E-man38, Everest, h.carrell,  idol, Ladida, PROMETHEUS, westslasher2, Yagami, yogui - Guests: 35 - Bots: 357 Users: 41,286 (1,497 active)
Latest: ZomWolfGame
Tip: Verify your ROM is unedited by using ROMclean.Not logged in.
Posts by EvilGuy0613
EvilGuy0613's Profile - Posts by EvilGuy0613
Pages: « 1 2 3 4100 101 »
I have a minor problem. In a few tutorials I've seen that most people's 10 and 11 map 16 pages contain the original smw Backgrounds but my pages 10 and 11 are blank. My originals start of in 40 and 41. Also when I press the blue mushroom button for the first time I don't get the "No GFX are present in the rom" error.

I want to insert BG and FGS but I don't know a safe place to but them. Please help.
Originally posted by WhiteYoshiEgg
Originally posted by EvilGuy0613
I have a minor problem. In a few tutorials I've seen that most people's 10 and 11 map 16 pages contain the original smw Backgrounds but my pages 10 and 11 are blank. My originals start of in 40 and 41.

The tutorial isn't exactly up-to-date anymore. Lunar Magic 1.70 and above allow for far more Map16 space, so foregrounds now use pages 0-3F while pages 40-7F are used for backgrounds.

Originally posted by EvilGuy0613
Also when I press the blue mushroom button for the first time I don't get the "No GFX are present in the rom" error.

That's supposed to happen when you do it for the first time. It should vanish after you've inserted some ExGFX.


So its normal for the orignal backgrounds to be on 40 and 41? and if so where do I insert my BG GFX

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by WhiteYoshiEgg
Anywhere between page 42 and 7F.


Understood, Thanks alot.

--------------------
My Youtube Channel for Hacking and Gaming.
My only problem is when I go to the Background Editor to use the Graphics i imported I press the page up and down and its only the default page its already using and blank blue blocks pages, and I saved after the pages the default backgrounds were in which was page 40 and 41.

Also the sample levels that come with the GFXs i download all keep saying "FG/BG GFX File not found in rom" so the background is blank.

If someone can help me out here I'd appreciate it =)

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by Ramp202
Originally posted by EvilGuy0613
My only problem is when I go to the Background Editor to use the Graphics i imported I press the page up and down and its only the default page its already using and blank blue blocks pages, and I saved after the pages the default backgrounds were in which was page 40 and 41.

It's different for changing the BG GFX Page. in LM 1.7+ you have to highlight everything in the BG Editor than press F9. You put in 100 to go one page forward and -100 to go one page back.
Originally posted by EvilGuy0613
Also the sample levels that come with the GFXs i download all keep saying "FG/BG GFX File not found in rom" so the background is blank.

It's normal for it to say that since the BG Page used in the Sample Level might not always be the first blank page you have from page 40-7F.


Alright it worked thanks. As for the the sample level thing, so I have to find the page its using and insert the background there?

--------------------
My Youtube Channel for Hacking and Gaming.
Hey its me again with another question.

I know how to insert a single bg graphic into my rom, but when I go to download another graphic i want to use, when it comes with a "map16pagebin"file and it ask if I want to replace the one that's already there, do I say yes?

And do I have to load every Graphic I get?

--------------------
My Youtube Channel for Hacking and Gaming.
Hey, When I go to test my levels, sometimes, the sprites don't show up. Its only been a problem for a few levels but I'm not sure why they don't show up. Any idea why that happens?

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by Koyuki
Hmm.. maybe you should try adjusting the Sprite memory setting in that level.


Sorry I'm kind of new to this, how do I do that?

--------------------
My Youtube Channel for Hacking and Gaming.
I typed the LDA #02 STA $7E0019 on 105 then on the cmd file it said patched applied with no errors but my mario still doesn't have a cape for some reason

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by Iceguy
Are you by any chance using xkas v0.08? It sometimes says that but doesn't really apply the patch. Try using v0.06 if that's the case.

Well I switched to the old version but it still didn't work. I am supposed to put -xkas smw.smc level.asm- in the cmd file to patch it right? Also I put the LDA and the other exactly how the tutorial said it in the level code file but its still not working.

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by Alcaro
Originally posted by EvilGuy0613
xkas smw.smc level.asm

The correct usage is xkas level.asm smw.smc (at least for 0.06, and I can't see any reason why other xkas versions would swap them).


Did that too, it said patches applied with no error. But I go to see if it worked and it didn't.

--------------------
My Youtube Channel for Hacking and Gaming.
Also I don't know why but on some of my stages, let's see how do I explain this...the sprites (mainly the plat-former sprites) they work fine its just they look a little bit glitched like part of the sprite is missing or something and I don't know how to fix it.

If you don't know what I'm talking about I can link one of my videos the problem occurs.

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by SomeGuy
Word of advice, you never have to put the '7E'. And if the first two digits are zeroes, you can remove them too. However, the amount of digits should never be three, so don't put "$137" for "0137", just put "$0137".


Just tried it, i didn't work. My Mario doesn't have a cape. Just to be sure I'm am supposed type this "xkas level.asm smw.smc" (Without the quotes of course) in the cmd file right? Or wrong.

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by LaularuKyrumo
Looking for blocks that instantly kill mario. Like lava, but less buggy and exploitable. It's important that it kills the player no matter where they touch it, and also needs to kill them if they're riding Yoshi as well. Think munchers, but more deadly and with anti-Yoshi properties.


Well It worked for like half of the level, but I'm going to try the no more sprite limit patch.

--------------------
My Youtube Channel for Hacking and Gaming.
1st, after I got done using BTSD I opened my rom to see if it worked, but the title screen was completely black. I can hear the music but I couldn't press anything.

2nd I opened a clean hack and stuff and used the block tool edited the data base and inserted the block to 370 but it keeps saying the "Super Mario World dbk" are not present in the rom for some reason. I rly don't know what I'm doing wrong.

--------------------
My Youtube Channel for Hacking and Gaming.
Originally posted by JowTH
All the BT standard blocks are compatible with BTSD. Only write the correct offsets.

Also, put all files what BTSD created in the same folder of your hack.


Their in same folder. Well it won't say "Super Mario World dbk are not present" if I save the blocks to map 16 page 2 however but is it safe to save them to page 2?

But even then the block still isn't working like its supposed too.

--------------------
My Youtube Channel for Hacking and Gaming.
So, I tried applying NoSpriteLimits patch to my rom and I'm not sure rather its working or not, but some sprites still looks like parts of them are missing so I assume not. I used like two different Xkas to see which one worked but it still didn't work.

However i was able to apply the health bar to my rom successfully with no problems. I just don't know how to get NoSpriteLimits working. If anybody can point me in the right direction, I'd appreciate it.

--------------------
My Youtube Channel for Hacking and Gaming.
Oh....no I didn't and that just fixed my problem I think. Thank you guys alot. Like seriously I'm really thankful.

--------------------
My Youtube Channel for Hacking and Gaming.
Hey guys, I'm pretty new to hacking I just started barely a week ago. But anyways this is my 6th level of my demo,

http://www.youtube.com/watch?v=qjc8PegZzWE (Don't know how to attach video without the link)

So yeah if you watched, Please give Criticism, I'd really appreciate it.

--------------------
My Youtube Channel for Hacking and Gaming.
(restricted)
Pages: « 1 2 3 4100 101 »
EvilGuy0613's Profile - Posts by EvilGuy0613

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2019 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 7

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • SMBX Community
  • ROMhacking.net
  • MFGG