Banner
Views: 992,975,112
Time:
8 users online: fsvgm777, gui, Hayashi Neru,  MarioFanGamer, Serge, shaoshao, spooonsss, Tomi4evs - Guests: 65 - Bots: 146 Users: 54,458 (2,084 active)
Latest: yoQuacc
Tip: Verify that your hack's BPS patch is functioning correctly before submitting it.
Not logged in.
Posts by TheSuperRotom
TheSuperRotom's Profile - Posts by TheSuperRotom
Pages: « 1 212 13 14 15 16 17 »
I need help like REALLY need help direly need help. I need to recover a ROM of mine from earlier today, but Lunar Magic won't open it up to allow me to. I used Lunar Expand to expand the ROM to 4 MB's, in order to insert a custom sprite. I made a backup before hand, and then I inserted them. Sprite-Tool said that it was done successfully, but then I tried to open it up in Lunar Magic. And it stated it wasn't a Super Mario World ROM. I checked with the Clean ROM Verifier, and indeed it isn't. The real problem is that backup ROM somehow got messed up as well when I copied it. So now I need some way to recover it, as my computer's backup is from the beginning of this year. Please if you know ANY way I can fix this please help me!#smw{._.}

EDIT: The weirdest thing is that when I loaded it in ZSNES, it still had a header. The header was "(c) 1994 Tricksasm" Maybe that might help.

--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by Alcaro
...what the hell? What the hell did TRASM do to your ROM?

Check if Lunar Magic's restore system can offer anything useful. I haven't used it myself, but poke around in File->Restore.

If that doesn't help, apply the following patch. With xkas or Asar, because TRASM is clearly possessed by some satanism.
Code
header
lorom

org $00FFC0
db "SUPER MARIOWORLD     "

Then port to a clean ROM as fast as you can and hope nothing too important broke.

Either way, I hope you'll make more backups in the future.


Header's fine, but everything else is fucked broken. All of the ExGFX is broken, sprites are broken. #smw{-_-;} Looks like I'll have to fix the OW map from the newest backup demo, and remake half of a world.

EDIT: If you'd know a way to repair it, the error is that it's opening, but Lunar Magic is stating that the ExGFX files don't exist, then follows up by saying that "Sprite GFX File 0x0 doesn't exist." Clicking the mushrooms to insert them is useless as all GFX was wiped. Almost all level names and the first two message boxes were replaced with "AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA".

DOUBLE EDIT: I tried the thing you suggested, but in reverse. So that means I applied the patch so I could access the ROM in Lunar Magic, and thankfully, the restore points were still there. So I could revert it to the way it was before I inserted the custom sprite.

--------------------
There used to be stuff in this footer, but it's all gone now.
Is there a tutorial on how to convert a custom sprite meant for TRASM into one for xkas? I'm curious about this

Originally posted by Alcaro
because TRASM is clearly possessed by some satanism.


--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by Ladida
use this


Didn't work. Same error as before, just this time because the ".cfg" had info that wasn't compatible with the xkas sprite inserter.

Oh and by the way, here is the sprite I'm trying to insert.

--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by Ladida
ok, for manual conversion:

thats all that comes to mind


I'm getting closer. The only things that are left are

A. Parts where I confused defines and labels
B. Me forgetting about putting at least one instance where the label comes before the define.
C.
Originally posted by Spritetool temp.log
error: tmpasm.asm: line 40{2}: invalid opcode or command [TABLE1,x]


And here is the line in specific.

Originally posted by WaterRise.asm
LDA: TABLE1,x


But that's the first instance of the label "LDA", and the next one is

Originally posted by WaterRise.asm
LDA #!$01


A define. And this is the case for all labels. What do I need to do?

--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by Ladida
kjaf ihsdoi
lesgfoweingwlk
oiwehngfoiweg
ksjdbf
hioghsw gfiusdohf


What one Earth does that mean. I'm sorry if I'm causing a problem for you. So anywho, now it's working in reverse.

Code
error: tmpasm.asm: line 43: define not declared (yet?)
error: tmpasm.asm: line 43: invalid opcode or command [LDA]


and the problem continues on with all references to the label. So, any idea.

--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by Alcaro
Did you even read the second half of his post?


That would be a yes. And here's proof.

Originally posted by TheSuperRotom (Before)

error: tmpasm.asm: line 40{2}: invalid opcode or command [TABLE1,x]
LDA: TABLE1,x (Line 40)
LDA #!$01 (Line 43)


And here is how it is now.

error: tmpasm.asm: line 43: define not declared (yet?)
error: tmpasm.asm: line 43: invalid opcode or command [LDA]
LDA TABLE1,x (Line 40)
LDA !24 (Line 43)

So clearly I did something wrong.

--------------------
There used to be stuff in this footer, but it's all gone now.
Sorry, for making another thread, but I didn't want to wait 24 hours to ask this very simple question. How do you find out what kind of custom sprite it is? Like a block or generator.

--------------------
There used to be stuff in this footer, but it's all gone now.
In my new hack, Megio, the intro level is a joke about blatant level edits, having the first 3 and a half screens of YI1, then leading to a cutscene introducing the concept of the hack. But in order to make the blatant level edit joke work (in my mind) it needs to have the standard music. The problem is, the music won't change even if changed in Lunar Magic. It'll still play the intro music. I've tried both ways of changing music (editing level header settings and bypassing the music entirely), but it still doesn't work.

Any idea if this is possible to change?

--------------------
There used to be stuff in this footer, but it's all gone now.
Originally posted by JackTheSpades
ROMmap to the rescue:

$009724 (0x01924) is the intro screen (level C5) music.


Value for the normal music?

--------------------
There used to be stuff in this footer, but it's all gone now.
Alright first moderation!

The hack was mostly alright. The palettes were a bit dull, but I'll assume that it was meant to be that way. The levels felt rather un-finished, maybe put an enemy here, another one there. The difficulty was another problem. Sure, the demo is only 3 levels long (4 if you include the "End of Demo" level), but from what I got, this all was World 1 stuff. And the ending of the second level was total bullshit. A precision section in the first world in a normal difficulty hack just shouldn't be there. Not to mention you have to do it twice in order to get both exits. And how do we end it? With an "End of Demo" level you can enter, that leads into Level 0.

As for difficulty, with the exception for the ending of the second level and the Red Switch, the difficulty is normal

While with a bit of work it could be decent, as it is, I have to go with rejection.
Alright, even though I already reviewed this, I was bored and decided to review the new demo 1.5

The hack was just about the same as before. The difficulty has been fixed in some areas, and in other areas not so much. Palettes are clearly the most major change. As with the difficulty, the palettes in some areas are fixed, but yet some others aren't. While the difficulty in the second level has been improved, the Red Switch Palace looks as if no attention was given to it. It still very hard and more. Castle #1 is a bit short, and Dark Night City...My god... For a normal hack, this is way too difficult for a second world. Not to mention the muncher pipes from Lemmy's fight show up all over here, without any warning or anything. It's better, but not quite good enough for me.

Again, like last time, with the exception of the Red Switch Palace and Dark Night City, the difficulty is normal.

I might have already given it away, but I'd still go with rejection.
So which free game should I chose. Pikmin 3 or Zelda?

--------------------
There used to be stuff in this footer, but it's all gone now.
The first time I remember playing a video game would happen to be Pokemon Yellow.

--------------------
There used to be stuff in this footer, but it's all gone now.
You know those platforms in DP3 that spin in a circle? I was going to place them in a vertical level, and they don't show up. The sprite memory is the same as it is in DP3, so I don't know what the problem is. Anyone want to help?

--------------------
There used to be stuff in this footer, but it's all gone now.
So, I wanted to make a GFX hack for Mega Man II that would use Mega Man III's sprites. So I go in and, the graphics are all compressed. I've been using yy-chr for doing this, and I was wondering, what can I do to decompress the GFX into a usable state?

(By the way, Mega Man II's graphics are mostly uncompressed, so that's noteworthy).

--------------------
There used to be stuff in this footer, but it's all gone now.
So, I was using the SMB3 Goal tutorial, and it brought up changing the palette of the "Goal ? Sphere" to sprite palette F. So how on earth do you change the palettes of sprites?

--------------------
There used to be stuff in this footer, but it's all gone now.
So whenever I patch a ROM with my hack to test the patch, for some reason the custom blocks don't work. What on earth!?

--------------------
There used to be stuff in this footer, but it's all gone now.
Alright let me show you an example of this using the SMB3 brick block.

Base ROM:

http://i1228.photobucket.com/albums/ee448/TheSuperRotom/before_zpsd3baa761.png

Patched ROM:

http://i1228.photobucket.com/albums/ee448/TheSuperRotom/after_zps1f1a94b5.png

(YCZ resize images if needed.)


yczedit: table stretch begone

--------------------
There used to be stuff in this footer, but it's all gone now.
Hang on, looks like something just was being bitchy.

Originally posted by yoshicookiezeus
...any particular reason why you couldn't do that yourself?


Couldn't find the BBCode for image re-sizing.

--------------------
There used to be stuff in this footer, but it's all gone now.
Pages: « 1 212 13 14 15 16 17 »
TheSuperRotom's Profile - Posts by TheSuperRotom

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks