Banner
Views: 853,026,998
Time:
32 users online: 7 up, AbuseFreakHacker,  Anorakun, blgmadresh0000, brickblock369, buggy789, CalHal, codfish1002, Dan Drigues, Darknubs, Darolac, earthmeLon, Enan63, Epic_Manky, eskayelle, FireSeraphim, Golden Yoshi, kellykelster, LeaderAngelo, Lizstar, Lumy,  Major Flare,  MM102, NewPointless, Odogo, RinasSam, Sariel, smw_andz, SnowyIceDragon, The Central Scrutinizer, thiaguintx, Zidan3 - Guests: 72 - Bots: 65 Users: 47,044 (2,522 active)
Latest: Jv341211
Tip: Coins and Dragon Coins guide your player through the level and mark progress. Don't forget to place them!Not logged in.
Posts by SpicySeafood
SpicySeafood's Profile - Posts by SpicySeafood
Pages: « 1 2 3 4 5 6 7 8 »


I've only got a concept screenshot so far. I spent last night compiling the map 16 page (just managed to squeeze everything in 1 page).
So I would have to make 3 different teams, for the best of 3 battles?
Good games, it was closer than I expected. #ab{:)}
semen
February 5, 1337
c3 end at never
In an effort to be more modern, I have downloaded the successor to spritetool, PIXI, and ported my ROM.

However, I appear to be having some trouble when running the program.

I'm attempting to insert Iceguy's goal roulette. I've put both the cfg and asm files to the /pixi/sprites folder, then I set list.txt to be "00 roulette.cfg". This is how it worked with spritetool. I checked the readme and this appears to be correct for PIXI too.

I then run PIXI, I enter my ROM name, and I am told "18 shared routines were registered". PIXI doesn't give me any further prompts or notices from that point even after 2 minutes. Once I tested it out in LM, (sprite 0, extra bit 2 because I want the normal exit) I found the sprite hasn't inserted at all.

It doesn't appear to be working for me. Is there something I'm missing here?
Thank you! It is working now.
I have a rather niche question.

I'm modifying the level_ender sprite built into PIXI. I want Mario to receive a 1-up if he has big, fire or cape after he has finished a boss dungeon full of enemies. It's a reward for completing a difficult section without taking damage.

However, it crashes the game upon finishing the level, but only when Mario is big/fire/cape. I'm not sure what could be causing this issue. I checked the RAM map and all the addresses seem to be correct.


The modified sprite is here: https://pastebin.com/sTeHJVA2

I'm a newbie to ASM so I apologise if this is a dumb question.

Thank you for your replies.
Try it out on another level? That way you can determine whether the 'custom image' in Yoshi's House is the problem.
(restricted)
what happened before with nameless? fill me in on the drama that i missed
Pages: « 1 2 3 4 5 6 7 8 »
SpicySeafood's Profile - Posts by SpicySeafood

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy