Banner
Views: 882,784,242
Time:
19 users online: Aeon, AmperSam,  Anorakun,  brickblock369, Danilo_Sick, DeepDeaDive, Isikoro, Kitikuchan, KoJi,  LMNtals, Murphmario,  Nameless, Nowieso, PlagueRatofDoom, Sping bot,  Stivi, supermargot, Truxton, Ultima - Guests: 59 - Bots: 73 Users: 49,451 (2,423 active)
Latest: legony64
Tip: Read Lunar Magic's help file and SMW Central's FAQ, as they cover most of the basics of SMW hacking.Not logged in.
Posts by August77
August77's Profile - Posts by August77
Pages: « 1 »
I'm working for a custom magikoopa that fires 3-way magic.
https://bin.smwcentral.net/u/40151/magikoopa.zip

but it becomes normal one after he's dead.
I want this to be still modified one.
in addition, he sometimes doesn't aim mario(especially he and mario are in the same height).

plz tell me if you know the tricks.
thx a lot!! I quickly made a fix of this and it seems working well right now :)

How about the aiming problems?
he sometimes shoot like this picture.
https://bin.smwcentral.net/u/40151/SMW000.png

if you notice anything,plz let me know.
I want to add music below in my rom with AddmusicK.
This music is for AddmusicM, so I just modified little bit.
But it seems some error occurs and it dosent work well.
I try changing #default to #optimized but no music play this time.
please let me know if u know something.



link
https://bin.smwcentral.net/u/40151/Four_Noble_Demons.zip
original files included
thanks for the reply!
I give up this music then.
so sad :(
hi :)
I'm working at making my own custom music but something is wrong.
I wanna make tempo little bit fast, so I modified the value with "t",
but it seems no effect.
Also,I wanna make #2 and #3 louder,but it seems "v" value is already maxed out.So let me know if you hava an idea.

my work is here.
https://bin.smwcentral.net/u/40151/lostdream.txt
Thanks for applying!
I just solved the volume problem,but tempo actually doesn't change.

Seems like my first two line

#0 t81 w200
@9 $ED $7F $A0 v200 o3 y12

is ignored.
(same as instruments. Nothing changed)

Could you tell me if you have a solution?
Thanks a lot!
The problem finally solved!
Maybe the comments disturb AMK :p

P.S. I didn't know about adding header,so I'll try it.:)
HI :)
I wanna make to respawn my custom magikoopa faster.
(twice of normal one would be better.)

Seems like these lines

.next
DEY ; decrease loop counter
BPL .loop ; if sprites left to check, branch
STZ $18BF|!Base2 ; activate sprite
PLB
RTL

are involved,but unfortunately I couldn't understand exactly which parts
to modify.(I added DEY,but it changes nothing.)

Please tell me if you have anything.
my file is here. https://bin.smwcentral.net/u/40151/magikoopa.asm
Thanks for the reply!
Unfortunately, neither of them are not what I wanted.
(The former is for timing of appearance after it disappears,
and the latter is for graphics.)

I would like to change time of respawning after Mario kills it.
Please let me know if you find any further information.

Thank you.
Thanks guys!
I just tried the code,but it makes magikoopa not to respawn anymore.
I guess this is because making $18C0 0 probably stops respawning.(I just checked about D2)
I'be happy if you teach me solution.
Thank you so much!
It finally worked!
I want to add music below in my rom with AddmusicK.
This music is for AddmusicM, so I just modified little bit.
But it seems some error occurs and it says Echo buffer exceeded total space in ARAM.
I try changing #default to #optimized but nothing changed.
Since there are few $F1,I cant get where to change.
please let me know if u know something.

link
https://bin.smwcentral.net/u/40151/four%2Bnoble.zip
thank you for the reply!
I just changed it 00,but it gets weird (especially channel #0)
I put it back to #default and then it says Echo buffer exceeded total space in ARAM.

please let me know if you have noticed anything.
thanks for the reply!
First,i can only change $F1 to 01 but it changes little.
I found that AMK says $FA command in line 32 was ignored,so I eliminated it. And then, it seems working except lead part (it sounds very weird)
Also,I tried #amk 2,but then the song stops in the middle,so I use #amm now.
please let me know if you have any idea.
Also, i would like to know alternate of $FA command, so let me know too.
I've noticed that line probably has a problem.

Code
"Lead=$F3$04$04 $EE $00 $ED $7F $E0 h12 $DE$00$09$30"


But since i don't know about $F3 command in AMM,I cant figure out where exactly the point is.

Dose anyone solve this?
Thanks a lot!
It finally worked!
I try to use this laser, but it doesn't hurt mario.

https://www.smwcentral.net/?p=section&a=details&id=3692

no ploblems in installation. Graphic is also ok.

please let me know if you notice anything.
Thanks for the reply!
I also inserted it as shooter.
I think the shooter works correctly,so the cluster sprite's code must have a problem.
SA-1 asserted. PIXI,GPS,LM 3.04 is used.
I also asserted

No Silent Bullet Bill
score fix
Scroll fix
Time up fix
Keyhole fix
HDMA fix
HDMA Circle fix
reserved all
reverse-gravity patch by xkas.
Laser doesn't contact with other sprites.(no reaction)
Pages: « 1 »
August77's Profile - Posts by August77

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks