Banner
Views: 895,278,522
Time:
27 users online: 3dsalmon, AppleBoy54321, chleain, Darknubs, DekuSlate, Diego, Dippy, eduard11, Goomba-24, HelmsDeepnest, jirok1, KaidenThelens,  KevinM, kjitmno''.pqr,  MarioFanGamer, Mirann, Miscalc, NicoSwitch, pat94plus, RoydGolden, SAMYR DUTRA ARAUJO, Segment1Zone2, socool111, supermargot, Torchkas, Will331999, YMM - Guests: 86 - Bots: 84 Users: 50,222 (2,298 active)
Latest: AwesumEMan
Tip: Don't replace the first two Map16 FG pages unless you explicitly know what you're doing, or objects may act strangely.
Not logged in.
Posts by semiblind
semiblind's Profile - Posts by semiblind
Pages: « 1 »
I am looking for a way to kill Ted without using a star or disco shell. I have tried these 2 sprite killer blocks with no luck.

https://www.smwcentral.net/?p=section&a=details&id=22898

and

https://www.smwcentral.net/?p=section&a=details&id=23325


Anyone have any advice or ideas on another way to get the job done?
Originally posted by KevinM
Blocks won't work because the Torpedo Ted doesn't interact with blocks, so your best next option is with a sprite. This should work.



That did the trick, Thank you very much!
Originally posted by Idunno
I'm pretty sure you can kill a torpedo ted with a throw block, but their hitbox will still be active so they will still hurt you when falling off the screen. I thought I should share this even if you found a another way to kill them.



I did not know that, but i do appreciate it! I am using the Ted to ride for a while and its in an area where the normal kill methods just dont work, so that sprite kill sprite was perfect for my use. Hopefully others can find this post and get an answer quicker than me trying to do it all on my own, lol.
I was wondering if there was a way to change the speeds and/or frequency/delay of layer 2 smash 3?
I never had any luck getting local sprites to work. I just put it in the list as the next number in my list. Example: 01 spritename.cfg and run pixi. Then manual insert and use extra bit 2 without issue.
Doing it this way also allows you to use the sprites in any other level in the rom that you may design later on.

I have had to mobe some sprite graphics around in yychr to make them look right in some levels, but that is a pretty easy process as well.
I am trying to do some work on events and have run into a problem where if i dont use the 4x4 event tiles already there, any tiles i made never seem to work right in the game even tho they look right in LM.

Here is in LM


Here is in game when the event runs



Any suggestions or advice on how to make it look right in game?


Edit: After talking with a few people on discord it seems it was working just fine, but i was using a save state at the end of the event triggering level, and that is what was causing the issue. Hopefully this can help others who are new to this like myself.
I had this happen while working on a level with a layer 3 background. I used the bring forward/send back option to bring the sprite to the forward most position and it worked for me. I hope it is just as easy for you.
I am using layer 2 for the skewers, so i am using a layer 3 background. When the level is complete, the layer 3 seems to get moved down. Does anyone know why this happens and what i could do to stop it from happening?


How it looks normally.



How it looks when completed.

Originally posted by MarioFanGamer
That's because the level end goal card is on layer 3 as well and is drawn at the top left corner of the tilemap, thus necessiting the shift. Not easy to solve unless you either remove the score card or modify it to turn the screen black or use sprite tiles for the score card.



For this particular level, i do not / would not mind removing it entirely if it will do the job. I will search around to see if i can find something on that, but i should also ask if you could possibly point me in the right direction as well?

Thank you for explaining why it was happening.
Just need to ask this...

Are you loading in with a save state or are you opening the rom and going through the intro first?

I ask because i have seen issues similar to what you describe when loading in with a save state that was made prior to doing the events.
Pages: « 1 »
semiblind's Profile - Posts by semiblind

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks