Banner
Views: 864,301,082
Time:
12 users online: DeeDee, Eminus, Green Jerry,  KevinM, nnj, PSYotta, RandyMarsh4108, Sping bot, Taja, underway, Zandro, Zerio - Guests: 56 - Bots: 90 Users: 47,852 (2,080 active)
Latest: Bored
Tip: ALWAYS test anything that you've made before submitting it to SMW Central.Not logged in.
Posts by whatajerk
whatajerk's Profile - Posts by whatajerk
Pages: « 1 »
Hi so I'm a noob with regards to lunar magic and smw central in general but had what I hope is not a total noob question.

Im trying to add line guides to my level, now I know that they are available if I change the GFX header to one of the rope sets or the castle set but when I switch to those the line guides dont show up without me also changing the corresponding FG3 setting in the graphics bypass. This in turn messes up my graphics I have currently (currently using Normal 1 for FG/BG). My question then is, is there a way to have line guides no matter which GFX header I use? One solution I potentially thought of while writing this out was to export the graphics, edit the Normal 1 set and add the line guides to it but im not sure if thats feasible or not. Like I said total noob question and since its my first here im not sure if this is the right place for it, if not please let me know and I can delete the thread and move it to the appropriate place otherwise any ideas/help would be appreciated.
So I'm a bit of a beginner with lunar magic and rom hacking in general but I was working in LM 3.10 and applied the retry patch. It worked fine at the time. I then updated to 3.11 and started over as my first attempt was just messy. I actually created some custom blocks for this hack and added them via GPS. Everything was working fine, I then decided to apply the retry patch to this new hack. I did so via ASAR and everything was fine according to the output. But when I tried it out in the rom, I'd get either a blank black screen or id wait and I'd get put in a random level and dropped from the sky with a couple of green koopas without shells. I then tried every different combination of LM and the patch with my backup file, changing it out each time. I tried the same file within LM 3.10, I made sure that the Use Separate Settings For Midway Entrance was set, everything that you need to do to get the retry patch working and nothing.

Just now I took a copy of my clean SMW rom with no custom blocks and using LM 3.11 set level 105 to use the midway entrance setting and applied the patch and it works as expected. So I guess my question is, would the custom blocks I added to the rom interfere somehow with the retry patch? Should I apply my patches before I insert custom blocks/graphics? Sorry if this is a silly question but being new I wasnt sure if there was a procedure on which comes first or if its even necessary to do one before the other. Thanks for any assistance with this.
Thanks, I didnt think so from everything I read. I had cleared the save file out (in game and in my directory) but could still be something I missed, I'll just use a fresh copy of the rom and make it the first thing I do. Thanks again for the replies.
Pages: « 1 »
whatajerk's Profile - Posts by whatajerk

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy