Banner
Views: 858,766,930
Time:
12 users online:  bebn legg, deadworld2009, Digital Entertainment, ExONightZ, Final Theory, Gmario37,  JamesD28, Jazzman287, JupiHornet,  Koopster,  Noivern, thiaguintx - Guests: 56 - Bots: 100 Users: 47,463 (2,240 active)
Latest: FenrirWolf
Tip: Try making new backgrounds using SMW's existing graphics. For example, if you have a hilly BG, rearrange it to make it look more unique.Not logged in.
Posts by Filippianist
Filippianist's Profile - Posts by Filippianist
Pages: « 1 »
Hello, everyone! My first post here. This is my first time to use PIXI, because I formerly used Romi's Spritetool. Everytime I use PIXI, it crashes my ROM. PIXI tool itself works fine, but when I place custom sprite in level and enter in my ROM, I only see the black screen (without Nintendo Presents, etc...). Custom sprite that I tried to use is Sushi (made by A-l-e-x-99). This also happened to Bill Bomber sprite made by Darolac and SMB3 Burners made by lion. This happens factically to every sprite I insert and place into level. Is there a way to fix this?
Hello, everyone! I didn't applied other patches. I now discovered that I'm aware that I used Romi's Spritetool, than PIXI which crashed my ROM. I made folder named "PIXI" where I put all contents that are for PIXI. I downloaed latest version of PIXI which is 2.1.15. I'm now aware that I used Romi's Spritetool sprites on my ROM named "SMW Custom Sprite Previewer.smc" and then I copied this into PIXI folder and changed the name into "SMW PIXI Previewer.smc" and when I used PIXI sprites, this crashed my ROM. My list.txt looks like:
00 BillBomber.cfg
01 sushi.json
02 burnerh.json
03 burnerv.json
04 flyingkeyhole.json
05 GIANTHWOMP.json
06 thwomp_red.cfg

EXTENDED:
00 Fireball.asm

In "sprites" folder are sprites for PIXI, not for Romi's Spritetool. When I place the custom sprites in the level, on the keyboard I click on "Insert" button and I enter the number of sprite and extra bit set to 2.

Thank you for help! I don't know to talk on English enough and I will have little problems for expression.

I now started with clean ROM and latest version of PIXI, when I enter to PIXI, it says that I need to modify a level in Lunar Magic (Clean ROM name is Super.Mario.World.1.smc). I modified a level in Lunar Magic and again I enter PIXI, it worked fine now with all sprites applied successfully and registered Shared Subroutines and when I place the custom sprite in the level that I modified, this crashes my ROM.
Hello, everyone! The ROM doesn't crash now. I realised that I had unedeed files in "PIXI" folder and I made folder name "PIXI (test)". After I inserted sprites in this new folder that I made, ROM now works fine. Thank you very much for the help! I'm finally done with this topic and you can freely close the thread now!
Name: Line-Guided Grey Moving Castle Block
Type: Sprite
Tool: Romi's Spritetool/PIXI (both)
Description: Line-Guided Grey Moving Castle Block that will start moving right or down by itself, just acts like Line-Guided Brown Platform Disassembly 62.
References: None
Pages: « 1 »
Filippianist's Profile - Posts by Filippianist

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy