Banner
The Questionable Level Design Contest ends in…
13 DAYS, 18 HOURS, 30 MINUTES AND 39 SECONDS
Views: 914,169,426
Time:
19 users online: ASMagician Maks, Black Goku, BootaNoBijuu, brian 693,  BTD6_maker, Dustyized, elusive, grisu, Henares, Julintendo, KungFuFurby, monkey03297, NoMoreStars, PlagueofDoom, prpleish, Ruiyabi,  ThirdWall, UTF, wulv257 - Guests: 35 - Bots: 84 Users: 51,204 (2,268 active)
Latest: Henares
Tip: Use palettes that aren't difficult to look at. Clashing, overly-bright, or overly-dim colours may make your level difficult to play.
Not logged in.
Posts by andy_k_250
andy_k_250's Profile - Posts by andy_k_250
Pages: « 1 2180 181 182 183 »
For some reason, I really like it! I did think of one thing though... any way to have it display maybe three ch-ching coin-out-the-top-of-a-block extended sprites and add these to the total in addition to the rolling coins?

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Here is a much improved version of Jagfillit's block that activates with thrown sprites. If someone can upload it to replace that one, please do. I've been too lazy. Sorry.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
So, at some point something changed with my hack to where custom music used across multiple connected levels will restart at each level load. Meanwhile, the game seems to be ignoring custom level times. Since these are both included in the same menu in Lunar Magic, I figure these two issues could be related. I'm honestly not sure at what point this happened yet; I'll be going through my backups to check. Anyone know what I might have done to my hack?


Edit: It appears that the only patches I've applied between my last correctly functioning backup and now are the Bounce Block Unrestrictor and the Sprite Initial Facing Fix. I am using HuFlungDu's version of Romi's AddMusic. This problem has never presented itself before.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Cross-posting this so long as it's not a big deal.

So, at some point something changed with my hack to where custom music used across multiple connected levels will restart at each level load. Meanwhile, the game seems to be ignoring custom level times. Since these are both included in the same menu in Lunar Magic, I figure these two issues could be related. I'm honestly not sure at what point this happened yet; I'll be going through my backups to check. Anyone know what I might have done to my hack?

Edit: It appears that the only patches I've applied between my last correctly functioning backup and now are the Bounce Block Unrestrictor and the Sprite Initial Facing Fix. I am using HuFlungDu's version of Romi's AddMusic. This problem has never presented itself before.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
It's definitely not a matter of sprite buoyancy, though thanks for the heads up on that. It's funny how there are always these little tiny glitchy things.

HuFlungDu -- I did try your recommendation of changing the level music to 00, and it does allow for the level music in one portion to continue, but then when I return to the main level the music restarts.

Also, it's worth reiterating that this is an issue that is not present in earlier versions of this level -- it's only a recent occurrence. If you don't mind, I'll pm you with links to my files.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Here is some praise for you. I'll take the opportunity to say again that I really hope all the ZSNES users will adopt this instead because it's demonstrably better in almost every aspect.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
HuFlungDu was able to determine the nature of this bug. All in all, it was thankfully a fairly simple fix, but one that might not necessarily be immediately evident.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
HuFlungDu was able to determine the nature of this bug. All in all, it was thankfully a fairly simple fix, but one that might not necessarily be immediately evident.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Thanks so much for locating this issue. Ultimately, it's something that was fairly simple, thankfully, but it's something that might not have been immediately evident. Does FuSoYa note which RAM addresses he dedicates to LM processes, or is that something we determine in reverse?

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Hi all. I've been fiddling with which bounce blocks the blocks in my hack use and I'm having some trouble. When I edit the entries in the table at $00F05C in a clean ROM, the entries are editable, but when I try to edit them in my ROM, it doesn't work.

The only relevant patch I can think of that my hack uses that might affect this is the Bounce Block Unrestrictor; however, when I apply this to my clean test ROM, I can still edit $00F05C as normal.

Anyone know of any other patches that might redirect around $00F05C, or why my table might be uneditable and yet still somehow function? It almost seems as if God doesn't want me to be able to use different bounce block tiles the table has been somehow duplicated and relocated in my ROM. No idea why that would be though.


Guh. Turns out that I had applied the All Switch Blocks Have Power-Ups Patch, which apparently redirects and replaces all of the game's bounce block related tables. Not sure if a stronger notice that this effect takes places is warranted with that patch, but it might be worth considering since the patch itself is a little vague about what it is doing.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
So, I've been trying to figure out how to make the SMB2 POW Block sprite that comes with ICB's SMB2 Block Pack activate when it hits other sprites (besides just activating when it is dropped/thrown and hits a wall/floor. I'm not sure if there is a simple solution or if it will require some custom sprite-sprite interaction code. Any guidance/assistance is much appreciated. The relevant sprite code is below.

Code
DYING	
                    STZ $B6,x
                    STZ $AA,x
		RTS

SPRITE_ROUTINE	JSR SUB_GFX
		LDA $14C8,x		; \  return if
		CMP #$02		;  | sprite status
		BEQ DYING		;  | is < 8, or
		CMP #$08		;  | branch to death
		BCC RETURN		; /  handler if dying
		LDA $9D			; \ return if
		BNE RETURN		; / sprites locked
		JSR SUB_OFF_SCREEN_X0	; only process sprite while on screen

		LDA $1588,x		; \  if not hitting
		AND #%00000111		;  | wall, then skip
		BEQ NOHITWALL		; /  this next code

KILL
	lda #$28			;shake ground
	STA $1887

        jsl $00FA80		;kill sprites, turn to coins
        LDA #$16                ; \ Play sound effect
        STA $1DFC               ; / 
		LDA #$02		; \ make sprite
		STA $14C8,x		; / start dying

NOHITWALL



RETURN		RTS


--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Originally posted by WhiteYoshiEgg
Try sticking a JSL $018032 at the beginning of the main routine - that should be enough to make it interact with other sprites, and if you're lucky, hitting another sprite will be treated like hitting a wall and thus trigger the POW effect.

Well, adding the JSL doesn't hurt anything, but it also doesn't change anything. The POW Block sprite already interacted with sprites by default; it dies in a puff of smoke when it hits them and kills them too. That's why I think something more might be necessary, but what that would be is beyond me.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Which sprites did you test it with?

After looking into it a bit more, it seems to vary in its behaviors based on which sprite it is interacting with and how the sprite is being touched. This may be why I thought it wasn't working before. For instance:
- By default, when I throw it at sprites from below, it collides and both disappear. When it is thrown from the side, it sometimes kills the sprite and goes through and hits the ground.
- When edited in the way you suggested here, it will not activate whether it is carried into or thrown at Koopa Troopas. It will activate when thrown at Goombas. Piranha Plants sometimes activated the POW kill when hit by the sprite, but other times would just disappear along with the unactivated POW.

So, something funky is going on with it. Have any other thoughts?

Originally posted by WhiteYoshiEgg
I've just given the POW a try, and it does what you want it to do by default - kill all on-screen sprites when it hits one of them.

...checking again, though, when it hits a sprite while still being carried, it does end up only killing that one. I take it that's what you want to get rid of?
In that case, changing the BEQ DYING to BEQ KILL should do the trick.


--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
A couple newer things from my hack:




That last screenshot I've shown before, but this one features a custom Toad (the Toad) sprite I made based on his Super Mario Bros. Super Show appearance. This way he'll stand apart (better) from other Toads.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
UPDATE: Well, I installed Firefox 19 (the version from about nine months ago or so) and the BG Ripper functions correctly in it. So, I'd like to verify that something that has been updated in recent browsers is what has led to the broken functionality.

Hi all. I'm hoping that someone might be able to verify that the BG Ripper is currently partially broken. First of all, here are the current mirrors:
BG Ripper (p4plus2's Mirror)
BG Ripper (Alcaro's Mirror)

In any event, lately I've noticed that after I load in a savestate I can't change which layer is selected. I also can't scroll the background by adjust the x/y scroll values. Last but not least, adjusting other values sometimes results in previous settings "sticking" (e.g. I'll make the BG 256 pixels wide, then change it back to 512, but 256 pixels are still shaded.)

So, in short, something with the BG Ripper seems to broken from my end. I have tried this with three different machines using multiple types of savestates, so I really don't think I'm doing anything wrong, but I wanted to make this thread to see if anyone else has been having these same problems. If anyone can shed some light on this, it is much appreciated.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Well, at the very least, now we know it's a shared issue. Thank you for verifying that it's not just my issue. I had been worried it was just my machine/browser becoming incompatible for some reason.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
(restricted)
I have tried using both Firefox and Internet Explorer. Maybe it's the browser versions I am using. I'm on 23+ on Firefox on every system I've tried. I have no idea what version IE is because it sucks.

EDIT: Well, I installed Firefox 19 (the version from about nine months ago or so) and the BG Ripper functions correctly in it. So, I'd like to verify that something that has been updated in recent browsers is what has led to the broken functionality.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
(restricted)


Here is a custom background that I just finished for someone. It’s the first background I’ve drawn from scratch and I’m pretty happy with how it turned out so I thought it might be worth sharing. It’s based on some background graphics in World 4 of Newer Super Mario Bros. Wii, so all the credit for creativity goes to them

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
Pages: « 1 2180 181 182 183 »
andy_k_250's Profile - Posts by andy_k_250

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks