Banner
Views: 934,023,939
Time:
8 users online: detdu, dirty, margot, medrano, Mohamad20ZX, OEO6, Splat3r, tcdw - Guests: 57 - Bots: 184 Users: 52,112 (2,123 active)
Latest: bob_ahhh123
Tip: The "Edit Animation Settings" tab in Lunar Magic is very convenient if you want to disable certain animations in the game to make room for your own graphics or ExAnimations.
Not logged in.
Details for Bomb blocks (from the kirby series)
SMW Blocks - Bomb blocks (from the kirby series) Link - Show random
File Name: Bomb blocks (from the kirby series)
Added:
Version History: View
Authors: HammerBrother
Act As: Various
Includes GFX: Yes
Description: Ever wanted a kirby-styled block remover/changer gimmick in your hack? Well now you can! If the player triggers the bomb block, it will spawn a custom sprite that wipes out all the adjacent blocks one by one (on each explosion). See the readme for more info.

Oh yeah the tool for the explosion sprite is romi's spritetool 1.40 or higher.

the animated image below was made by me using licecap.

UPDATE: Fixed a buoyancy glitch. Address $019138 affects the sprite's interaction, causing strange teleportation when it shouldn't be (like destroying 1 block above the explosion).
Tags: bomb, kirby, lorom, puzzle, secret
Rating: 4.7 (Votes: 7)
Download: Download - 232.17 KiB
763 downloads
Screenshots
Previous 
 Next
Black Goku
Originally posted by Fermín Acosta Jr.
Originally posted by rvx
The explosion sprite isn't compatible with PIXI and SA-1 hacks :(


I could do sa-1 compatible for sa-1 convert and Romi’s SpriteTool to PIXI through Trashkas


You have to remap two addresses that cannot be converted with sa-1 convert to give it full support with sa-1 (In the sprite, the block can be converted to sa-1). .
Posted by: Black Goku - | Link
Fermín Acosta Jr.
Originally posted by rvx
The explosion sprite isn't compatible with PIXI and SA-1 hacks :(


I could do sa-1 compatible for sa-1 convert and Romi’s SpriteTool to PIXI through Trashkas
Posted by: Fermín Acosta Jr. - | Link
rvx
The explosion sprite isn't compatible with PIXI and SA-1 hacks :(
Posted by: rvx - | Link
Fermín Acosta Jr.
Make Pixi Compatible and SA-1
Posted by: Fermín Acosta Jr. - | Link
HammerBrother
Feel free to update this if you need to (including re-uploading this for fixing/future tool replacement purposes).
Posted by: HammerBrother - | Link
Galeth
Assembling the sprite required for the blocks to work has no side effects (yet) if you use PIXI.
Posted by: Galeth - | Link
DiscoTheBat
This is a really nice concept and it has been pretty well made. I liked it!
Posted by: DiscoTheBat - | Link

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks