Banner
Views: 844,364,872
Time:
17 users online: Aram, Coockie1173, Dippy,  JamesD28, Jern, JRock96, MarioFan22,  MarioFanGamer, Nint, oderjunks, OEO6,  RussianMan, Rykon-V73, shane, SuperDyl13,  Telinc1, Zidan3 - Guests: 33 - Bots: 65 Users: 46,421 (2,764 active)
Latest: Glitch23
Tip: Stay up-to-date with new tool and resource releases on the SMW hacking scene by viewing this forum.Not logged in.
Details for PIXI v1.2.1 - Sprite Insertion Tool
Tools - PIXI v1.2.1 - Sprite Insertion Tool Show random
This file is obsolete. The latest version is PIXI v1.2.15 - Sprite Insertion Tool. For other versions, check the version history.
File Name: PIXI v1.2.1 - Sprite Insertion Tool
Added:
Version History: View
Authors: JackTheSpades
Operating System: Windows
Platforms: SNES
Games: SMW
Source Available: Yes
Featured: Essential
Website: Link
Description: A sprite insertion tool made to allow more dynamic sprite usage, space savings and more SA-1 compatibility when compared to old iterations.
Despite this, it is almost fully compatible with sprites written for older SpriteTools, save for the fact that Asar is now used as the assembler.

Detailed usage instructions, common errors and changes compared to older sprite tools can be found in the included readme.txt file. Version history can be found in changelog.txt.


For more information, read here.
Source code can be found at GitHub.
Tags: cluster, extended, insert, inserter, insertion, sa-1, sprite, sprite tool, spritetool
Rating: 5.0 (Votes: 3)
Download: Download - 16.86 MiB
1,665 downloads
Screenshots
Previous 
 Next
Circus Charlie
@JackTheSpades
I would prefer it to be a new version because it does not work with me, something needs to be improved
Posted by: Circus Charlie - | Link
Activisor
how do you use it
Posted by: Activisor - | Link
Activisor
how do you use it
Posted by: Activisor - | Link
Elie Barnes
until these bugs are fixed, i'm sticking with spritetool
Posted by: Elie Barnes - | Link
obersteiner86
If i insert are sprite with it my game starts but i dont see mario and it freeze at the title screen i us are sa-1 rom
Posted by: obersteiner86 - | Link
smwgohken
All sprites crash when they create projecttiles for create a custom sprite!
Posted by: smwgohken - | Link
gblake90
Does anybody have a tutorial to this... and in ENGLISH?!!!
Posted by: gblake90 - | Link
Major Flare
%Star() still misses its necessary PHB : PHK : PLB and PLB in order to correctly access the tables.
Posted by:  Major Flare - | Link
Yuzu
Edit: Solved a bug with the Lastest of Powerups v3.0.4 without Defs but inserting without problems
Posted by: Yuzu - | Link
kamekku14
And what about the Display features? Is it fixed yet?
Posted by: kamekku14 - | Link
Kiatus
I'm going to port everything of my rom to a new one because i had a very old version of pixi. But yeah, i hope this version has no problem with "broken" cluster sprites.
Posted by: Kiatus - | Link
RPG Hacker
The only thing that has changed is a single sub-routine, so I think it should be no problem. Make sure to backup your ROM before you try it.
Posted by:  RPG Hacker - | Link
toad64
can i use PIXI 1.2.1 with my rom that has PIXI 1.2 in it.

Test it if work or not?
Posted by: toad64 - | Link
RPG Hacker
No code changes to the application itself were made between 1.2 and 1.2.1, so sure, if you use the old version, it will behave just like version 1.2. Is there a good reason to do that? (Something broken with the new version?)
Posted by:  RPG Hacker - | Link
toad64
Can i use the old PIXI 1.2 version of suboffscreen.asm and replace the PIXI 1.2.1 version of Suboffscreen.asm?
Posted by: toad64 - | Link
RPG Hacker
Mod's note: made some minor adjustments and bumped to version 1.2.1. Changes are listed in changelog.txt.
Posted by:  RPG Hacker - | Link
zacmario
I can't not get my custom sprites displayed in lunar magic! This is driving me fucking insane! Why won't they show!
Posted by: zacmario - | Link
Mariofan64
awesome
Posted by: Mariofan64 - | Link
Erik
The display features barely work:
- Load m16 does nothing.
- Neither does Load GFX33.
- I assume the 8x8 Tile Selector would allow me to make my custom map16 tiles, but I can do nothing in it.
- Changing to 8x8 mode in both windows still only pastes 16x16 tiles, and no, I can't remove one by one, I can only remove the 4 or nothing.
- Who should I pray for this to save?
- You can't use the mousewheel to scroll.
-

with all due honesty never touch this again unless you plan to stick around, be responsive to the bug reports and keep up with our own progress in the pixi fork.
Posted by:  Erik - | Link
MarcStar Hacks
I'm stupid, I couldn't find the download. Lol
Posted by: MarcStar Hacks - | Link
toad64
can you give me a image of the run the tool via command line?
Posted by: toad64 - | Link
TheBiob
You need to run the tool via command line if you want to disable them.

Code
pixi.exe -npl <rom name>
Posted by: TheBiob - | Link
toad64
I can't find the way to disable per-level sprites insertion?
Posted by: toad64 - | Link
Telinc1
This version adds an option to disable per-level sprites insertion, which fixes the softlock. The option is not enabled by default, so running PIXI normally will not fix anything.

Potential resolutions (rather, workarounds) have been found and are being tested for inclusion in an unofficial future version of PIXI.
Posted by:  Telinc1 - | Link
toad64
Version 1.2 still has the softlock.
Posted by: toad64 - | Link
Mogu94
Been looking forward to this.
Posted by: Mogu94 - | Link
Konata Izumi
custom appearance support? O_O
besides that, what else, and is the softlock bug fixed?
Posted by: Konata Izumi - | Link

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy