Banner
Views: 790,118,890
Time:
15 users online:  Aja, Cheolpeoduck, CONLUSH666,  Deeke, FailSandwich, Golden Yoshi, Haithius, Isikoro, proppi, SquidMan_Raps, thejhonny-ador,  Tob, WhiteYoshiEgg, Yagami, yogui - Guests: 48 - Bots: 175 Users: 41,245 (1,495 active)
Latest: proppi
Tip: Proofread your message boxes for spelling and grammar mistakes.Not logged in.
Details for Lunar Magic 3.10
Tools - Lunar Magic 3.10
File Name: Lunar Magic 3.10
Added:
Version History: View
Authors: FuSoYa
Operating System: Windows
Platforms: SNES
Games: SMW
Source Available: No
Featured: Essential
Website: Link
Description: This is THE required tool to hack SMW.

This version of Lunar Magic fixes a couple crash bugs in the editor along with adding a few other minor tweaks and fixes.

Check the "What's New" section of the help file for more info.
Tags: editor, level editor, lorom, lunar magic, sa-1, super fx
Rating: 5.0 (Votes: 1)
Download: Download - 1.27 MiB
1,532 downloads
Screenshots
Image
Shiny Ninetales
Originally posted by Romano338
I don't recall seeing a hack using the LM3 features!

Yeah, it will took a while to people to get used to the new features, since they are big (exlevels and stuff). It kinda happened with Layer 3 when it got handled by LM, and even nowadays I think people don't explote it that much (in my opinion), but it could be the lack of Layer 3 varieties in the graphics section (or because it's still a mess to handle Layer 3 with the vanilla status bar, which seems to be the prefered status bar for most people, or at least the rookiest hackers).
Posted by:  Shiny Ninetales - | Link
h.carrell
i'm still using 3.04 for my hack
Posted by: h.carrell - | Link
FadyHosny
Great one, Thanks.
Posted by: FadyHosny - | Link
Romano338
Nice, thanks for your answer! I wasn't too sure because I don't recall seeing a hack using the LM3 features!
Posted by: Romano338 - | Link
lx5
Originally posted by Romano338
Is LM 3.xx ready for use? Like, is it compatible with enough stuff (or are enough stuff compatible with it)?
I remember when it came out obviously some stuff weren't useable so it was adviced not to start on 3.xx


that was an horrible way to welcome LM3.01 when ot came out, people worked hard to fix most of the incompatibilities that the update may had with major tools and patches (GPS, PIXI, SA-1 and my Custom Powerups patch), and shortly after people began fixing other minor stuff that also broke; this didnt last very long.

i believe this update is compatible with most of the resources publicly available, even complex patches that make use of layer 3 such as the minimalist status bar and smb3 status bar (the latest update btw!), these are confirmed to be working fine. i've yet to test it with vwf dialogues, but i really doubt that it will be incompatible as it only replaces and restores the tilemap automatically.
Posted by:  lx5 - | Link
Romano338
Is LM 3.xx ready for use? Like, is it compatible with enough stuff (or are enough stuff compatible with it)?
I remember when it came out obviously some stuff weren't useable so it was adviced not to start on 3.xx
Posted by: Romano338 - | Link
Major Flare
Tested within Windows 10, and used cmd.exe for the command-line options.

Well, it is certainly an update worth of LM's 19th anniversary. The new Layer 3 features are a nice touch; however, one has to deal with SMW's limitations, since some settings done within Lunar Magic will cause strange things to happen in the game (like the status bar cutting into layer 3). Since those issues are not due to the tool itself, and I did not found any relevant crashes either (I've been using it consistently since Eevee uploaded it in my last moderations or code testing in general, and so far so good), I'm going to accept this.
Posted by:  Major Flare - | Link
Hayashi Neru
Originally posted by Shiny Ninetales
I only need BG4 and BG5... but updates like this are nice too.

BG5 is not in SNES. However, if use Parallax(HDMA), can express it similarly.
Posted by: Hayashi Neru - | Link
7 up
I wasn't serious! I only wanted to say this gets updates slightly more often than right before 3.0 has been released.
Posted by: 7 up - | Link
AntiDuck
All I'd really like is easier support for other BG modes, like Mode 0 or Mode 3 for better support for ExGFX Revolution stuff. So that can be revived and easier to use.
Posted by: AntiDuck - | Link
Shiny Ninetales
I only need BG4 and BG5... but updates like this are nice too.
Posted by:  Shiny Ninetales - | Link
AntiDuck
Maybe we should go back to 1.63?
Posted by: AntiDuck - | Link
lx5
based fusoya for a new update
Originally posted by 7 Up
How many updates does this shit need?

unbased 7 Up for not wanting more updates
Posted by:  lx5 - | Link
kiki79250
Originally posted by 7 Up
How many updates does this shit need?


beacause It's THE editor for hack SMW, updates are here for bug fixes and new features
Posted by: kiki79250 - | Link
King Mayro
Thank you, this makes my SMW hacking a lot easier 11/10
Posted by: King Mayro - | Link

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2019 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 7

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • SMBX Community
  • ROMhacking.net
  • MFGG