Banner
Views: 926,938,249
Time:
16 users online: Alex_X8,  Anorakun, BootaNoBijuu, buckaroodle610, chaves12zzz, detdu,  Eevee, Golden Yoshi, gui, Infinity, Jimmer, kellykelster,  Lazy, Paperdomo101, Rykon-V73, WhiteYoshiEgg - Guests: 66 - Bots: 105 Users: 51,806 (2,055 active)
Latest: datnonameboi
Tip: If you make a change to your ROM that you regret, just go to File > Restore > Restore ROM to Previous State in the menu. From there, you can select a restore point and revert your ROM to a previous state.
Not logged in.
Details for Elevator
SMW Sprites - Elevator Link - Show random
File Name: Elevator
Added:
Version History: View
Authors: Sukasa
Tool: PIXI
Type: Standard
Dynamic: No
Disassembly: No
Includes GFX: Yes
Description: This is a 32x48 elevator sprite. The player can control it with the D-Pad while standing on top of it. Its speed is configurable.

I'm amazed I changed this sprite.

(Rykon-V73): Small changes: Converted the 2 .cfg files to .json and tilemap and palette can be edited easily.
Also added a .gif.
Tags: elevator, lorom, pacifist, sa-1
Rating: No rating
Download: Download - 9.38 KiB
248 downloads
Screenshots
Previous 
 Next
KevinM
Small update: fixed an issue that sometimes caused bounce sprites (most notably, turn blocks) to act weirdly when using this sprite.
Posted by: KevinM - | Link
colablues
Me again (yes I know I'm boring)
I just finished testing this Sprite with all the PIXI versions, unfortunately the result remains the same!
After Insertion and implementation, ALL the BGs of my Rom
becomes corrupted on the MAP16 from 90 to 9F!
But I fixed the problem and the Sprite works perfectly!
It sounds obvious, but I can't repeat it enough:
before any Sprite insertion
(and even more patch or other music)
zip or rar your Rom (it takes 30 seconds)
and only work on a copy!
As far as I'm concerned and the problem encountered,
luckily Lunar Magic has the option that saved my life: the complete export of the Map16!
Result,
everything is back to normal and I can play with this great Sprite! But I still do not explain where the problem comes from?
Thank you if you find you and especially if you take the time
to explain it to me, because I love to learn, even at 43 years old!
Posted by: colablues - | Link
colablues
Continuation of my previous message:
I don't understand anything anymore, I just started again,
and the same problem arises, except that there,
I took my trouble patiently (I took my map16 backups),
So I put everything back my map16 from 90 to 9F without removing the sprite!
So everything came back ok at the level of the corrupt BGs, and surprise,
i just played with the sprite correctly!
I do not understand anything ! I noticed that after applying the Sprite
with Pixi (version 1.31), each Map16 from 90 to 9F,
they had been covered by emptiness of green color
for the most part ! So this will be a Pixi bug?
I wonder if I will not try with an old version to see!
I would like to update my post!
Posted by: colablues - | Link
colablues
Hello, I would like to report a BIG problem that I just encountered after applying this sprite ...
Certainly I'll be able to get by, but we should bring
explanations or corrections because I will surely not have
be the only one who this BIG problem happens to!
The sprite works beautifully, BUT ...
After application of the sprite with PIXI without error,
ALL my level using as BG the MAP16 from 90 to 9F
have been deleted from MAP16!
I find it curious and I understand nothing and find nothing
in ASM files. I did all my tests
before applying the sprite and everything is perfect!
But as soon as I apply it, the problem happens!
So for me the conclusion is NEVER again
used the MAP16 from 90 to 9F, which is a lot anyway!
But no choice, I like this beautiful sprite too much
which I repeat worked wonderfully!
Posted by: colablues - | Link
JamesD28
Tested with:

• Lunar Magic 3.11
• SA-1 Pack v1.32
• PIXI v1.2.15
• Snes9x v1.60

Works as intended, so, update accepted. During moderation I fixed a small issue with elevator_slow.json where the slow elevator was named as fast.
Posted by:  JamesD28 - | Link
Brutapode89
Oh great! We can use it like in Zelda II: The Adventure of Link.
Posted by: Brutapode89 - | Link
HammerBrother
Feature request: Have the elevator be restricted to specific stop points rather than be able to stop anywhere by the player. This can be archived by taking the sprite's XY coordinate, add/subtract by a certain value, get block number, and if it matches with a given block number, get that position, keep the sprite going until it is aligned with the block and then it stops at that coordinate.
Posted by: HammerBrother - | Link

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks