Banner
Views: 932,719,324
Time:
9 users online: codfish1002, doctor1, ForthRightMC, Koopster,  MarioFanGamer, Parahax, Retro Master HD,  sincx, Supertails - Guests: 115 - Bots: 371 Users: 52,062 (2,107 active)
Latest: Reissman
Tip: Use Kipernal's Blockreator if you want to code custom blocks but you have little to no experience with ASM.
Not logged in.
Details for AddmusicK 1.0.8
Tools - AddmusicK 1.0.8 Link - Show random
File Name: AddmusicK 1.0.8
Added:
Version History: View
Authors: Kipernal
Operating System: Windows
Platforms: SNES
Games: SMW
Source Available: Yes
Featured: Essential
Website: None
Description: A tool used to insert custom music into Super Mario World. This tool is completely hardware compatible and is designed with ease-of-use in mind. This tool supports both songs made for Addmusic 4.05 as well as AddmusicM with minimal tweaking.

Please read the readme for more information.

1.0.8:

(KevinM): added my "Better Pause" fix to prevent songs that use long notes/legato from breaking when pausing. Also removed Medic's pause fix from 1.0.7 since it's obsoleted by this change. Do note that a new SFX was added in slot $2C in $1DF9, make sure you don't change it!

1.0.7:

(Lui): Fixes an issue with hardware timing after uploading SPC data

(Medic): This version fixes the bug where the music would break sometimes when pausing and unpausing **IMPORTANT NOTE: This adds a new freeRAM !FREERAM_FIX_PAUSE used in the asm\SNES\patch.asm which may need to be checked for conflicts** (removed in 1.0.8)

(Vitor): Added a fix for bank crossing issues on large SA-1 roms

(Medic): This version fixes the bug where AMK would break the credits music.

(KungFuFurby): This version alleviates some of the slowdown caused by higher tempos and/or frequent pitch bends.

1.0.6:

(Medic): This version fixes the bug that caused random music to play after the P-switch timer ran out on accurate emulators while using the SA-1.

(HertzDevil): This version fixes the issue where certain error messages do not show up in the AddmusicK GUI, especially the one about missing sample groups.

Tags: addmusic, amk, brr, brr samples, inserter, music, sa-1, samples
Rating: 5.0 (Votes: 3)
Download: Download - 2.03 MiB
6,994 downloads
Francium
The vanilla background music that comes with this tool is partially incomplete.#smw{>_>}
Posted by: Francium - | Link
Mapping_bl
thanks
Posted by: Mapping_bl - | Link
KevinM
Originally posted by Xboy1282
It's fine on a vanilla ROM but I made a patch to change the music at 99 seconds and it crashes when Mario dies ik it's not the patch because it works fine with vanilla music how do you fix it?

Your patch probably hijacks the same spot as one of AddmusicK's edits. You can check in the hijack map.
Posted by: KevinM - | Link
Xboy1282
It's fine on a vanilla ROM but I made a patch to change the music at 99 seconds and it crashes when Mario dies ik it's not the patch because it works fine with vanilla music how do you fix it?
Posted by: Xboy1282 - | Link
SimFan96
Sorry about posting too many comments, but I wanted to report that if you use #am4 and the #pad command, you cannot pad the song out by more than 2 digits, everything after the first 2 digits of the value give an error in AMK and only the 2 first digits will be read. Just wanted to report that issue!
Posted by: SimFan96 - | Link
TheXander
I need help! I am new to this page and I am having problems With AddmusicK, when I try to use my Rom to insert Custom Music, it tell me the following:

ERROR: Couldn't not find "Mainloop_pos "
Press "ENTER" to continue...

I have no idea what is happening, I have checked and verified that everything is fine, and everything is fine and is keep coming out.

I have used the AMKGUI, but it did not insert anything... so I concluded that some AddmusicK files had been damaged... I downloaded otros again, I did everything like this in the README but I still gen this error, any help would be very appreciable, and I really don't know what to do With this problem...#smw{<_<}
Posted by: TheXander - | Link
SimFan96
Just wanted to post a bug I found, occasionally when you're in a situation that has heavy sfx usage such as grinders, saws, some custom sprites (I'm assuming they are all using $1DF9 sounds) and pause the game then unpause, the game will be muted. You can correct this in-game by pausing/unpausing again or dying/exiting the level. Small issue but I just wanted to make note of this!
Posted by: SimFan96 - | Link
Pokemon Hacker
We need that custom music, because without it the romhack has no soul
Posted by:  Pokemon Hacker - | Link
Anas
I noticed that the UberASM code provided by AMK for enabling echo on SFX doesn't fully work; if a global songs plays and ends afterwards, then the echo may not affect SFX at all or after a few seconds in the song in the level with echo. Try this instead.
Posted by: Anas - | Link
quietmason
Originally posted by Atari
I used this tool to insert a sampled track into my ROM to test it out and it worked, though I realized all SFX didn't sound as great anymore.
Afterwards I noticed when Castle 1 is completed, during the castle destruction scene the game totally freezes for about 1 sec when the castle is halfway destroyed.
I played on to Castle 2 that has a slightly different destruction scene, yet the exact same 1 second freeze occurs at the exact destruction point of the castle, when it is halfway going down into the ground.(I didn't test any others)
It appears that it is linked to me using this tool so I reverted back until I learn more of why this is happening.
I don't need the castle cutscenes in my ROM but I am concerned in case there are other problems as well I don't know about that may affect the ROM down the line.
Does anyone know about this issue?


This is due to the fact that it takes the SNES (or emulator) some time to locate and load up the correct set of samples to use, especially if the sampled port you've inserted omits some of the vanilla samples. Or, if you mean that you're transitioning between two different sampled songs, it will definitely take some time to switch samples. This can also be observed at the end of levels in Casio Mario World, where Mario freezes for a second before grabbing the goal tape (that's when the right samples are loaded for the ending theme). It's not really an issue that's feasible to fix.
Posted by:  quietmason - | Link
Atari
I used this tool to insert a sampled track into my ROM to test it out and it worked, though I realized all SFX didn't sound as great anymore.
Afterwards I noticed when Castle 1 is completed, during the castle destruction scene the game totally freezes for about 1 sec when the castle is halfway destroyed.
I played on to Castle 2 that has a slightly different destruction scene, yet the exact same 1 second freeze occurs at the exact destruction point of the castle, when it is halfway going down into the ground.(I didn't test any others)
It appears that it is linked to me using this tool so I reverted back until I learn more of why this is happening.
I don't need the castle cutscenes in my ROM but I am concerned in case there are other problems as well I don't know about that may affect the ROM down the line.
Does anyone know about this issue?
Posted by: Atari - | Link
GaloombaCat
i like this
Posted by: GaloombaCat - | Link
MarioSonic4life
Originally posted by Nara Sherko
When I type the rom name it says
Code
ROM not found.
Press ENTER to continue...


There are 2 simple solutions to that issue.

1. Drag and drop your rom into the same folder as the executable you're trying to use and then type your rom name in the cmd window.

2. Drag and drop your rom into the cmd window. (Much simpler imo)
Posted by: MarioSonic4life - | Link
SimFan96
Hello there! First of all, awesome job at updating this to fix the slowdown for songs that have high tempos, it's been great to have more songs that do not suffer from this issue anymore!

I did want to report a bug. Some of the songs on the site that are usually used as global songs have echo in them.

What happens for example is if you're playing a level that has music that has no echo, or has a lower echo buffer than the global song with said echo. Once the global song starts playing, there is a small pause when the global song plays which is sometimes accompanied with staticky/crackling noises.

Either that or if you are using a custom starman song that has echo in it, once you lose your star power and the regular level's music plays, the music will either majorly glitch or the music engine will crash, therefore causing the game to crash there or by the next time you exit a level. This doesn't happen when the level' echo buffer matches the same value as the one's with the global song.

Just wanted to inform you about this issue!
Posted by: SimFan96 - | Link
Nara Sherko
When I type the rom name it says
Code
ROM not found.
Press ENTER to continue...
Posted by: Nara Sherko - | Link
BootaNoBijuu
It there's a way to Disable the better music pause?
Posted by: BootaNoBijuu - | Link
KevinM
Originally posted by StackDino
When I press start+select quickly (almost at the same time), to leave the level, the song still plays.
A good idea is to use the noise clock mute flag to pause the music instead of backup the echo volume and lowering the master volume.

You're right, that way is much better so I'll update the sfx (although it doesn't solve the issue when doing start+select quickly).
Edit: found out how to fix it, so thanks for reporting the issue.
Posted by: KevinM - | Link
StackDino
When I press start+select quickly (almost at the same time), to leave the level, the song still plays.
A good idea is to use the noise clock mute flag to pause the music instead of backup the echo volume and lowering the master volume.
Posted by: StackDino - | Link
brickblock369
Okay good! Now I don't need to add a reminder about adding the "better music pause" patch
Posted by:  brickblock369 - | Link
KevinM
After some people requested it, and in agreement with the music mods we decided to integrate the pause fix in AMK so porters don't have to worry about pausing breaking their songs. Also the fix has been slightly improved from the standalone patch version (the song won't play for a brief second when exiting a level with start+select).
Posted by: KevinM - | Link

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks