66 users online: 7 up, A-l-e-x-99, AmazingChest,  Anorakun, AntiDuck, autisticsceptile1993, Bad luck man, Blizzard Buffalo, BoBTF, CalHal, chickaDEE Magazine, Cr4zy, crm0622, Daizo Dee Von, Dark Prince, Darolac,  Deeke,  Doctor No,  E-man38,  Eevee, ElpoderosoBv, floppingcheepcheep, Green Jerry, Hat Kid, HD_DankBaron, Heraga,  idol, Incognito, Internet_Goblin, Isaque World, Kevin WAT,  KevinM, KiloMinimo,  Koopster, LeaderAngelo, Leozoppi,  lion, LOLRyan2006 the Goombud, lordkronos100, lucasfilm,  Maarfy, Magmatic, MDBattleFrog, meatloaf, Mogu94, MrDeePay,  Nameless, ninj, NoMoreStars, OrangeBronzeDaisy, Raidenthequick, RetroJunky.T, Rilla Roo, S.N.N., SammmUuU,  Scrydan, Soonstar, Super Maks 64, superbahweird,  Tahixham,  Teows, TheBiob, TheMorganah, Ultima, Yoshi Master, Yoshimaster96 - Guests: 87 - Bots: 265 Users: 45,650 (3,285 active)
Latest user: BlueBotBlues
Not logged in.
Pipe path not working
Forum Index - SMW Hacking - SMW Hacking Help - Pipe path not working
Pages: « 1 »
I'm trying to create a secret exit path that goes from a level to the Castle via two pipes placed in the submap. The path from the level to pipe 1 activates as normal after activating the secret exit, but the path from pipe 2 to the Castle doesn't work no matter what I do. No direction can be moved in, all I can do is take the pipe back to pipe 1. The path is connected properly and all paths and levels are set for the correct events.
I think what you're missing is you didn't enable a direction to move from pipe 2.
Basically, the event you activate on the level only enables you to move from the level to pipe 1, in order to move from pipe 2 to the castle, you need to enable movement from pipe 2 itself, by going into the "Modify Level Tile Settings" (#lm{owlevel}) for the pipe tile and checking the "Enable [Desired Direction]" box.

--------------------
My Youtube Channel
I already tried that and it didn't work. It's strange because pipe 1 still lets me move back to the level I came from, even without any "Enable direction" flags checked.
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Pipe path not working