Banner
Views: 827,957,218
Time:
17 users online: AnasMario130, Darolac,  dtothefourth, Eminus, ExONightZ, Holy Shinx, Ice Man,  KevinM, LOLRyan2006 Mario Fan,  Maarfy,  MarioFanGamer, OEO6, SmoothySmooth, SquidBoy20, SquidMan_Raps, Stivi, yoshiatom - Guests: 27 - Bots: 69 Users: 44,313 (2,531 active)
Latest: Veals
Tip: You can use the SMW Customizer to edit tons of misc. features in SMW, including the speed of Bullet Bills, how many points a 3-UP moon gives you, and more!Not logged in.
Easy Mode 7 Patch not working?
Forum Index - SMW Hacking - SMW Hacking Help - Easy Mode 7 Patch not working?
Pages: « 1 »
Hey guys, sorry if this is in the wrong spot, but I've been having some troubles with the easy mode 7 patch. I've been trying to apply the patch, however it gives me some serious troubles. First and foremost, when I initially apply the patch with no modifications, I get errors.

However, if I use Asar 1.5, the patch actually applies to the rom. However, next follows an exception right at the Nintendo Presents screen.


This is where I'm stumped. I've figured out the fix to this before, probably gonna figure this out 5 minutes after posting this but for the time being, i'm stumped. It doesn't seem to have any conflicting hijacks with anything else in the rom, so I don't think that'd be whats causing this. Any help would be greatly appreciated.
If by chance you've found out the solution to this could you share it. I'm having the exact same problem.
I'm wondering if it has to do with LM3 and later. The patch has not been remoderated and confirmed as to whether or not if it works with LM3 or higher. Since LM3 had new ASM stuff for the level expansions, requiring patches to be updated, examined and such.

I would love to know if I can use this patch myself.

--------------------
Китти печь книжной полке приливной волны


I'm not currently able to try it myself, but just looking at the patch it's because the author used a weird method of handling fastROM addressing that doesn't work with asar's autoclean function. Basically, remove all calls to the "remap_rom" function and just use the referred address directly; i.e. convert all instances of lines like this:

Code
org remap_rom($00988C)

to just:

Code
org $00988C


This should resolve the errors with current Asar at least. If you still get those errors of "autoclean used in freespace" or "address FFFFFF out of bounds", it's cause you missed one. Whether or not that fixes the crash bug though, not sure.
(make sure you test that with a ROM that the broken version of the patch has not been applied to)

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Originally posted by Thomas
I'm not currently able to try it myself, but just looking at the patch it's because the author used a weird method of handling fastROM addressing that doesn't work with asar's autoclean function. Basically, remove all calls to the "remap_rom" function and just use the referred address directly; i.e. convert all instances of lines like this:

Code
org remap_rom($00988C)

to just:

Code
org $00988C


This should resolve the errors with current Asar at least. If you still get those errors of "autoclean used in freespace" or "address FFFFFF out of bounds", it's cause you missed one. Whether or not that fixes the crash bug though, not sure.
(make sure you test that with a ROM that the broken version of the patch has not been applied to)

Downloading the latest version of the shared routines from RPG Hacker's github seemed to actually have fixed the problem with the remap_rom, the new problem is that after applying the patch, it still just crashes.

--------------------
Currently working on:
Super Kekcroc World 3
I managed to get it and the sample UberASM to work in a clean rom with just LM3.xx once. Are you using SA-1?

--------------------
linkies

im gay and a lion. I AM VERY POOR PROGRAMMER !!!
pixel art no hoper. transcriptions on a hot tin ear.
Originally posted by lion
I managed to get it and the sample UberASM to work in a clean rom with just LM3.xx once. Are you using SA-1?

Nope. Me and Darkbloom talked about this in private and darkbloom got it to work but when I reproduced the methods I still end up having the crash.

--------------------
Currently working on:
Super Kekcroc World 3
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Easy Mode 7 Patch not working?

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 16

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy