Banner
Views: 827,964,646
Time:
15 users online: Arobam, blocc, Darolac, Gregor, Ice Man, Ixitxachitl, kamekku14,  Linkdeadx2, LOLRyan2006 Mario Fan,  MarioFanGamer, orka-bln, Sariel,  Tahixham,  Tob, westslasher2 - Guests: 54 - Bots: 73 Users: 44,315 (2,531 active)
Latest: Lazyboy23w
Tip: You can insert custom sprites on the overworld by using Overworld SpriteTool.Not logged in.
UberAsmTool Error
Forum Index - SMW Hacking - SMW Hacking Help - UberAsmTool Error
Pages: « 1 »
Hey there! I'm trying to insert GreeenHammerBro's screen scrolling pipes. In UberAsmTool, I get this error message:
Code
Processing file 'FaceYoshi.asm':
  FaceYoshi.asm:28: error: (E5088): Define 'Freeram_SSP_PipeDir' wasn't found.

Not sure what that means or how to fix it, but if I take out "FaceYoshi.asm", then it complains that it's not there.
Can someone help me please?
Thanks! :)
Yeah those are blocks not uberasm you need gps

Actually I realized there is uberasm code and was thinking the yoshi ASM thing was part of the blocks.

Did you follow the readme it came with?
Yes. It just says "In the folder UberasmTool, the sub directory folders should be obvious of where should you put the ASM files in."

Why does it say
Code
Processing file 'left_horizontal_pipe_cap_B.asm':
  left_horizontal_pipe_cap_B.asm:121 (called from left_horizontal_pipe_cap_B.asm:121): error: (E5094): Macro 'FaceYoshi' wasn't found. [%FaceYoshi()
Ok let's make this quick:
These blocks are pretty complicated to set up.
There are a lot of different files you have to put into different folders and so on.
Your problem is not with uberasm but with gps.
In the folder "BlockRoutines" of the downloaded files you can see the file "FaceYoshi.asm". Copy this file to the "routines" folder of your GPS folder. Then it should work. (last sentence of 5.1 in the readme)
It's not a uberasm routine but a gps routine.

You should probably don't say this is a uberasm tool error when you are running gps (which I can tell because the error mentions the filename of a block and uberasm won't use those files when it comes to the screen scrolling pipes).
Edit: I don't even know why you would call "faceyoshi.asm" with uberasm (first error msg). don't do that. only do what is written in the readme.

--------------------
My Youtube channel

Currently working on:
Project C

Finished project:
Thanks NGB! It seems like it worked, but when I go into the ROM, all of the pipes don't interact with Mario! |-O Does anyone know why and how to fix it?
Thanks!
Are you sure you inserted the UberASM code and the blocks? It sounds like you may have forgotten to do one or the other.

Also, there's a patch included with the package that you should make sure to patch using Asar; it's the file called Fixes.asm (if you get the pipes successfully working, but only the ones with vertical entrances, you'll need to patch this file to make the ones with horizontal entrances work correctly).

Hope you're able to get the pipes working.
Hey, just for clarification, do I insert the .ASM files in "SSP_Tiles" with UberAsmTool?
I inserted Fixes.asm.
Originally posted by Ramenoodles
Hey, just for clarification, do I insert the .ASM files in "SSP_Tiles" with UberAsmTool?

You don't. As the name implies, these are tiles aka blocks and so they need to be inserted with . Not that it would work anyway since UberASM codes and blocks use different formats (e.g. different way of calling libraries / shared routines and different ways to determine the start of the code).

Originally posted by Ramenoodles
I inserted Fixes.asm.

That should be naturally done as only then the horizontal pipes work (+ some other bugfixes with the pipes which can't be solved with just blocks or UberASM).

--------------------
Okay, my layout looks ugly.
I inserted the sprite tile limit patch, inserted the UberAsm Files (ScreenScrollingPipes.asm, GM14.asm), inserted the blocks using Gopher Popcorn Stew (Everything in SSP_Tiles and FaceYoshi.asm), and put in the fixes patch, but he pipes still don't interact with Mario.
I have no idea what to do. Did I miss anything?
Does anyone know what could be the problem? |-O
Okay, I figured it out. Close the thing.
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - UberAsmTool Error

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 16

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy