Banner
The Questionable Level Design Contest ends in…
15 DAYS, 1 HOUR, 17 MINUTES AND 3 SECONDS
Views: 913,922,204
Time:
19 users online: Ahrion,  BeeKaay, Cal-of-Gearva, EpicBrave_YT, GrumpyWalrus, Jordan,  KevinM, le4che, Maw, MercuryPenny,  Nameless, NoMoreStars,  NopeContest, Not_Vinicius1, PlagueofDoom, PuffleDreemurr, quietmason, Spedinja, TheEPMaker - Guests: 71 - Bots: 87 Users: 51,189 (2,250 active)
Latest: FrickerMan23
Tip: After editing your overworld, make sure to use an EMPTY save file, as save files with progress may load Mario's position based on previous versions of the overworld. Note that altered level flags will also only take effect on new save files.
Not logged in.
Issue trying to use sa-1 and retry
Forum Index - SMW Hacking - SMW Hacking Help - ASM & Related Topics - Issue trying to use sa-1 and retry
Pages: « 1 » Link
Hi all, this is my 1st time posting, so please apologize if I posted in the wrong section or something of that sort.

I was having some slowness issues with my hack and found out about the sa-1 patch, that could sort that out.

So I patched it in a clean ROM (expanded to 4mb) and it worked fine.
However, when I install the retry patch, things start getting weird (I tried with and without bwram plus).
The Rom loads normally, but whenever I die, the whole screen glitches, showing a mess of random graphics. Also, when I reset and load my save file, the screen also glitches for a second, and then takes me to level 00.

I'm probably messing something up, but I have no idea what else to try.
Did you do this?
Originally posted by retry readme
- Make sure that at least (any) one of levels has a midway entrance with the option "Use separate settings for Midway Entrance" checked.

If not, do that then reapply retry and it should work out. Also make sure you start from a new save file.
Okay, that solved part of the problem, thank you for that!
Now the game doesnt glitch out when I die.
However, it's still breaking when I try to load the save file.

Do you have any clues what the reason might be?

And again, thanks for the help
As I said, you need to start from a new save file. If you already have one saved from before you applied retry and bwram+, erase it.
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - ASM & Related Topics - Issue trying to use sa-1 and retry

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks