Banner
The Overworld Design Contest ends in
1 MONTH, 2 DAYS, 7 HOURS, 46 MINUTES AND 5 SECONDS
Views: 898,301,296
Time:
11 users online: Abdu,  Anorakun, catboyjeremie, chickaDEE Magazine, Gamer2567_,  JamesD28, JefBueno, Marcozzo Daro, Mithrillionaire, MrDeePay,  PablosCorner - Guests: 59 - Bots: 136 Users: 50,409 (2,277 active)
Latest: aaabryan
Tip: Switch palace switches normally disappear if you replay the level. However, if you insert them as direct Map16 and use the hex edit at $00EEB2 in the ROM map, you can replay the level without a problem.
Not logged in.
I can't get samples to work in AddMusicK 1.0.8
Forum Index - SMW Hacking - SMW Hacking Help - I can't get samples to work in AddMusicK 1.0.8
Pages: « 1 » Link
Hiya, this is my first post here. I've been screwing around with addmusick for a while and I'm tired of using regular SMW instruments, I want to start using samples, however I've NEVER gotten songs with samples to import right. The console always says "so and so not included in song", and no matter what I try, inserting the sample into the samples folder, adding it to sample groups text file, I still get the same error. I'm currently trying to make a port of my own song and I'm getting this error. Can somebody help?

Edit: I've tried creating a folder in the samples folder and adding the sample I want, then adding #path "foldername" but even that doesn't work, it still says that the sample couldn't be found, no matter what I do or how I do it.
Is the text file's #path "Samplefoldername" matching the folder's name you have inside the "samples" folder?
I hope you've read this tutorial, the part about "sampled music".
Okay, so I figured it out: I, out of stupidity, put the sample (and its folder) that I want in the music folder and not the samples directory. At first I got an "instrument not defined" error but that was because I was using the wrong instrument number for my stuff. Everything, somehow, now works.

But now I'm having a different issue. I used @21 in my song and I think that's a kick drum, because that's what I'm getting out of it. What's a number I can use that can be counted as custom?

Edit 2: oops, I figured out that up to @29 are defaults. Trying @30.
Edit 3: I got @30 to play something, however it's super high pitched and, I dunno, shrill? What's a good tuning number?
Edit 4: Each note plays 1 semitone below what it should be, but I guess that's fine. The pitch will no longer make anyone's ears bleed.
Edit 5: I switched the sample and not only does it sound better but it plays the notes normally.
For future reference:
As for tuning SMW instruments, this section in Wakana's tutorial can help.
I think BRR Player can help you a bit with the correct tuning value in custom samples, though not every sample might help in the same way.
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - I can't get samples to work in AddMusicK 1.0.8

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks