Language…
7 users online: AjaTheVampire,  AmperSam, inuyasha-, Jaden1291 the Toad, Mr. MS, Samie Zuccati, snoruntpyro - Guests: 132 - Bots: 116
Users: 57,117 (2,271 active)
Latest user: NotGob

NPCs v4 Palette Bugs

I found 2 palette bugs in this sprite.

-----------------------------------------------------------------
Bug 1 with Normal Messages or Message Box Expansion



When I use another palette row in this sprite it always changes to the color that is in the palette row E when Mario is walking to another screen (sometimes the sprite is flashing like a Bob-Omb in any palette row when I use Message Box Expansion)


Bug 2 with VWF Dialogues Patch



I set the sprite to palette F, but whenever I press UP to generate a message, the sprite always changes to palette row E temporarily, and only returns to palette F when the message ends. (I put random colors in the palette E)
-----------------------------------------------------------------

How do I solve this?


Note: I made these 2 gifs in a clean SMW ROM
Did you edit something in the .asm file that had to do with the palettes? Because that may be the cause of the bug.

(Sorry for my bad language, i speak spanish and my english is more or less).


"Always be better, be respectful and kind to people".
Originally posted by Black Goku
Did you edit something in the .asm file that had to do with the palettes? Because that may be the cause of the bug.


Nope. I downloaded and inserted the sprite several times and the glitch remains the same.
It's definitely a bug with my code, but I don't have the time to look into it right now. Anyone who knows ASM is free to examine and update the sprite.


 
I had palette problems too.

However when I did set the palette in the asm-file to the one I used, the problems were gone. (I tried changing the palette in the cfg and use the Bypass in the html-file prior to that with no effect.)

Another glitch I noticed: When you enter a level via a pipe while the custom NPC is already on the screen it might use the wrong graphics.

In my case it briefly showed the graphics from SP3 top-left, which is by default the position where the graphics for the sprite would be located anyway, but I used the bypass for the walking frames to get the GFX from another position from SP3 and these only show up once you are out of the pipe.