Banner
Views: 926,143,973
Time:
11 users online: Amomario123w, AndreDK7,  Bench-kun, Ice Man, Klug, monkey03297, OEO6, Rykon-V73, simon.caio, TheBiob, Vash the fairytail - Guests: 108 - Bots: 88 Users: 51,767 (2,050 active)
Latest: Eaveslabet
Tip: Check this thread to find extremely useful diagrams and data.
Not logged in.
Effect Tool and/or UberASM issue (probably beginner level)
Forum Index - SMW Hacking - SMW Hacking Help - Effect Tool and/or UberASM issue (probably beginner level)
Pages: « 1 » Link
This makes me feel dumb because I figured out how to do this once upon a time, but it's been forever since I've attempted to use Effect Tool and UberASMTool and now it just won't work for me.

So, I'm trying to create a parallax effect, and I generate the code, paste it into an .asm file (test3.asm), and place it in the "level" subfolder. I edit list.txt to include 10C in the level asm list, and point it to test3.asm). I feel like this isn't where the problem lies; there are examples to follow and I've used other tools which rely on list.txt without any issue.

The Effect Tool code defaults the JMP code in line 17 to "level105_main" and warns "IMPORTANT! Please edit the JMP command below for the level you use this on". And, this seems to be where my roadblock is, because no matter what I do, I get an error.

- changing it to "level10C_main" on line 17 outputs
Code
test3.asm:15: error: (E5060): Label 'level10C_main' wasn't found. [JMP level10C_main:]


Changing it to simply "10C_main" doesn't work either.

okay, so that seems to indicate that it's pointing at something that isn't there. So, I change the 'main' code to 'level10C_main'. It seems like the wrong thing to do, and it doesn't work.

The only way I can get this code to successfully insert is to remove the JMP line altogether. But, this crashes the rom as soon as I enter level 10C. Which also makes sense.

But, I don't know what else to do. Either the instructions are not clear, or I'm just missing something really obvious. Please help a brother out.
GANYMEDE

Chapter two: Land of No Shame
Coming January 2022
The code it generated is not made for uberasm tool but for the long outdated patch version of uberasm. To get it to work with uberasm tool you need a few changes.

I don't remember exactly what it generates but if it crashes try replacing all RTS with RTL.

Alternatively, Effect Tool has been updated to generate uberasm tool compatible files so you should be fine if you redownload the tool and make it with the new version in the future.
I'm using the most up-to-date versions of both tools (I lost all my legacy tools in a hard drive crash). The generated code uses RTL rather than RTS. I do remember that being a problem using the older version.

Probably should have just pasted the code, so here that is:
GANYMEDE

Chapter two: Land of No Shame
Coming January 2022
Weird that it still generates the JMP then, thought that would've been removed.

Either way, I just removed the JMP line and inserted the code myself and it works fine so you might have something else that's messing it up. Does it work if you don't insert the code at all? Are you combining it with anything?
Have you tried changing JMP level105_main: to just JMP main, without the colon?

--------------------





YouTube
Remove that JMP level105_main:. Not only does it has got a syntax error (that colon shouldn't be there), it is redundant anyway considering the destination (the main code to correct the parallax) is located right next to that jump anyway.

--------------------
Rest in peace, Near.
I tried both methods, and it works, and the parallax is functional! Great! Problem is solved and thanks to everyone who helped.

But anyone have any idea why it makes Layer 3 go nuts? I'm pretty new to using Layer 3, so I never knew if it was a problem or not.

GANYMEDE

Chapter two: Land of No Shame
Coming January 2022
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - Effect Tool and/or UberASM issue (probably beginner level)

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks