15 users online:  AmperSam, bandicoot, ChristianR839, Dark Prince,  dtothefourth, gabriel09213535, Green, Heitor Porfirio, Humpty Dumpty Magazine, Jamie, MrDeePay, NikutheMeat, Red2010, vob-omb, zAce08xZ - Guests: 77 - Bots: 170
Users: 62,953 (2,669 active)
Latest user: KingRhodesTN

Custom Power up no projectile

Trying to use Custom Shooting Power-ups ( and everything was installed properly but I have no projectile.

From the creator he says in a comment:

"Make sure you insert EVERYTHING correctly, power-up sprites, uberASM, extended sprites, and make sure there's no freeRAM conflict. SpriteToShoot is used by respective power-up (configured by sprite's extra property byte in .cfg) to allow shooting the projectile. By default, for example, hammer power-up has extra prop. byte set to 0, so it'll use the first entry in SpriteToShoot table, which by default is db $00+!ExtendedOffset. That means it'll use custom extended sprite 0 from the sprite list."

Yet I have no clue what to do..

My Pixi list is as follow:

0 powerup_hammer.cfg
1 powerup_boomerang.cfg
2 powerup_shuriken.cfg
3 powerup_ice.cfg
4 powerup_bubble.cfg
5 IceBlock.cfg

6 Projectile_hammer.asm
7 Projectile_boomerang.asm
8 Projectile_shuriken.asm
9 Projectile_iceball.asm
10 Projectile_bubble.asm

UberASM list:

; Game mode list. Valid values: 00-FF.
07 ShootExPower.asm
0B ShootExPower_DisplayOnly.asm
0D ShootExPower_ColorOnly.asm
0E ShootExPower_ColorOnly.asm
0F ShootExPower_ColorOnly.asm
13 ShootExPower_DisplayOnly.asm
14 ShootExPower.asm
15 ShootExPower_DisplayOnly.asm
1B ShootExPower_ColorOnly.asm
1F ShootExPower_ColorOnly.asm
20 ShootExPower_ColorOnly.asm

I tried changing db $00+!ExtendedOffset to db $06+!ExtendedOffset and so on but still doesn't work. I tried changing extended numbers to 0-5 to match the one above, still nothing.

The best I've managed is to see a fireball for the ice which didn't turn enemies in ice but killed them and then spawned a powerup bubble coming from the ground, which that powerup shows the bubble but mario goes through it.

I've look every where, read every comment, I just cannot find what I'm doing wrong. Pretty new to all of this but at this point I guess I'm just stupid