Banner
Views: 874,902,333
Time:
29 users online: 7 up, Adriel_Isaque, Amine Retro, Apparluk, ArmaRood, Bensalot, blgmadresh0000, buggy789, callmeCMDR, DaHitmenGuy, Dennsen86, Diba9Br, eduard11, Evil_Abed, faloppa, h.carrell, Hat Kid, HelloSammu, josee_544, Mega, Minuy600, Mr. MS, PlagueRatofDoom,  shovda, Sig_AM, swunsh_,  Teows, TheLegendaryOrb, Wolfguy423 - Guests: 69 - Bots: 113 Users: 48,776 (2,448 active)
Latest: pattmeterson
Winter C3 2021 Content Spotlight
BootaNoBijuu's "Cool Rip, Nice Graphics"!
Not logged in.
MORE.bin problems
Forum Index - SMW Hacking - SMW Hacking Help - MORE.bin problems
Pages: « 1 » Link
Okay, I have music that uses ASDR or something and the music doesn't loop properly. So, I was told to insert MORE.asm to my ROM to fix the problem. This is what happened:

1: Downloaded AddMusic RevX and got the MORE.asm and MORE.bin files.
2: Found free space in my ROM at 8FC31, used Lunar Address to convert to $11:FA31, wrote 11FA31 in the ASM file.
3: Attempted to insert asm with command-prompt xkas with "xkas.exe MORE.asm Super Mario World.smc, I know it didn't work because it didn't screw up my ROM's checksum.
4: Tried to use RevXkas to insert asm, error message: C:/ MORE.asm: line 41: file not found[incbin MORE.bin] (This message appears twice). MORE.bin is in the same directory as the rest of the stuff.

Why is it not working?

Also, After I try and fail to insert asm, the ROM will not run in an emulator.

--------------------
Now with extra girl and extra hacker
Hmm, a very easy way I have been able to use ASDR is typing "addmusic romname.smc -se" in command promt. Make sure to have command promt, a 1 MB - 4 MB ROM, and Romi's addmusic in the same folder with Romi's Addmusic. You should be free to insert music with ASDR via Romi's Addmusic from then.

--------------------
FUCK KILL STEAL SHIT
Okay, I tried that, but the music still loops incorrectly.
Could there be a problem with the music file? Click here for the music I used. It loops at around 4.5 seconds.

--------------------
Now with extra girl and extra hacker
What addmusic are you using, Noobsicle? What Daboys suggested only works with Romi's current version of addmusic.

--------------------
<TLMB> I use YY-CHR to edit DNA
Yes, ti's the music file. I've actually fixed it with my non-existant porting skills:

;Super Mario RPG ƒnƒiƒ`ƒƒƒ“‚̐X
l8 {

#0 w160 t52 $F0

#0 @7 q7F v255 y10 p16,16
#1 @7 q7F v240 y10 p16,16
#2 @7 q7F v240 y9
#3 @5 q7F v255 y11
#4 @11 q7F v160 y12 p12,32
#5 @11 q7F v160 y8 p12,32

The bolded appears to have been accidently tab'd. Just move it in the same positon as shown.

And yes, I did suggest Romi's Addmusic, since I happen to always use it.

--------------------
FUCK KILL STEAL SHIT
AAK... NOT... WORKING!!!
*bangs head on desk*
*pants loudly*
Here's a spc of what it sounds like.
And... for some reason, when I open the file with notepad, the text looks like this:

asd;lgkfjasdlgja;slkjg'aslkdj;ald';alsjkDGLka;sdflkg'akgalksd'k;lgk

Instead of this:

asdlgj
adslgj

a.jfhg
adfg

(pardon for the garbage)

Could that be it?
Also, I re-updated the txt file, in case there are any more errors.

--------------------
Now with extra girl and extra hacker
If you're using Romi's addmusic, I can't help you, but if you're using Carol's Addmusic_e, then there's a common, similar issue where some songs incorrectly loop. The fix for addmusic_e is to not use addmusic_e, and use the japanese one (just "addmusic") here.
YESS!!! YESS!!! YESSSSSSSSS!!!!!!!!!!!!!
*shot*

(translation: it worked!)

--------------------
Now with extra girl and extra hacker
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - MORE.bin problems

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks