Language…
13 users online: 1UPdudes, CODEHEX4EVER, D1STYNCT, Dark Prince, Foxy_9000_, Isikoro, JupiHornet, Matheus0349, NewPointless, Ringo, solgaleo35,  TickTockClock, Tiozinho - Guests: 76 - Bots: 156
Users: 54,909 (2,064 active)
Latest user: Sonulianic.Exe

Lunar Magic 1.71. MAKE A BACKUP BEFORE USE!

What screen-scrolling pipes WILL work????
Your layout has been removed.
Originally posted by imamelia
LEARN HOW TO SCREEN-SCROLLING PIPES!!! *steam shoots out of ears*

Um, I mean...I got them to work okay with 1.71, why?

(Edit for clarification: That's a link to an IPS patch of a ROM edited in Lunar Magic 1.71 and patched with the screen-scrolling pipes on page 4. Brownie points for anyone who knows who I was quoting.)


These should work okay. They did for me, at least. Just don't patch that to an edited ROM. (One that has been hacked by Lunar Magic is okay.) That IPS patch was made with LM 1.71, and the pipes are on page 4.

----------------

I'm working on a hack! Check it out here.
Originally posted by Ripperon-X
This probably didn't happen to many, but the last version of Layer 3 ExGFX has a very minor glitch. The layer 3 graphics display perfect, but the ExAnimation is the problem. When I loaded a savestate of the level containing the layer 3 exgfx, instead of ExAnimation GFX, I saw SP4's GFX. Yes, I set the address with free room. At 298000 to pe specific.


If anyone wonders, right now I'm working on a v2.2 to fix said bug.
Expect it tomorrow, maybe.
--------> Don't follow "Find Roy's Dignity", my hack. Because it's pretty outdated. <--------
Originally posted by S.N.N.
Originally posted by cheeseofdoom
Is anyone else having trouble with addmusic? I have a problem where the song plays for a bit, and then it stops and breaks all the sound in the game, and crashes the game when I go through a door.


Huh? That actually sounds like more of an issue with the song itself (or a command in said song). Which song is it?


Right now I am trying to get "Geothermal" to work, which was ported by.... you >.>

I've also tried with other songs, and one got rid of the sounds before playing at all.



Have you tried all this on a new ROM? If your music troubles occur on a clean ROM, and I or someone else can reproduce it, I'll add it to the list of problems at the start of the page.
Alright, I tried on two (what I assumed to be "clean") roms, one being opened in 1.7, the other in 1.65, and they both did the same thing... So I think maybe there's something wrong with my addmusic >.> I'm going to try redownloading it and see if that fixes it.

Edit: Redownloaded, still having the same problem... Should I not be using Romi's Addmusic?
Originally posted by imamelia
Originally posted by imamelia
LEARN HOW TO SCREEN-SCROLLING PIPES!!! *steam shoots out of ears*

Um, I mean...I got them to work okay with 1.71, why?

(Edit for clarification: That's a link to an IPS patch of a ROM edited in Lunar Magic 1.71 and patched with the screen-scrolling pipes on page 4. Brownie points for anyone who knows who I was quoting.)


These should work okay. They did for me, at least. Just don't patch that to an edited ROM. (One that has been hacked by Lunar Magic is okay.) That IPS patch was made with LM 1.71, and the pipes are on page 4.


No ASM file???
I don't want them on page 4 =3

Also, why this thread isn't sticky???
Your layout has been removed.
Originally posted by cheeseofdoom
Alright, I tried on two (what I assumed to be "clean") roms, one being opened in 1.7, the other in 1.65, and they both did the same thing... So I think maybe there's something wrong with my addmusic >.> I'm going to try redownloading it and see if that fixes it.

Edit: Redownloaded, still having the same problem... Should I not be using Romi's Addmusic?


Be sure you installed more.asm to your hack if you use music with NTSC.
Just make a command file (.bat) and type

''AddMusic.exe YourHack.smc -se''

Then open the .bat file to install it.

If that's not the case, i don't know man.

Your layout has been removed.
Of all the glitches mentioned in the first post, which ones are present on LM 1.71? Also, if it's possible, is there a place to see ALL glitches, even if they're not present on this thread?

Status of my Hack:



Originally posted by rtyuio54321
Of all the glitches mentioned in the first post, which ones are present on LM 1.71?

LM 1.71 itself has no known glitches. All the problems people have are caused by external code (patches/tools) not being compatible with LM's new features. FuSoYa will never fix those, as they're pretty much our fault.


 
Originally posted by WhiteYoshiEgg
Originally posted by rtyuio54321
Of all the glitches mentioned in the first post, which ones are present on LM 1.71?

LM 1.71 itself has no known glitches. All the problems people have are caused by external code (patches/tools) not being compatible with LM's new features. FuSoYa will never fix those, as they're pretty much our fault.


So, how can I be completely sure that my ROM will not have any problems if I use LM 1.71? If I load the hack, edit it, and it plays normal, would that mean my hack will work alright?

Status of my Hack:



did the glitch where the secrete exit goal post show as a red X with a black box around it happen in 1.71...or was that an older version...
Originally posted by rtyuio54321
Originally posted by WhiteYoshiEgg
Originally posted by rtyuio54321
Of all the glitches mentioned in the first post, which ones are present on LM 1.71?

LM 1.71 itself has no known glitches. All the problems people have are caused by external code (patches/tools) not being compatible with LM's new features. FuSoYa will never fix those, as they're pretty much our fault.


So, how can I be completely sure that my ROM will not have any problems if I use LM 1.71? If I load the hack, edit it, and it plays normal, would that mean my hack will work alright?


As long as you don't use outdated patches and tools like the old btsd, etc, you should be fine.

MarioMaker6: yes, read the recently fixed section in the readme that comes with lm 1.71, the fixes section. #w{=9}



Check out my hack HERE!
So, there's NO glitches so far in 1.71?
Not that we know of, no.
Actually, if you use the time limit bypass to force any time limit you want... and set it to zero it will not change it and only keep the old time. You have to set a zero time limit with the other option thing headers.
I own a community of TF2 servers!

ASMT - A new revolutionary ASM system, aka 65c816 ASseMbly Thing
SMWCP - SMW Central Presents a Product- tion long name

frog

http://esolangs.org/wiki/MarioLANG
And Sprite 17 still hasn't been updated. It's not unused, it's the sprite spawned by the Jumping Fish Generator.
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel
Originally posted by Fakescaper
Actually, if you use the time limit bypass to force any time limit you want... and set it to zero it will not change it and only keep the old time. You have to set a zero time limit with the other option thing headers.

Actually I sent that thing FuSoYa before 1.70 was released, but I didn't got the answer. Probably thats means it's not a bug.
... not to mean he reacted on that bug, which I sent after sending time limit bug.
Originally posted by FuSoYa
corrected an issue where attempting to save more sprites than a LoROM bank could hold would not display an error message like it was supposed to and LM would only save the sprite header. Thanks goes out to Glitch for reporting this.

... also he/she written badly my name
Legacy ports zip (now that those went down because Dropbox)
The 1.71 SS Pipes ips patch DOES NOT work.

Well... to be more accurate, it works, but it has the same glitchs I noticed when I used the old xkas version. In some levels (I believe it is all levels under level 100 though I haven't looked through all of them) it replaces the flashing color used by the Yoshi coin with a weird purple. Also, in some levels (and I can't see a pattern here... it seems to be random), it screws up the graphics for the coins, question blocks, and brown used blocks.

I patched it to a clean rom and tried a couple of times to see if it was a fluke and got these still glitches every time.
I have a hack thread - Link (Now with a demo!)
Also a music thread - Link

C3 Projects
2013: Modern Spiny Pack
2012: MGSS v0.1
Spring 2010: SMB2 Autobomb Sprite
Try checking the animation settings for those levels.


EDIT: Tried it. It worked except the pipes graphics were screwed to oblivion. But they could easily be remapped to BG2 or BG3.
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel