Banner
HackJam voting closes in
7 HOURS, 18 MINUTES AND 58 SECONDS
Views: 961,009,498
Time:
9 users online: Alex No,  Atari2.0, Coockie1173, derv82, Green Jerry, KaidenThelens, Kleyson Rodrigues, simon.caio, WhiteYoshiEgg - Guests: 63 - Bots: 93 Users: 53,191 (2,293 active)
Latest: Adeadflyy
Tip: If you're using the original SMW ending, remember that Level 104 (Yoshi's House) will appear during it.
Not logged in.
Ask anything about SMW Hacking - 2019 Edition
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition
Pages: « 1 2186 187 188 189 190286 287 » Link
I have a question.

I don't know if I found something new or something, but here me out.

If I use the layer 2 on/off switch and I let the layer 2 stuff come down and fall down to the floor the switch then goes to the ON position.

While in this position when Mario spin jumps he doesn't make the normal noise he usually does, but instead it goes "kaboom" like a ground pound. The same noise happens when I collect coins on layer 2 as well.

Is this a known thing?


Yep, it's known. It's because of these lines in SMW's code:

Code
	LDA.w #$0009		;$05C75D	| Smasher SFX
	STA.w $1DFC		;$05C760	|


Because the only condition for this sound effect to play is for Layer 2 to be at its lowest point, it ends up storing every single frame. So, whenever $1DFC is updated with a new sound effect (e.g. by spinjumping or collecting a coin), it promptly gets overwritten by the smash sound effect.

(there's a list of all of SMW's glitches here btw)

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
I'm having a problem inserting a port by worldpeace. You see, in this port it tells me to remove something, but everytime I do, it gives me this error:

Originally posted by AddmusicK
Could not parse interger for #define


I don't exactly know what this means, but I can't fix it either.
Is there any particular reason levels 13A and 13B are unable to be accessed from the overworld?
thx to e r i k for layout
That shouldn't be the case. Levels 13A and 13B should be accessible from the overworld (unless you're using this patch, in which case they'd be levels 5E and 5F instead).
I haven't touched that patch, so it looks like it locked them for no obvious reason. I could knock up an IPS tomorrow if that would help...
thx to e r i k for layout
So, from what I understand, there are four ExAnimation slots each (not counting Global ExAnimation) that can work with each other because they run on the same frame. Now, what do I do if want to have more than four tiles synch with each other?

e: Thank you!
You use the animation types that animate more than one 8x8 tile.

--------------------
My YouTube channel
Get the official ASMT resource pack here!

Where can I find some graphics to go with the Parabeetle sprite included with SpriteTool?
Originally posted by MercuryPenny
Where can I find some graphics to go with the Parabeetle sprite included with SpriteTool?


If it's not included with SpriteTool, then you'll have to look in the graphics section.

...However, there are none, so you'll have to draw them yuorself or somehow request them. :( sorry

--------------------
Twitter
The handomest people in the world are ones who follow my Twitch
or rip them from smas
Romi's sprite pack also contains some (unless I'm misremembering...), as does the Tessera 0.52 folder.
That is what I'm looking for, but SpriteTool whines about something going wrong with assembling Romi's Parabeetle and temp.log says this:

Originally posted by temp.log
65816 Tricks Assembler Version 1.11 (C)opyright 1994 1000 Miles [Tricks]
Internet: [email protected], IRC: minus

Memory available: 2147483647
Starting address defined as $95B58F

Pass 1
Error in 10.1/9: Unable to append source file

Pass 2
Error in 10.1/9: Unable to append source file
Error in 121.1/104: Symbol does not exist

Pass 3
Error in 10.1/9: Unable to append source file
Error in 121.1/104: Symbol does not exist

Source code assembled.

Although the source code was assembled, the program may not run
properly due to errors detected during the assembling process.

[$95B58F-$95B69E]
Lines=159
Statements=139
Symbols=14
Errors=2


...and the sprite doesn't function at all. Any ideas?
Originally posted by MercuryPenny
Originally posted by temp.log
Unable to append source file

As stated in the description of the sprite pack, Romi's sprites use a couple of patches for shared subroutines (SubOffScreen.asm and GetDrawInfo.asm), as well as a file called definition.asm to read the location of those patches. Do you have the patches applied, and definition.asm in the Spritetool folder?

--------------------
My YouTube channel
Get the official ASMT resource pack here!

I have a question, how do you make custom overworld borders?

--------------------
Check out Team Hack Fix/Translations' thread full of fixed and translated SMW hacks!

Wanted Permabanned or Dead by new staff team
press #lm{extgfx}#lm{insgfx}#lm{extexgfx} -> in the ExGraphics folder create a file called ExGFX###.bin (with ### being any number from 80 - FFF (int hex)). -> Press #lm{insexgfx}.

#lm{ow} -> File -> Layer 3 submap -> Load layer 3 submap -> select map -> edit as you like -> save -> In the dialog, in the first box, search for the file you created earlier (the ###). Leave everything else -> Ok.

press #lm{l3gfxby} (still in OW editor) -> select map you want custom border on in top box -> check "Enable bypass of standard layer 3 tilemap for this submap" -> select your ### again in the first box (GFX tielamp file) -> click OK -> done.
(repeat that last process for every map you want that custom border on, just changing the slot in the first box)

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
I'm using the SA-1 patch and I have expanded my ROM to 8MB. However, now I want it to be back to 4MB. Can I somehow convert my rom back to 4MB or am I gonna have to transfer my work over to a new rom?
I have already posted a new thread with a question so is it obsolete to ask the question here too? Also my apologies for making so many threads I should have posted the more simple questions here.

But anyway, I have a level that uses the layer 2 smash 3 sprite (E9). Its the same sprite that's used in the fifth room in bowser castle. It acts like it supposed to but when I enter the level in screen A the layer 2 smash acts like layer 2 smash 2 (the one in valley Fortress). In LM both sprites in screen 0 and A are layer 2 smash 3.

(The reason I have the same sprite in screen A is because you can enter the level in screen A too. Also when I enter from screen 0 the layer 2 smash stays the same, it does not change when I reach screen A)
How the he*k do you use upsidedown slopes?
This is the best I can get them to look:



Originally posted by Lazy
I'm using the SA-1 patch and I have expanded my ROM to 8MB. However, now I want it to be back to 4MB. Can I somehow convert my rom back to 4MB or am I gonna have to transfer my work over to a new rom?

Just chop off the last 4MB (with a hex editor probably), at least unless you put any data there, in which case no luck.

--------------------
Your layout has been removed.
upside-down slopes will only appear correctly in one of the underground tilesets (1, 2, or 3). enable #lm{hidegfx} and you'll see that you aren't meant to use the underground slope in your current tileset
Pages: « 1 2186 187 188 189 190286 287 » Link
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks