Language…
5 users online: Hayashi Neru, Isikoro,  MarioFanGamer, StarWolf3000, Wlerlen - Guests: 67 - Bots: 177
Users: 55,629 (2,424 active)
Latest user: esmith13

Ask anything about SMW Hacking - 2019 Edition

  • Pages:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 258
  • 259
  • 260
  • 261
  • 262
  • 263
  • 264
  • 265
  • 266
  • 267
  • 268
  • 287
  • 288
  • 289
Originally posted by Shiny Ninetales
Are these tiles of GFX0F even used for something in the game?



Are they safe to overwrite?


Those are padding tiles that are used solely to fill up space in the chr that isn't being occupied by actual graphics, so yeah, you can overwrite them.
Don't eat the sandwich
Hey everyone!
I have a question about editing graphics:
Basically, i've recently discovered about the term "tile merging" through VLDC 11 rules thread. With a bit of searching, i discovered this method is about overlapping 2 tiles, having both their graphics merged together into one single tile (such as having a Vine tile and a Dirt tile merged so i can use Vines inside Ledges without causing cutoff).

Now that the contest is over, i finally got around to learning about SMW Tools and stuff, including YY-CHR. Now i'm making a ExGFX file, and i need to merge a few tiles, but i noticed (and Leod's YY-CHR tutorial says this as well) that YY-CHR doesn't understand color 0 as transparency, and as such i can't copy one tile and place it on top of the other, as that will override the tile below.

So, in order to merge them, will i need to draw the second tile on top of the first pixel by pixel, or is there an easier way to do it that i don't know about?
My Youtube Channel
Originally posted by ECS.98
So, in order to merge them, will i need to draw the second tile on top of the first pixel by pixel, or is there an easier way to do it that i don't know about?


The quickest and dirtiest way I copy-paste things onto YY-Chr is to do work with MS Paint first (yeah, the default drawing program). That can handle transparency fine enough if you have "transparent selection" ticked on, so you can lay your tiles over each other, and then copy-paste it. None of the other drawing programs I use seem to be able to do that, so MS Paint it is.

You might get some slightly weird colors though, but if you know what everything is supposed to look like it shouldn't be a problem recoloring things.

Currently working on Æther: The Infinite Library!

Other Submissions of mine!
Originally posted by Deeke
The quickest and dirtiest way I copy-paste things onto YY-Chr is to do work with MS Paint first (yeah, the default drawing program). That can handle transparency fine enough if you have "transparent selection" ticked on, so you can lay your tiles over each other, and then copy-paste it. None of the other drawing programs I use seem to be able to do that, so MS Paint it is.

You might get some slightly weird colors though, but if you know what everything is supposed to look like it shouldn't be a problem recoloring things.

"Quickest and dirtiest" xD
Thank you! That worked really well!
I did have to recolor stuff, but it was a pretty quick step, and certainly way less problematic than having to draw one tile on top of the other!
My Youtube Channel
Ok so this is important, i have messed up all the graphics in my editor, not sure how. When i open my editor and look through tiles and sprites all i see is garbled graphics. All of my levels are fine when in,the editor and playing them but now i cant place anything but garbled mess. Any ideas? Thx
Originally posted by Magmatic
Ok so this is important, i have messed up all the graphics in my editor, not sure how. When i open my editor and look through tiles and sprites all i see is garbled graphics. All of my levels are fine when in,the editor and playing them but now i cant place anything but garbled mess. Any ideas? Thx


What are your settings in #lm{sgfxby}? Or is this something that's happening on every single level?

Currently working on Æther: The Infinite Library!

Other Submissions of mine!
Okay i will bemore descriptive, it happens on all levels and whatever i did affected all of my roms. I downloaded lunar magic again and downloaded a new rom and it still does it


Well, it'd help more if you could just show an image of what's wrong. I've never heard of a clean ROM and new download of LM having any sort of display issues like that.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
I will see if i can post a picture tomorrow.
 photo screenshot_zpsumebsbxi.png</a>" alt="">
When you go to #lm{gfxby}, what is the level type set to? It just looks like your settings are incorrect, and should be set to "Cloud/Forest"
Did you also modify anything using #lm{sgfxby}?

Currently working on Æther: The Infinite Library!

Other Submissions of mine!
No its not the settings. i have switched level types and all of that, it doesnt do anything. All of the names of objects dont even match a specific tileset, the names are mixtures of different level types. Like it has ghost objects, castle objects and grassland objects. This affected all of my roms btw. If i had the wrong level type than my already made level would have garbled graphics, but it doesnt it looks fine


That is normal. The SNES can not load all the game's graphics at one time, and is limited to a smaller subset. If you hit the #lm{hidegfx} button in the add object/sprite windows, Lunar Magic will automatically filter the list down to objects and sprites which display correctly in the current set of GFX files.

If you want to change current set of objects/sprites available, you can do so through the #lm{gfxby} button in the main LM window. Alternatively, you can manually choose the individual graphics files under #lm{sgfxby}, but I'd recommend getting more comfortable with LM first before exploring that feature.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
it worked! thx! not sure how it gopt that way though, i never turned that off.
Don't Know if this has been asked before, but how do I use pixi?
I have already gone through the tutorial but I run into an error that instantly terminates the app.
How do i add more colors of land on my main overworld? Like i want to make a white snowy mountain, a grassland and a brown mountain but there are only 2 ground tiles to edit the colors for. Thanks for all the help guys.
Shouldn't you know this already from the levels? Like, #lm{pal} also exists on the overworld editor and enabling custom palettes allows you to edit palettes 0 - 3. All you then need to do is to create path tiles for snowy colours (look to the right of the overworld) and the start working on it.
There is, however, one notible issue: The path reveil animation (at least the fade). This needs to be disabled first or else the animation will overwrite your custom palette. In order to disable the animation, just go to Overworld > Extra Options > Disable Event Path Fade Effect
Sorry, i havent used lunar magic in awhile i forgot some things
I was wondering if it would be possible to make it so powerups like the Mushroom, Fireflower and 1UP always face one direction instead of facing whatever direction the player is when said items appear onscreen. I've edited a good portion of the coding for these to my liking and even found a hex value that would give me the desired effect, however, it also applies to the Star and Feather. Could that be hijacked by chance? I am wanting to know as I edited some hex values to prevent powerups from moving horizontally.

Additionally I was also wondering if was possible to have certain sprites like the powerups lowered by one pixel like most other sprites such as enemies.
Don't eat the sandwich
Hello everybody,

I am trying to make the "Nintendo Presents" screen stay on for approximately 16 seconds.

I have edited the hex code at

Code
$0093C6 1 byte Timer How long "Nintendo Presents" stays on the screen before disappearing. 



I changed the value to FF because I thought that was the maximum for a 1 byte entry, but it doesn't equate to enough time.

However, when I set the next value; $0093C7 to FF as well, the screen stays on for the right amount of time but I get the logo blinking.

Does anyone know if it's possible to simply have the "Nintendo Presents" screen set for 16 seconds? Or another way to do it?

As always, any input is greatly appreciated :)
  • Pages:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 258
  • 259
  • 260
  • 261
  • 262
  • 263
  • 264
  • 265
  • 266
  • 267
  • 268
  • 287
  • 288
  • 289