Banner
Views: 859,494,439
Time:
21 users online: binavik, brickblock369, Cartesius, Dark Prince, Darknubs, Dobosco, FineTunedBenjo, Gammed Z, GrumpyWalrus, Haruda, Infinity, J.C.Russell_96, K.T.B.,  KevinM,  Koopster, Mirann, Rykon-V73,  Sinc-X, singlepat, Turret 3471, xxxJohnnieWalker2005 - Guests: 103 - Bots: 72 Users: 47,502 (2,201 active)
Latest: Markgabriel01
Tip: If you're using the original SMW ending, remember that level 104 (Yoshi's House) will appear during it.Not logged in.
Ask anything about SMW Hacking - 2019 Edition
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition
Pages: « 1 2277 278 279 280 281 282 »
Originally posted by BrownBuddy
Is there an uberASM that clears the level/teleports mario after collecting all coins?

Yes, but it's a block inside a pack. However, it's for teleporting only.
Hey,

I need a way to fix my Pipes for Exits. Right now it looks like this:



( Screen 09 is for better comparison, both are exit enables exits )

I also know that the palette of the exit enables pipes depends on the screen where they put at.

How do I change this behavior? Can I set an offset, add different exit pipes or such? I do not want to change my palette because of the background.

Thanks in advance

Mod edit: Fixed slight table stretch.


You can create fixed-color pipes by just selecting the Map16 tiles for the pipes and copying them to another page, and then placing those tiles instead. Only the original tiles will change per screen, your copies won't.

In case you're not familiar with Map16 editing, see here for more info.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Originally posted by Thomas
You can create fixed-color pipes by just selecting the Map16 tiles for the pipes and copying them to another page, and then placing those tiles instead. Only the original tiles will change per screen, your copies won't.

In case you're not familiar with Map16 editing, see here for more info.


But if I do so, I can not use the pipe as an exit and that is my problem =) The editing to fix the color is all right.


Originally posted by ChrillePan
But if I do so, I can not use the pipe as an exit and that is my problem =) The editing to fix the color is all right.

The tiles will still behave as exit-enabled tiles, since that is indeed tied to their acts-like setting. Specifically, the exit-enabled tiles are 137/138 for the vertical pipes and 13F for the horizontal pipes (the top tile of the pipe doesn't have to be 'exit-enabled'); if you hover over these tiles, you'll see LM's description of them mention that they're exit-enabled.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Originally posted by Thomas
Originally posted by ChrillePan
But if I do so, I can not use the pipe as an exit and that is my problem =) The editing to fix the color is all right.

The tiles will still behave as exit-enabled tiles, since that is indeed tied to their acts-like setting. Specifically, the exit-enabled tiles are 137/138 for the vertical pipes and 13F for the horizontal pipes (the top tile of the pipe doesn't have to be 'exit-enabled'); if you hover over these tiles, you'll see LM's description of them mention that they're exit-enabled.


I have to admit, I overlooked over those tiles.. I thought the exit pipe thingy is something special coded or such. Thanks for your patience anyway!
Thanks a lot!

EDIT:

Now I am working on custom sprites and everything is fine :D
But how do I change the x-speed of the skullraft with those asm files?


Originally posted by ChrillePan
Now I am working on custom sprites and everything is fine :D
But how do I change the x-speed of the skullraft with those asm files?

Are you using the skull raft disassembly? If so, it's handled in a bit of a weird way. Just open the .asm file (it's just a text file, you can open it in notepad), then find these lines:

Code
			LDA #$0C				;\ set sprite trigger
			STA $18BC|!Base2				;/

And change the "0C" value to whatever X speed you want the raft to use (in hexadecimal).

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Originally posted by Thomas
Originally posted by ChrillePan
Now I am working on custom sprites and everything is fine :D
But how do I change the x-speed of the skullraft with those asm files?

Are you using the skull raft disassembly? If so, it's handled in a bit of a weird way. Just open the .asm file (it's just a text file, you can open it in notepad), then find these lines:

Code
			LDA #$0C				;\ set sprite trigger
			STA $18BC|!Base2				;/

And change the "0C" value to whatever X speed you want the raft to use (in hexadecimal).


Yes I do =) Was looking for something "SpeedX" or "Valuable X" or such: Thanks again!
How do I get a ROM? I keep looking for ROMs when there aren't any? What do I do?
By Googling for one. We don't host them because doing so is illegal in favor of patches which are not. Also, are you sure you're looking for the right ROM?
Originally posted by Katerpie
Originally posted by BrownBuddy
Is there an uberASM that clears the level/teleports mario after collecting all coins?

Yes, but it's a block inside a pack. However, it's for teleporting only.


Thank you.
Hey!

I insert this sprite to use in my levels:
https://www.smwcentral.net/?p=section&a=details&id=3424

If I add this in a non-castle level the sprites looks like crap.

If I want to bypass my GFX for that, I already use all of the slots given by pressing the #lm{sgfxby}

Any other way to fix that?

Thanks in advance!
Originally posted by ChrillePan
Hey!

I insert this sprite to use in my levels:
https://www.smwcentral.net/?p=section&a=details&id=3424

If I add this in a non-castle level the sprites looks like crap.

If I want to bypass my GFX for that, I already use all of the slots given by pressing the #lm{sgfxby}

Any other way to fix that?

Thanks in advance!


If you open the "Add Sprites" window in a castle level you can see that the grafics for the fireball are stored in slot SP3 in GFX file 12:



So, you can open that in YYCHR and find out that the grafics have to be exactly here:



You can then copy these tiles into the exact (!) same spot in your current SP3 file. If you have a normal GFX file right now I recommend to save it as ExGFX and put that in your SP3 slot. So this won't affect other levels.
Then you can use the normal fireball and you don't have to use the disassembly (unless you want to modify something ASM-wise). To do so you have to uncheck the cloud, marked in the first picture.
Be aware that whatever sprite's grafics were in that spot, will "look like crap" afterwards. If you happen to need that sprite also, you have to remap the grafics to a different spot/slot. But I don't know how to do that.

--------------------
Mario Quits - My Kaizo hack in progress
That might work because I do not need the chucks in my level.. Thanks so far :D Ill try and if I got no results, ill edit this post =)

EDIT:

I might find a easier solution: I just set SP3, with mainly contains Chucks and Fish, with the GFX for , let me say, Castle Sprites. Functions really good and as long as I bypassed the GFX and dont edit it, its good for all other levels as well. Gotcha!
Originally posted by ChrillePan
I might find a easier solution: I just set SP3, with mainly contains Chucks and Fish, with the GFX for , let me say, Castle Sprites. Functions really good and as long as I bypassed the GFX and dont edit it, its good for all other levels as well. Gotcha!

Be aware of Yoshi, though: His tongue isn't global graphics so he isn't compatible with all graphics of SP3. #ab{;)}

--------------------
Okay, my layout looks ugly.
Hey!
I added this background to my romhack: https://www.smwcentral.net/?p=section&a=details&id=6086

In the comments below he explain how to change the waterfall into lava waterfall, but im not sure about the instructions.

Quote
If you want the lava waterfall instead of the water, you'll need to change the amount of frames to 4 and enter a couple of things:

Destination: 28
Frames: B7 15 29D 1BA

Destination: 29
Frames: 15 1BA 29D B7

Destination: 2A
Frames: B7 29D 1BA 15

Destination: 2B
Frames: 1BA B7 15 29D


Can someone explain it to me?

Mod edit: don't use code to quote others' posts
That means you must change the ExAnimation settings through #lm{exan} the same way it's done with the waterfall, and then pick a slot for each of the 4 frames. That means you should just base yourself from the .mwl file. Most of the destination slots are pretty much the same, what should be changed is the amount of frames and the frames themselves.
Hi everyone!!
Im new to rom hacking but have been following along with chainfire and a few other tutorials on youtube for a while now trying to hack this rom my kid plays its exacty the same but has a peach sprite instead of mario and i have 2 issues i cant find anything that actually works online so far to fix. so in chainfires video, he makes his overworld layer 2 stuff off to the side in the blue area with the black X's, and then he drags it over top of the old overworld after deleting all events and what not. he does this on the map at the top with donut plains etc. today, I wanted to start with yoshis island and im not sure if i missed a step but i deleted all events, dragged my new map over top, set up the levels and paths made sure everything connects nice. i moved yoshis house so i moved the mario and luigi sprites, but it still starts where the house used to be,its on a path but i cant move any direction until i put the house back. ti shows a red 1 and 0 where the castle exit used to be and the yellow switch palace used to be. i should mention moving the sprite anywhere on any maps still starts at where the house used to be.
also where that water level was on yoshis island is land now but it still does the animation that hes is the water and ive set the direction to let me pass but it wont at all.

sorry for the long post!!
thanks!!






Mod edit: Please don't post huge images directly! I've fixed them for you with HTML.
If you pick a tile for water levels, of course the player acts like they're in water. You can see the paths on the overworld if you press #lm{owl1path} or 9.

--------------------
Okay, my layout looks ugly.
haha oops haha. well that solves the water level issue, thanks!!
so how do i change the starting position, cause no matter where i put yoshis house of the sprites, it always starts at the same place where the house used to be..
also that level that was a water tile. i still cant go passed it even when i set the directions to be open in lunar..
Pages: « 1 2277 278 279 280 281 282 »
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy