Idioma…
16 usuários online: Ahrion,  AmperSam,  Anorakun,  Ayami, CalHal, EliteBellic, Green Jerry, haine9, HammerBrother, MarioTeam, MORC, nebulous84, Samie Zuccati, Spy, yoshiatom, yuhmate - Visitantes: 102 - Bots: 244
Usuários: 55.726 (2.323 ativos)
Último usuário: Kakasouza14

Ask anything about SMW Hacking - 2019 Edition

  • Páginas:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 276
  • 277
  • 278
  • 279
  • 280
  • 281
  • 282
  • 283
  • 284
  • 285
  • 286
  • 287
  • 288
  • 289
I have a level i created that can be cheesed by constantly going backwards and forwards to respawn falling platforms till you figure out a way of doing it is there a way that i can make my falling platforms not respawn? by off screening them?
Originally posted by danthaman4671
Can someone tell me everything palette 9,7 does? Thanks!

If you mean colour 97 in the palette editor, that's used by quite a few sprites including the red part of Grinders as well as the Boo's mouths. No idea why you really need this information, though.
Originally posted by BlueToad
What do you mean by palette 9, 7? Do you mean palettes 9 and 7 individually or color 7 in palette 9?

Color 7 in palette 9.


Originally posted by Thwompz
I have a level i created that can be cheesed by constantly going backwards and forwards to respawn falling platforms till you figure out a way of doing it is there a way that i can make my falling platforms not respawn? by off screening them?

Sure, with a little bit of ASM tweaking. To start, you'll probably want to create a custom version of the platform by using the disassembly of the falling platform, unless you want to change them globally. You can then add the following code between the "BEQ .checkContact" and "LDA.w !1540,X" lines:

Code
	; BEQ .checkContact

	PHX
	LDA !161A,x
	TAX
	LDA #$01
	if !Disable255SpritesPerLevel
		STA !1938,x
	else
		STA.l !7FAF00,x
	endif
	PLX

	;LDA.w !1540,x


Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Is there a way to use the layer 3 water with a layer 3 background at the same time?


Originally posted by danthaman4671
Is there a way to use the layer 3 water with a layer 3 background at the same time?

It is possible, as you can just load a Layer 3 tilemap alongside the tides through the #lm{l3gfxby} menu. By default though your background would autoscroll left with the tides, which probably isn't desired; to fix that, you'll have to add a little bit of ASM work as well.

Basically, the process is:
1) Enable Layer 3 tides.
2) Enable the advanced bypass settings and disable horizontal scrolling.
3) Edit the level's Layer 3 tilemap and add your background above the tides, then apply that to your level.
4) Use UberASM and create an HDMA code that has the BG portion of your Layer 3 tilemap scrolling as desired, while the tide portion autoscrolls left as normal. You can use Effect Tool to generate a code to use as a base for the HDMA, though you would have to modify the logic of it slightly to add in the autoscroll.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Would anyone happen to know what causes animations to pause on things like the file select and info block messages?
Don't eat the sandwich
That's because none of them run the animation codes, either because they're in their own game mode (title screen menu) or don't run the rest of the game mode (messages).
Originally posted by Thomas
Originally posted by danthaman4671
Is there a way to use the layer 3 water with a layer 3 background at the same time?

It is possible, as you can just load a Layer 3 tilemap alongside the tides through the #lm{l3gfxby} menu. By default though your background would autoscroll left with the tides, which probably isn't desired; to fix that, you'll have to add a little bit of ASM work as well.

Basically, the process is:
1) Enable Layer 3 tides.
2) Enable the advanced bypass settings and disable horizontal scrolling.
3) Edit the level's Layer 3 tilemap and add your background above the tides, then apply that to your level.
4) Use UberASM and create an HDMA code that has the BG portion of your Layer 3 tilemap scrolling as desired, while the tide portion autoscrolls left as normal. You can use Effect Tool to generate a code to use as a base for the HDMA, though you would have to modify the logic of it slightly to add in the autoscroll.


When I load the BG the water disappears
I am hoping someone can help me. I'm very new to Lunar Magic and I've tried following along a few tutorials, but still struggling to insert a sprite. I have a clean rom which I have opened at least once in Lunar Magic. I have downloaded PIXI and installed to a separate folder. I am trying to insert this sprite:

https://www.smwcentral.net/?p=section&a=details&id=16220

I've extracted all three files and placed them in my PIXI/sprites folder. I've created a list.txt file in the PIXI folder and added a line that says "00 batadon.cfg" (without the quotes). I run pixi.exe and drag my rom onto the screen and hit enter. A message appears saying "All sprites applied successfully!".

However, when I re-open the rom in Lunar Magic and navigate to the Add Sprites Window, I can't seem to find the new sprite listed anywhere. I suspect there is some additional step I'm missing, but not sure what. If anyone can point me in the right direction, I'd appreciate it. Thanks!
You missed a portion of the tutorial. Go to to the Pixi tutorial, find "switch to sprite mode and now press "Insert" on the keyboard [...]" and read the next few lines.
Originally posted by jplank
I am hoping someone can help me. I'm very new to Lunar Magic and I've tried following along a few tutorials, but still struggling to insert a sprite. I have a clean rom which I have opened at least once in Lunar Magic. I have downloaded PIXI and installed to a separate folder. I am trying to insert this sprite:

https://www.smwcentral.net/?p=section&a=details&id=16220

I've extracted all three files and placed them in my PIXI/sprites folder. I've created a list.txt file in the PIXI folder and added a line that says "00 batadon.cfg" (without the quotes). I run pixi.exe and drag my rom onto the screen and hit enter. A message appears saying "All sprites applied successfully!".

However, when I re-open the rom in Lunar Magic and navigate to the Add Sprites Window, I can't seem to find the new sprite listed anywhere. I suspect there is some additional step I'm missing, but not sure what. If anyone can point me in the right direction, I'd appreciate it. Thanks!


If a sprite doesn't come with a json file then it wont show up in the custom sprites part of the Add Sprites Window after running Pixi. You can insert them manually by going to Edit -> Insert Manual... while in sprite editing mode, putting in the number you inserted it in for the Command field and 2 or 3 for the Extra Bits.
Thank you, I appreciate the help! That fixed it.
Is there a way to have different boss music for each boss? I want the tower fights to use different music than the castle ones, similar to New Super Mario Bros.
-hanox
  • Páginas:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 276
  • 277
  • 278
  • 279
  • 280
  • 281
  • 282
  • 283
  • 284
  • 285
  • 286
  • 287
  • 288
  • 289