Banner
Views: 859,541,461
Time:
14 users online: Adriel_Isaque, AnEvilGhost, Arcten, chickaDEE Magazine, DaHitmenGuy, FerpyMcFrosting, Ixitxachitl, Jern, K3fka, kyasarintsu, Miscalc, SiameseTwins, Sping bot, UTF - Guests: 114 - Bots: 70 Users: 47,506 (2,205 active)
Latest: RoboTurtle
Tip: Don't put a coin over a question block. It will create an invisible solid block above the ? block if the block is hit first.Not logged in.
Ask anything about SMW Hacking - 2019 Edition
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition
Pages: « 1 292 93 94 95 96281 282 »
You don't want #$00 there, #$00 is no sound at all. Pick another one.

--------------------
<blm> zsnes users are the flatearthers of emulation
Originally posted by Sokobansolver
I noticed that for some reason Mario falls faster downward off of a layer 2 object than from an object on layer 1. Anyone know why that is?

Maybe it's storing Mario's speed as still falling on Layer 1? If that's the case, we might actually need to recode the way Layer 2 interaction works to the point of breaking every single sprite in the game in order to fix the wallrunning bug there...

--------------------
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel
How do i activate free roaming mode with cheats? I need this because otherwise i have to start another game to make Mario move in "exit enabled" levels. I tried with the debug cheat, but it doesn't work.

Ugh now i know why YCZ with the cookie crisis was smart enough to make all levels with any direction enabled and using Layer1 events to make Mario not move where he isn't supposed to move.

Also:



Why does this happen? Can it depend from the fact the rom was previously edited with an earlier LM version? I don't even remember if i did.

Then the No Yoshi intro patch makes Mario start at Y:06 even if the floor is at Y:05.

Edit: the position problem is solved, but why the "entrace" patch doesn't work with SuperGFXBypass? Because if i use ExAnimation or something similar, it doesn't load GFXs, it loads only GFX from the original GFX header.

--------------------
My deviantART
My Youtube channel
My avatar
Watch, i made a Super Mario 64 level
/*
PSEUDO CODE for Yoshi Spawning Coin:

If shell hitting yoshi coin is green (sprite DA)

spawn green yoshi ($13C7 = #$0A)

Else if shell hitting yoshi coin is red (sprite DB)

spawn red yoshi ($13C7 = #$08)

Else if shell hitting yoshi coin is blue (sprite DC)

spawn blue yoshi ($13C7 = #$06)

Else if shell hitting yoshi coin is yellow (sprite DD)

spawn yellow yoshi ($13C7 = #$04)

Else if sprite/object hitting yoshi coin is
NOT a green, red, blue, or yellow koopa shell

do nothing

End if
*/


I'm getting closer! Can someone please check my ASM file again and help me figure out what to do next?:

http://bin.smwcentral.net/u/14533/Sam%2527s_First_ASM_4.zip
Originally posted by ROM Map
0E501 $01:E301 1 byte Timer [20] How long time Monty Mole waits in the ground until jumping out (for other areas than YI)
0E53C $01:E33C 1 byte Misc. Tile spawned by ledge-dwelling Monty Mole
0E56A $01:E36A 1 byte Sprite tilemap related Attributes of Ledge-Dwelling Monty Mole
(Sprite 36 code somewhere in here)
0E654 $01:E454 1 byte Sprite tilemap related Dry Bones and Bony Beetle crumble animation, frame 1
0E65E $01:E45E 1 byte Sprite tilemap related Dry Bones and Bony Beetle crumble animation, frame 2


Tweaker locates Sprite 36's ASM offset at $01 E41F. What exactly is here?
http://bin.smwcentral.net/u/5541/Code36.png
http://bin.smwcentral.net/u/5541/InTrans.png

Exactly what does this have to do with the interaction between the Layer 3 Smash and Generator Disablers? Because the crash is exactly the same.


yzcedit: table stretch begone

--------------------
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel
According to all.log, some sort of table related to the speed of the Dry Bones/Bony Beetle. Hence the crash.

--------------------
My YouTube channel
Get the official ASMT resource pack here!

Edit: Fix'd

--------------------
I will become alive again sometime soon.
Might be a stupid question but:

I wanted to port a level from my previous hack into my new hack, but now comes the stupid part, how do you actually do that?

Thanks,
Oh Hell No.
Go into file and search for the "make level file" thing. That'll do the trick. (Warning: none of your ASM, uberASM, ExGFX, Map16, etc will be saved with it. You'll have to transfer it yourself)

- BlackMageMario
I have a simple question. What size is the standard koopa sprite? I was thinking 16x24 or 16x32 but I am not sure.
According to the 8x8 editor, it's 16x32.
Yes, it can be 16x32 with some graphics editing.
It acts like it's 16x16, though, so don't make it too big or you'll confuse the players.

--------------------
<blm> zsnes users are the flatearthers of emulation
I just upgraded from Lunar Magic 1.5 to 2.01 and now Bg layer 3 is all messed up. By that I mean it appears as a layer of things that look like @. In the levels where it is used (i.e. ghost house) I can see outlines of what should be there.

I can disable it easy enough, but that's no good for levels where it's used (tides, fog, etc). What's more is that after a minute the "ui" (lives, coins, time etc...) gets messed up both in level and on the overworld.

Other notes: 1) There is an option for No layer 3, tried that, no dice. 2)When I save the program gave me some flak about needing an unmodded version of the rom to restore to or something. I'm pretty sure I resolved that, but I've never seen it before.

So has anyone else experienced this? I don't know enough to figure it out myself.
I have 2 problems with this sprite:

http://www.smwcentral.net/?p=list&type=sprites
Ctrl F: [Sprite] Level Teleport

1: When I teleport to another level with the same music, the boss ending theme starts to play, however, when there's a different kind of music, it works fine.
FIXED

2: I made a Switch Palace with the sprite and when the level is finished, there is no music at the Overworld.

Does anyone know what's the problem?
I can't find any of the Background GFX in the YY-CHR bin files other than the Forest Background in GFX19. Does anyone know where the rest of the Background GFX are? Or can most Backgrounds only be edited in Lunar Magic?
Originally posted by MonkeyMan
I can't find any of the Background GFX in the YY-CHR bin files other than the Forest Background in GFX19. Does anyone know where the rest of the Background GFX are? Or can most Backgrounds only be edited in Lunar Magic?


A trick: Click on this button in Lunar Magic. In the BG1 slot there is for example the number 15. Then you have to look in GFX file 15 for the appropiate tileset. For other levels, find some levels with castle, sea or hill backgrounds to find those tilesets.

EDIT 1: I've got a problem, when I complete my switch palace, there's no music on the OW. Anyone knows what could cause this problem?
I'm trying to move the X position of Mario's extended tiles. I essentially need them to show up in front of him rather than behind him. I figured the code would compare his position and add to/remove from that but I can't seem to find it. Any idea where that data is?

EDIT: Well it seems like editing the table in PC address 5EEC does the trick.
Hey, i'm absolutely new to SMW hacking and i was looking around but couldn't find an answer to my problem. I am editing the overworld, the submap for world 1 in particular and the water is colored differently than in the rest of the overworld. I created a world in the empty spaces to the right and then dragged it into the submap and the palette changed. Do I have to create the world from scratch inside the submap area to prevent this from happening?
@Khronyx

First: Welcome to SMWCentral, glad you're in our community.

It's not necessary to create the world immediatly in the submap, you can change the Overworld Palette here:
.

To go to the Yoshi's Island Submap:


You can always copy the Main Area's palette by clicking Ctrl+Left Click and paste with Ctrl+Right Click.

I hope this helps, if you have any questions, please ask them, there's always someone to answer them for you!
Thanks for the help Oh Hell No. I think i'm doing it wrong though, nothing happens when I change "current overworld palette".
The palettes where land meets water, the bridge and the brown parts are wrong. Do I touch the colors to the left in the OW palette editor? That's the only thing I haven't tried.
Pages: « 1 292 93 94 95 96281 282 »
Forum Index - SMW Hacking - SMW Hacking Help - Ask anything about SMW Hacking - 2019 Edition

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy