Banner
Views: 926,259,557
Time:
22 users online: akari1129,  Anorakun, AppleBoy54321, Daemontom, Daizo Dee Von,  Deeke, detdu, gui, Hat Kid, IanBoy,  JamesD28, jesus angel, Jeyson29, Paperdomo101, Ralshi02, SFan, Shmooples, SMWizard, TheJank, underway, Vanessa, WhiteYoshiEgg - Guests: 86 - Bots: 72 Users: 51,773 (2,052 active)
Latest: ByLHacks
Tip: Be conservative with item usage. Unnecessary throw blocks/powerups/Yoshi may leave room for unintended breaks in your level.
Not logged in.
Music Hacking/Help Thread - addmusic questions go here
Forum Index - SMW Hacking - SMW Hacking Help - ASM & Related Topics - Music Hacking/Help Thread - addmusic questions go here
Pages: « 1 2 3 4 5 682 83 » Link - Thread Closed

These are mine, though Koopa Beach is terrible, and Forest Stage could use some instrument tweaking. :/

Originally posted by spigmike
Originally posted by Aiyo
Wait what if u just insert OW music, and get he pow or star, will they keep playing? Or is it if u insert OW and Level music?


Any level that uses custom music will have the pow/star keep playing. If you have level music in your hack, but your using one of the original songs for a level, you can use a pow/star in it.

Ohhhh ok.

--------------------
Kawaii !!


Originally posted by Boingboingsplat

These are mine, though Koopa Beach is terrible, and Forest Stage could use some instrument tweaking. :/

Koopa Beach doesent function properly though.
I remember inserting it in my hack and the instruments got severly fucked up and some levels couldent load.

--------------------
Your layout has been removed.
Really? For me, Koopa Beach just looped terribly.
I have a very bad problem....

When I first inserted custom music into a smw rom everything worked great accept that music needed to be fixed a little, However though when I reinsert music back into the same rom the music disappears completely from the OW and LEVELS causing my game to crash when I press start and select to exit out of a level with the custom music. There is No custom music being played or sound if I insert it in a level...

when I import my custom music into my rom do I need to only do addmusic smw.smc INIT only once ? and when I need to reinsert the music just skip that part ? I really would like to know why my custom music is playing at all that includes 90% of S.N.N request musics.

--------------------




Make sure you only INIT your Rom once.

After you INIT, and do the nomarl addmusic, can you overrite the songs from last time? Say in 11.txt you had wing cap mario, later you changed it to metal mario, would it overrite wing cap?

--------------------
Kawaii !!


Can someone please explain to me the < and > octave stuff?
I didn't understand that part of the tutorial.

--------------------
Your layout has been removed.
When tinymm makes th mml, all of the > and <s are backwards. You have to switch them around.
Originally posted by Boingboingsplat
Make sure you only INIT your Rom once.


So your saying once I put INIT 1 time in the rom there is no need to do it again when I want add more music or replace music in my hack right ?

I was under the impression that you had to put INIT in the rom everytime you wanted music in the gaem.


--------------------




Actually, using the INIT more than once screws up the hack. So, yeah use it only one time, and after that you can insert music as often you like.

--------------------

Originally posted by Boingboingsplat
All of the > and < s are backwards. You have to switch them around.


I wish people would stop implying this. Yes, it does happen, but not always. If someone learning saw this, and converted a song, they would be severely screwed up and probably discouraged too. That's why I have been using the "sometimes" in there :)

Anyway, I may as well post all of the songs I have made for my hack here together, so I can get some combined feedback. Yes, they're all composed from scratch, and yes, it took a very long time >_> Most people have heard at least one of them, but if you have missed any along the way, now is your chance.

Andante Snowfield (OW)
The Staccato Forest (OW)
Skyway of Composers (OW)
Kingdom of Dissonance (OW)
Legato, Homeland. (Level)
Keytastrophe's Castle (Level)
Boothoven's Symphony (Level/Boss)

That's all for now, just looking for a bit of feedback and advice on them so I know what to fix. Thanks.
Hm, I never saw putting tinymml the >/<'s right. They are always wrong for me. The only thing I noticed besides that is that tinymml sometimes put them in places where no octave change is needed at all.

--------------------

Originally posted by FPI
Hm, I never saw putting tinymml the >/<'s right. They are always wrong for me. The only thing I noticed besides that is that tinymml sometimes put them in places where no octave change is needed at all.


Hmm... that's what I thought too... I thought they just coded it backwards or something...

--------------------
Your layout has been removed.
I try'ed my best to follow the tutorial but I dont know what I did wrong when trying to make this txt:

http://rapidshare.com/files/51693325/17.txt.html

--------------------
Your layout has been removed.
Originally posted by Troopa Pride
I try'ed my best to follow the tutorial but I dont know what I did wrong when trying to make this txt:

http://rapidshare.com/files/51693325/17.txt.html


Hmm.... this part looks like a problem

16o7c4o6c32>

First, it states o7, which is already an octave too high, then it goes up another one to o8. I highly doubt this song will work with smw, because it goes down to o4 at some spots too. Most instruments sound like crap under o3, so if you change o4-o8 to o2-o6 it would work, but probably sound way too low and crappy. I suggest trying a different song.

note: that part is like 1/3 of the way through

--------------------
Your layout has been removed.
I just added more music to my hack and it worked, then I decided to add more custom sprites. When I was done, I tested it and it was alright...

Then, I wanted to add more music and it just glitches. It just shows "Nintendo Presents" and then, the screen goes to black. >_<

Does this has anything to do with spritetool?

If it does, do I gotta start on another ROM and use the version that's compatible with the custom music, or I just use the same ROM and use the version compatible with custom music?
Um, try reinserting sprites with the new Sprite Tool, and if that dosen't work, get a new ROM.
Heh, just switching spritetool worked. ;)
In other news, I just finished the second last song I plan on using before I release another demo of my hack. It's another sorrowful one, because, yeah .. it kind of fits the theme.

"Discord Bells Toll"

It's 51 seconds long, so quite lengthy for a hand-created one. Please drop some feedback if you listen to it :)
Pages: « 1 2 3 4 5 682 83 » Link - Thread Closed
Forum Index - SMW Hacking - SMW Hacking Help - ASM & Related Topics - Music Hacking/Help Thread - addmusic questions go here

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks