Banner
Views: 794,969,906
Time:
11 users online: 7 up, aknightofwands, Bernardo, blocc, gohkenytp111, I don't know a good name., kamekku14, Madeline, mikairanutshack, N450, Tattletale - Guests: 31 - Bots: 169 Users: 41,487 (1,496 active)
Latest: broyourrehacksogodo
Tip: If it's possible to carry a tileset-specific sprite (such as a Buzzy Beetle or Bob-omb) through a pipe, make sure it has the correct graphics and sprite palette on the other side!Not logged in.
FuSoYa's SMB3 Screen Scrolling Pipes (v1.5.0)
Forum Index - SMW Hacking - Resource & Tool Releases - FuSoYa's SMB3 Screen Scrolling Pipes (v1.5.0)
Pages: « 1 2 »
Well... It's been almost three years since the last update. I went ahead and tested this with the most recent Lunar Magic and it works fine.
Let me know what you guys think and if you spot any errors.
Link

Originally posted by _README.txt
v1.5.0:11-19-11 (5.55 years)
Redid the block inserting code to follow smkdan's BTSD style.
Attempted to fix some bugs that the community has complained about... a lot!
Wrote a little program (C++) to change the .map16 and .dsc files to match the page the user wants.
Revamped the naming convention in pipes.asm to look somewhat nicer
Tried cleaning the whole folder so users don't look confused.
Simplified the readme.
Assured compatibility with Lunar Magic v1.90

----------

Interested in MushROMs? View its progress, source code, and make contributions here.

...Well, I already can't get them to work. The game crashes as soon as I touch a pipe tile. All I did was save a level, insert GFX and ExGFX, patch pipes.asm and noblocks.asm, and insert pipes.map16, and that happened. I don't know what I could have done wrong.

Also, you should probably change the RAM addresses the pipes use; $7FFFxx is not free RAM, or even unused in levels.
When I tried using the batch files I kept getting error messages saying I was missing a file. I looked at the copy of xkas.exe you supplied and noticed it apparently isn't version 0.06 because it had the wrong file size, so I swapped it with 0.06. That worked, but like imamelia said, the game just crashes when you touch a pipe tile.

<form action=http://google.com/search method=get> </form>

Unexpected end tag (</form>) at 627, expected </div>
options\noblocks.asm
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

I patched noblocks.asm, although I don't remember whether I did it before or after patching the main patch.
I've tested the patch and I get two results:

1. If using BTSD, for some reason, touching an pipe tile crashes the game.

2. If not using BTSD, pipes won't work, most pipes acts like cement blocks while others makes Mario fly (?) or even screw up with layer 1 (showing garbage in that screen until I leave that screen).

Also, I've tested in a Clean ROM with an good and enough FreeSpace.
Originally posted by spel werdz rite
options\noblocks.asm
Were you referring to me? If so, then I applied that before pipes.asm—I just couldn't use the included version of xkas because it said I was missing a .dll file.

<form action=http://google.com/search method=get> </form>

Unexpected end tag (</form>) at 587, expected </div>
No I wasn't referring to you (at least not directly). It's just that the descriptions you and imamelia gave sounded like that would be the problem. You guys wanna be a little more specific on how you are applying these?
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

- open fresh ROM in Lunar Magic
- save level
- extract and reinsert GFX and ExgFX
- import test level
- change ROM name in .bat files to that of my test ROM
- run pipes.bat
- run noblocks.bat
- import Map16 file
- open the ROM in bsnes 0.80
- enter level 105
- touch pipe
- BRKage
I did everything exactly as you did and did not get an error. It wouldn't be a header issue would it?
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

Nope, I tested it on a headered ROM. Could it be the version of xkas I'm using? I didn't get any error message, but you never know.

Actually, in fact, it does look like an assembling error, since I just tested it in a debugger, and for some reason, your "LDA HighBytes-!P" and "LDA LowBytes-!P" are assembling as "LDA $803000" and "LDA $813000" respectively. Some xkas-related bug that I'm unaware of, perhaps? According to the command prompt, I'm using xkas v0.06.1.
v0.06.1?

Where did you get that one? Is that the one I included?
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

No. It's just the one that happened to be in my main hacking folder. I suppose you included your version and there's some bug related to arithmetic that it fixes?
Ohh yeah that would most likely be the reason!

The define value !P = (!Map16Page*$100)

The expectation value is $148030, which is why you got $803000.
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

So then we have to use your version of xkas? It says I'm missing MSVCR100.dll from my computer... I'm not sure what to do about that.... :/

<form action=http://google.com/search method=get> </form>

Unexpected end tag (</form>) at 432, expected </div>
Try this one. I'm not entirely sure if it contains all needed changes compared to a clean xkas6, but if parentheses is the only used change, it should work fine. Guaranteed to not need MSVCR100.

--------------------
<blm> zsnes users are the flatearthers of emulation
It still crashes. :(

Edit: I mean the game, Asar works fine.

<form action=http://google.com/search method=get> </form>

Unexpected end tag (</form>) at 433, expected </div>
It's all "Touch Blocky, Get Crashy" for me in my dirty ROM, too. I'll get around to try out a clean ROM as well, but I'm guessing something is borken at this time.

In any event, is the whole "I just came out of a horizontal pipe but I'm still behind the scenery and if I jump into the bottom of the horizontal pipe I came out of I'm going to ride the pipe again and glitch the VRAM" thing fixed in this version?

All that aside, thanks for working on this again, you hater.

--------------------

[?] Miscellaneous Helpful Hints
If I moderated your hack, there was apparently a 90 percent chance it was rejected.
I still ask myself why I do when the success rate seems to be 0. All of you are the haters!
----------

Interested in MushROMs? View its progress, source code, and make contributions here.

Well, I decided to download MSVCR100.dll, put it in the folder with everything else, and try reinstalling the pipes (on the same ROM I tried before with the broken pipes, if it matters), and it appears to work... but... is there supposed to be something different about them? When you said "Attempted to fix some bugs that the community has complained about... a lot!", I assumed you meant bugs with the function of the pipes; if not, then that's unfortunate, especially considering I found another bug: if you press start + select while in a pipe, you'll lose your powerup. It's even more serious if you change the default RAM addresses to something that doesn't clear on overworld load; when you start the next level, Mario will still be invisible!

Also, about the freeram... I noticed all the addresses skip a byte; is that because they need two bytes each?

<form action=http://google.com/search method=get> </form>

Unexpected end tag (</form>) at 1156, expected </div>
Pages: « 1 2 »
Forum Index - SMW Hacking - Resource & Tool Releases - FuSoYa's SMB3 Screen Scrolling Pipes (v1.5.0)

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2019 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 7

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • SMBX Community
  • ROMhacking.net
  • MFGG