Banner
Views: 854,440,363
Time:
4 users online:  Atari2.0, lustreflux, Romano338, The Fun Police - Guests: 58 - Bots: 61 Users: 47,161 (2,476 active)
Latest: migattenobenjai
Tip: Proofread your message boxes for spelling and grammar mistakes.Not logged in.
Completely screwed
Forum Index - SMW Hacking - SMW Hacking Help - Completely screwed
Pages: « 1 »
why is it that every time i try to add back grounds or ExGFX my graphics becoome completely screwed up i had about 10 levels so far and started a new one and tried to use a new BG/FG and now my hack is completely garbled up and i cant get it back to normal? can someone please help me im almost at the point of giving up
Have you extracted and inserted the GFX before attempting to insert ExGFX? If not, do so and your graphics should be fixed.

--------------------
My YouTube channel
Get the official ASMT resource pack here!

ill just start over i guess but also i need to know if it matters what rom i use. the one i found had a sfc file extension but sprite tool cant seem to find my text file with my sprite names. sorry i just got internet back and have been away from mario hacking for awhile and i wasnt all that good back then either
DOn't!
Send over your ips thru the filebin, and maybe one of us can help

--------------------
Your layout has been removed.
A multitude of things can cause this, but most commonly it's the result of trying to insert graphics to a ROM's copy in another folder BEFORE extracting graphics and Exgfx in that folder. My suggestion is to export all the levels and map16 data to files and then insert that all into a new rom with correctly inserted ExGFX.

My apologies for bad grammar, but I'm typing on an old, slow smartphone.
how do i save the map16 data and gfx into files? maybe this is the problem i have too many folders going on. one main one with lunar in it and my custom map16s and ExGFX and GFX. a folder for sprite tool. a folder for block tool. i hate havingso many files all over the place but i hate having so many files in 1 folder even more
This happened to me when I inserted ExGFX without extracting and reinserting normal GFX. To fix the garbled graphics do the following:
-Open your rom in Lunar Magic.
-Click "File" in the upper left of the screen.
-Click "Restore".
-Click "Restore ROM to previous state".
-Find the line that says "Insert all ExGFX to ROM."
-Click the line right above it.
-Click OK.
-A warning should appear, if you click Yes, Lunar Magic will restore your ROM to the state before you inserted ExGFX, meaning that it will fix the garbled graphics, but you MIGHT lose some of your work. If you press No, that wont do anything and you will still have garbled graphics, it's up to you.
Supposing you pressed Yes, you fixed the garbled graphics but your ExGFX isn't inserted yet. Do the following to insert ExGFX without glitching your graphics:
-Click the Red mushroom at the top of the screen.
-Click the Green mushroom at the top of the screen
-Now click the Yellow mushroom to insert your ExGFX without glitching your graphics.
Hope that helped!
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Completely screwed

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy