Banner
Views: 754,555,665
Time:
14 users online: B2De, Darolac, Emerald Shell,  FPzero, IllumiNavi, izaguirrefermin28,  MarioFanGamer, Mariotag1, MMKC,  Noivern,  Pablo's Corner, pro_bot,  System, toad64 - Guests: 52 - Bots: 154Users: 39,673 (1,820 active)
Latest: kiddvenison
Tip: The lowest row of 16x16 tiles in a level do not appear. Avoid having a low platform that looks like a bottomless pit.Not logged in.
Gah. My Layer 1 tiles are a scrambled mess.
Forum Index - SMW Hacking - SMW Hacking Help - Gah. My Layer 1 tiles are a scrambled mess.
Pages: « 1 »
After putting my general level design together, I went to add things like coins and coin blocks and the like. Well, when I went to do it, everything was just garbage sprites and everything was messed up. I was pretty sure it was okay before I started... so I'm not sure what happened. I tried a lot of things, but nothing really worked.

Help would be lovely.



What do you mean it went garbage?

did you try to add ExGFX with #lm{insexgfx} or changed the original gfx and inserted them with #lm{insgfx} and got an error message while doing so?

Or did you change the index of graphics with #lm{gfxby} or #lm{sgfxby}

Or did you just rightclick to paste them?

Some more detail would be appreciated.

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Originally posted by PikBube3
-snip-

Yeah, sorry. I wasn't clear. I have ExGFX added fine, and I didn't touch the index of graphics at all. I fiddled with them to try to fix it, but nothing worked. Some levels don't have this problem, Pic 1, and this one does. Pic 2. x_x

Edit: Gah. I'm an idiot. I meant my Objects. Not my Layer 1.
Did you by some chance insert level #lm{exan} or global animation? #lm{aniset} and overwrote the coin tiles with it.

Placing custom animation above already existing ones causes both of them to sort of mix...

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Originally posted by PikBube3
Did you by some chance insert level #lm{exan} or global animation? #lm{aniset} and overwrote the coin tiles with it.

Placing custom animation above already existing ones causes both of them to sort of mix...

I didn't touch those buttons at all. So I doubt they are the problem.
Than go to the 8x8 Editor #lm{8x} and have a look at the tiles where coins usually are (6C - 6F)
If they look glithed there too than the GFX file you have in your FG1 slot is probably at fault.

How about submitting a picture of the 8x8 oder just your Rom as IPS so I can have a look at it? (you could upload it under My Files)

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Hmm. Nope. They look fine to me. Just an FYI, it's ALL of the things in the "Add Objects" window. Not just the coins.

http://oi49.tinypic.com/dcu1x.jpg

Alright, Gimme a sec. I'll upload an IPS.

http://bin.smwcentral.net/u/22120/test%2Bpatch.ips

There you are.
An image of the sprite section int the 8x8 editor doesn't help much but ok.

Anyway, if ALL of your layer 1 tiles look glitched, what about the tiles you already placed? In the screenshot they looked just fine. Or is it just BG?

Also, if you upload an IPS tell me the level number you're having problems with.

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Man. I must seem like an unorganized mess.

Anyway, the IPS is in my last post, just edited in.

And it's level 02.

Also, don't mind level 105, it's a garbled mess for testing purposes. x_x
Well, I found your problem.
In the Animation Settings #lm{aniset} you need to check "Enable original game tile animation" (First checkbox) that causes the BG to glitch up a little though.

Seeing as you probably don't want a glitched BG, you should either change it, so It won't need the glithed tiled anymore, or you learn how to make custom animations, (there are planty of tutorials here) and insert cutom animated coins in place of the original.

Edit: If you want the flashing animation of the coins back, you'll have to check the second box in #lm{aniset} too.

Also, it's not that all your Layer 1 tiles are glithed up, that's just doe to the ExGFX you inserted with #lm{sgfxby} in the FG1 slot. Couse that's where the common tiles like pipes and such are stored. Putting a different file there will of course glitch up the looks of most objects in the "Standard Object" section. (has nothing to do with the coins though)

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Originally posted by PikBube3
-snip-


Right, I see. Thanks for your help. This is sort of my first serious hack, so some things confuse me.
Well, everyone started once. Also, that's waht the forms are there for anyway

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Gah. My Layer 1 tiles are a scrambled mess.

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2019 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 23

Menu

Follow Us On

  • Facebook
  • Twitter
  • YouTube

Affiliates

  • Talkhaus
  • SMBX Community
  • GTx0
  • Super Luigi Bros
  • ROMhacking.net
  • MFGG
  • Gaming Reinvented