Banner
Views: 1,003,300,355
Time:
14 users online:  Anorakun, ASSATAKKU, CalHal,  Fernap, Flamesofshadow, h.carrell, HammerBrother, JupiHornet, MarsAmpere, Natsu, Ringo, SJandCharlieTheCat, SomeGuy712x, Spicy Jalapeno - Guests: 91 - Bots: 142 Users: 54,837 (2,033 active)
Tip: Unlike for traditional hacks and Kaizo: Beginner hacks, usage of tools such as savestates and rewinds in Tool-Assisted: Kaizo and Tool-Assisted: Pit hacks is encouraged, if not necessary.
Not logged in.
General Bugs and TODO list [Updated 6-25] (Please report all bugs here; General and Level specific)
Forum Index - Events - Super Mario World Central Production 2 - SMWCP2 Archive - General Bugs and TODO list [Updated 6-25] (Please report all bugs here; General and Level specific)
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 » Link
Yay, first contribution to the site in over ten months.

Like Wormer said, upon beating Truntec, game freezes/hangs before I return to overworld.
Also, WILL SOMEONE PLEASE FIX THE TANK BOSS. It's been broken for over a year. It can't be that hard to fix layer 2, can it?
Thank you for making Outrageous Mario World the 11th most downloaded hack on the site!

Ham Sandwich progress: v1378 (Now with more arbitrary version numbering than ZGC!) Waiting to get around to working on it again.

I occasionally stream ROM hacks on Yoshi Lighthouse's Twitch account. Be sure to check it out!

Layout by Counterfeit.
Oh, I noticed also that the life counter glitches up if you get over 100 lives. In a level it will "reset" the counter to 0 and on the OW it shows weird values of lives (like A0, B7, N5). Probably if you get more than 128 lives, you get the same glitch you have in SMB1 - the amount of lives will glitch up and "reset" to 0 which results in an instant Game Over when you lose a life. Probably using code for more than 100 lives (if it wasn't inserted yet) or just sticking to the standard 99 lives max would be good. Well, what's actually the sense of having 999 lives?

EDIT: I actually noticed that when I've got about 150 lives after beating the levels the 4th time. I died in one level and I got a Game Over, lol. Fun fact, if you die then, Mario will be walking on the OW with his dead animation. O.o

EDIT2: I made a screenshot of the glitched life counter and Mario on the OW. Yes, blame my emulator, I couldn't do a screenshot in it, so I made one fast with Paint. xd

Clicky!

EDIT3: Oh, and for the Tank Boss that AA said, it can be easily killed with cape slide/dive. Also, sprite memory issues - Mario's cape is cut off while flying.
Originally posted by AnybodyAgrees
Yay, first contribution to the site in over ten months.

Like Wormer said, upon beating Truntec, game freezes/hangs before I return to overworld.
Also, WILL SOMEONE PLEASE FIX THE TANK BOSS. It's been broken for over a year. It can't be that hard to fix layer 2, can it?


What is wrong with it? Does the boss involve any kind of ASM for the Layer 2, if not, try fixing it yourself if it is so easy and submit an update you think would work and save Lightvayne some trouble, if it is ASM gimmicky otherwise, then yes, I think it would be difficult. Screaming isn't going to get anyone anywhere, it is just annoying. #w{:s}

Otherwise, if it has been bugged for so long, I'm surprised no one has pointed it out yet. My hat's off to you.#w{=P}

--------------------
Your layout has been removed.

List updated. Thanks you Lui37 for fixing a good chuck of Music related bugs and MarioE amd HFD for fixing some sprites that were on the list

The Truntec issue I found a while back and was already on the list I have a feeling it has something to do with the music again and will take a look at it soon
Layout by LDA during C3.

Updated the list with a bunch of bugs that I found up to world 3.
Layout by LDA during C3.
For the bosses, open their asm files, Ctrl-F $1DFB and change the music number to something that exists (i.e. not 0x0B).

Yeah I already had fixed that is is currently fixed in the newest base (sorta). Turns out we don't have a boss cleared music theme yet. Torch is currently working on that one
Layout by LDA during C3.
LOL
I have nothing else to say now. Huh...
Originally posted by Lightvayne
Turns out we don't have a boss cleared music theme yet. Torch is currently working on that one

We don't? I thought I made something for that too. I think it was even inserted at one point, though it kept crashing in the middle.

@Falconpunch

I don't get it.

--------------------
Check out my music!

If we did I unfortunately don't have it.
FP was pointing out some glitched animated tiles showing up in those world( kinda hard to tell by the screen shots). The issue has already been fixed
Layout by LDA during C3.
Overall, I need to say, whoever has the backbone to run this thread, well done. The progress seems great, and am still ready to beta test when all this is over and completed :)

edit:
Originally posted by Moose
I don't get it.


I also was going to mention the glitch here anyway:

In the picture, there are strange 'X' tiles from a failed animation 8x8 tile in the Oriental and Factory submap (not sure in the list already)
Hard to see but noticable.

--------------------
I do art commissions cheap! PM here or DM via Discord for more details.

**Layout by Erik557


Couple of bugs in Frigid-Fried Frenzy.


Perhaps this would help. I know this is an edge, but it's still annoying when this happens.


This poor rotating fireball fell into the lava and became glitchy.

And finally, the slippery block doesn't seem to work on slopes. If you are on a part that isn't slippery and land on an ice slope before landing on an ice ledge, the slope won't be slippery until you touch the slippery block parts.
I have nothing else to say now. Huh...
Originally posted by Falconpunch
Couple of bugs in Frigid-Fried Frenzy.


Perhaps this would help. I know this is an edge, but it's still annoying when this happens.


This poor rotating fireball fell into the lava and became glitchy.

And finally, the slippery block doesn't seem to work on slopes. If you are on a part that isn't slippery and land on an ice slope before landing on an ice ledge, the slope won't be slippery until you touch the slippery block parts.


The first could be easily fixed I supposed. Could claim an extra map16 tile and make that act like tile 100 and put a invisible block sprite there to keep Mario from going into it, just hope it doesn't make anything disappear #w{=P}.

The second, eh, I don't really know what you mean. Rotating fireball, you mean a projectile of sorts or do you mean the reflecting fireball (that podoboo that bounces off the walls at an angle) if so, fixing this is kind of beyond my limits. It is a problem within a tilemap specific sprite, and GFX space is kind of limited. Don't know how to do anything about that, but it is a very small bug (now just watch 'em build up *shot*).

Thanks for the alerts, Falcono.

--------------------
Your layout has been removed.
Originally posted by metalgearhunter

The second, eh, I don't really know what you mean. Rotating fireball, you mean a projectile of sorts or do you mean the reflecting fireball (that podoboo that bounces off the walls at an angle) if so, fixing this is kind of beyond my limits. It is a problem within a tilemap specific sprite, and GFX space is kind of limited. Don't know how to do anything about that, but it is a very small bug (now just watch 'em build up *shot*).


Yeah, I didn't have a clue what those sprites were called. I meant the Reflecting Fireball.
I have nothing else to say now. Huh...

Both problems were fixed on my end
Layout by LDA during C3.
Originally posted by Falconpunch
And finally, the slippery block doesn't seem to work on slopes. If you are on a part that isn't slippery and land on an ice slope before landing on an ice ledge, the slope won't be slippery until you touch the slippery block parts.


You also forgot this bug, guys.
I have nothing else to say now. Huh...
Just replayed my level (god did I make this level THAT long?)

Seems like graphics file wasn't replaced


What it's supposed to be:


For one thing, yeah the torpedo teds are incorrect. For another it seems like the Sky Pop just using one frame? And is not using the correct ones? The one it's using right now is an idle frame with the Yoshi Plane sleeping. Also the torpedos shot from it is incorrect.

Here's the correct graphics file:

ExGFX1CC

So anyway to make the Pop use all three front frames? (and if it's not too much to ask to make it use the sleeping frame when it's not being rode on, and it wakes up once it does)

Also yeah I'm gonna update the level some time this weekend to cut down that uneeded area. And to fix this death room:


EDIT: Oh wow it seems like the level update I sent wasn't inserted. Eh doesn't matter now that I'm updating it again.
p-switch sprite problem quote from before.
OOPS, Before you use the p-switch version 4.5, I highly recommend version 4.6.
I found a glitch that the p-switch did not launch mario upward when it deactivate when big/fire/cape mario is inside of it, because the bottom offset only runs if mario is UNDER the block (also run when small mario or big crouching mario INSIDE it). I update this block so it uses the body, head & bottom offset and make it warp #$10 (16 in decimal) up instead of launching mario's y speed upward.

--------------------
Give thanks to RPG hacker for working on Asar.
wut
I have nothing else to say now. Huh...

Tile map fix. Also that sprite is not suppose to turn to the right which I believe was already noted down.
Layout by LDA during C3.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 » Link
Forum Index - Events - Super Mario World Central Production 2 - SMWCP2 Archive - General Bugs and TODO list [Updated 6-25] (Please report all bugs here; General and Level specific)

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks