Language…
20 users online: AntonioDosGames, Banddy, Beefy Chud, Bullymario, deported, GenMaruo, Haroz, Haruru, Hat Kid, Impetus, Jordan, LinkVideo64, LordElixs, MarioTeam, Mega,  NopeContest, ShUriK KiD, Shuttles, TCgamerboy2002,  ThirdWall - Guests: 72 - Bots: 219
Users: 55,723 (2,321 active)
Latest user: ponchotaco

ZSNES' save states are all messed-up

Hi, normally I use Snes9x, but now I'm playing VIP5 and I heard it only works in ZSNES, so I'm using that. So, I'm trying to use save states because I suck, but... they act strangely. For example, once I savestated in the middle of a room, safe and sound. When I loaded the state, it brough me at the beggining of the room, with the enemies normally at the back now being in front of me, and I somehow became small and a Feather was falling from the sky. Tried to load again (without saving inbetween) brough me back to the OW. What. The. Fuck!

I double checked, and I didn't map the rewind button to the load button by accident. My first example above never happened before I loaded, so it can't be a rewind.

I though of deleting my state file and reloading ZSNES, but then I'd lose all progress I made since the last fortress.

EDIT: Does Windows 8 have anything to do with it?

EDIT2: Another one... This time I JUST appeared in the level when I saved, and then I loaded and I was dying in a section of the level I never saw, with no hazard around.
I can just say it: I AM using Windows 8 and I have NOT got any problems. Can you show a video?

Edit: Try to (re)download (the newest version of) ZSNES.
Nope, doesn't work. I'll have to say that the savestates are only corrupt around half the time, but that's still really annoying. I can get warped anywhere, with any status, and sometimes I'm dead. I can't play VIP5 further because I have the version that crashes in the Pokemon level, so this is now useless.
May be a glitch with the hack :/
EDIT:Have you tried to use save states on other hacks, cus if you have and you have the same problem then i agree with "mario and luigi".
Hey remember me! Me neither!

a.k.a. TehUndeadSpartan222 on youtube

Chikorita is best pokemon <3

Check out my scratch(.mit.edu)! Username is MarioGamer120. Working on a Five Nights at Sugarcube Corner 2.Link




Currently: Ripping off (what used to be) MercuryPenny's footer, which is also a rip off of someone else's footer, so... I don't know if I'm like stealing a footer sence im ripping of a ripped of footer but...meh. I won't worry about it, and also celebrating 1,000 subs on youtube :D and trying to beat nightmare mode on FNAF3 and 20 mode on FNAF 1 and 2
it sounds like King Dedede has confused the save state button with the rewind button. if not, then check your paths section. i once had a similar issue, but that was a while back so i don't remember how :/.
Currently: Attending college!
I just said I didn't confuse the two buttons... |-O I double-checked, it is bound to "Q" while "Load" is on my controller, and as I said, it brings me back in scenarios that never happened, something the Rewind function shouldn't do (unless it was glitched).

Either way, as I said in my last post, this thread can be disregarded as I can't get further in VIP5 and that hack was the only reason I'd use this crap of an emulator.