15 users online: Apple Boy, ASMagician Maks, bettyfelony27,  Blaagon, Chadtronic, CKJ1983,  drspork, FantasticFox, hh0962430, imamelia, Josuke Yoshikage,  Lazy, Moronsky, SureThing, Ziz - Guests: 99 - Bots: 147
Users: 66,425 (2,327 active)
Latest user: Chadtronic

Gopher Popcorn Stew Beta (BTSD replacement) [Updated!]

Adding onto what imamelia said, I think there's something wrong with the latest update for GPS; basically, I tried to insert LX5's powerups patch into an SA-1 enhanced ROM and when trying to insert the blocks through GPS 1.4.21, it says this:

29 Shared routines registered in "routines/"
An error has been detected:
main.asm:27 (called from main.asm:38): error: (E5088): Define 'fullsa1' wasn't found.

When I used 1.4.1, that seemed to work out perfectly fine, so unless there was a routine that was missing (since that said there were 31 routines registered), I don't know what went wrong.

I commented about it in their server and one user said to post about it on here. Hopefully that issue can be fixed at some point.
I just downloaded GPS again and it works fine. If you updated from 1.4.1 to 1.4.21 make sure you replaced all the files that came with the update.
The file that contains the define that it says it's missing is defines.asm

The two removed routines were test routines that weren't supposed to be in 1.4.1 in the first place, I just forgot to remove them so there being two routines less is intended.
I now seem to be having this exact same issue with the powerups mod. I am using the newest version of gps freshly installed.
Which issue? The define wasn't found one? Can't tell you much, just make sure GPS is fully extracted and in it's own folder.
If that still doesn't work I'd need more details on what you're doing.
Hey I thought I'd post this here, but I'm having an issue with a block when using one of the routines in GPS. Basically, when using %set_item_memory, the coinhunt coin is acting like Extended Object 35, or a Question Block with wings/pwing/key/shell - while also still being collectible (and item memory is set correctly otherwise). I'm not sure if it's an issue with the macro or the coin itself, but I thought I'd plug it here. See the thread for full details.
If you're too lazy to click on the link, I already answered it as Sarcose didn't preserved and restored Y after calling the routine.

To be fair, it may be smarter to preserve Y within the routine for the next version given that many other common routines already do this.
I have a bug to report where shatter_block.asm doesn't preserve $0F which in sprites hold the current interaction point (i.e. SpriteV or SpriteH as well as which specific direction) but the routine it calls overrides $0F for its own purposes.

On top of the fact is that since PIXI officially supports custom bounce sprites, GPS also has to be updated to take them into account.