Banner
Views: 994,195,025
Time:
9 users online: Bonobi, Fury, FYRE150,  Linkdeadx2, Magmatic, OhMuramatsu, RollingRigatonis, slopcore, solgaleo35 - Guests: 30 - Bots: 140 Users: 54,513 (2,085 active)
Latest: RockslamX
Tip: Use Kipernal's Blockreator if you want to code custom blocks but you have little to no experience with ASM.
Not logged in.
Painful!!Music Patching Error!
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Painful!!Music Patching Error!
Pages: « 1 » Link
There is a .txt file I made the other day.
It's for AddmusicM.
But when it's time to patch,it points out"line 1 error"......
What should I do to solve the problem?!
The .txt file is here:Septette for the Dead Princess
BTW,this song isn't completely created by me.I found it in the hack OTL Mario and I like it very much,so I made this up and want to put it into my own hack......
Anyway,help me please...
Try changing this:

Code
t66 w255
#0

into this:

Code
#0 t66 w255
LINKS Twitter | YouTube | SoundCloud | Fortaleza Reznor
to hear birds and see none.
Originally posted by MaxodeX
Try changing this:

Code
t66 w255
#0

into this:

Code
#0 t66 w255

That's fine as-is. The real problem here is that you're missing this:
Code
;title=(insert title here)

at the top of your text file, which is required by all AMM songs. This "title" is what the song shows up as in Lunar Magic.
What? All of my AMM songs DO NOT have that tag, I removed it because I found it annoying.

I've had this problem before. What you need to do is open the txt file of a song that DOES insert and paste the code inside, then use the save as feature to save it as a .txt . AMM can be picky sometimes. I've had to deal with this with a couple songs in my previous hack.

--------------------
Your layout has been removed.
That's rather interesting. I've never been able to insert a song using AMM without that header. Of course, you may be using a different version of AMM entirely, but generally, especially considering that the error occurs on the first line, the above solution should fix it.

Edit: Just tested it; adding the ;title does indeed fix the problem.

--------------------
soundcloud / bandcamp / twitter / battle of the bits / buy our album / buy/stream my EP
Originally posted by X-cniS
Originally posted by MaxodeX
Try changing this:

Code
t66 w255
#0

into this:

Code
#0 t66 w255

That's fine as-is. The real problem here is that you're missing this:
Code
;title=(insert title here)

at the top of your text file, which is required by all AMM songs. This "title" is what the song shows up as in Lunar Magic.

I've changed it,and it seems to be patched successfully.But after I using Lunar Magic to change the song and using the Emulator,there is just no sound...Am I using the wrong version of the AddmusicM?
IIRC, AddmusicM works only with an inaccurate emulator like ZSNES or an early version of SNES9x. Which emulator are you using?
Originally posted by MarioFanGamer659
IIRC, AddmusicM works only with an inaccurate emulator like ZSNES or an early version of SNES9x. Which emulator are you using?

That's incorrect. AddMusicM should work on every emulator unless the song you've inserted breaks and this piece in particular doesn't.
According to the problem you have now it seems like you've patched the ASM files that come with AMM wrong. Try following this tutorial (remember to use an unedited ROM) and see if the problem stays after you've done all the steps written.
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Painful!!Music Patching Error!

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks