Banner
The Old-School Level Design Contest ends in
9 DAYS, 10 HOURS, 5 MINUTES AND 37 SECONDS
Views: 892,389,234
Time:
18 users online: AppleBoy54321, Cheolpeoduck, cyphermur9t, ECS.98, Far, h.carrell, jc5500, JonnyManjiro, kaigem, katun24, l_priest, Maniek, PokerFace, ScatmanJones49, The WHG Modz, VLSkoot,  Wolfguy423, Zeproide - Guests: 40 - Bots: 146 Users: 50,065 (2,330 active)
Latest: MateoHincapie
Tip: Make sure there is no stylistic clash between the graphics you choose.
Not logged in.
[Tool] LM "Addons": Layer 3 Background Editor, Visual Graphics Selector, UberASM Editor
Forum Index - Sunken Ghost Ship - C3 Museum - Summer 2014 - [Tool] LM "Addons": Layer 3 Background Editor, Visual Graphics Selector, UberASM Editor
Pages: « 1 2 3 4 5 6 7 » Link
Alright, let's try going back to the drawing board now. I installed a much more robust error handler now. Redownload here. Try running the layer 3 background editor, and then if it crashes or doesn't show up, go to "Addons/Layer3BackgroundEditor/Logs" and give me whatever the most recent file is. Hopefully that should tell me everything possible about whatever state the program was in when is crashed.

Originally posted by HackerOfTheLegend
It did the same exact thing on a clean ROM.


Alright, I'll have to look at what's up with that once I fix the crashes. If I forget, feel free to yell at me.

Originally posted by Daizo Dee Von
I keep getting an error that says "C:\Users\user\Downloads\vcredist_arm.exe is not a valid Win32 application" when I try to install that file.


You'll want the x86 or x64 versions depending on your CPU type. See the next quote.

Originally posted by Jonesy47
Even though vcredist_arm.exe didnt install, x86 and x64 did AND, bingo-bango, IT WORKS. AWESOME. SOOOOOOO AWESOME.
Weird because I could have sworn I'd installed those long ago but, apparently not...oh well! WORKS!


So we have at least one success story. I am really seriously non-sarcastically relieved here. Really. This is like a shining beacon of hope.
I should get a new layout.

Probably won't, though.
AHA! I think I have it too!
I'm really tempted to try this, but because the SA-1 sprite status bar MUST be updated, I'll pass for now.
Originally posted by Rykon-V73
I'm really tempted to try this, but because the SA-1 sprite status bar MUST be updated, I'll pass for now.


You can use it without the sprite status bar. Your backgrounds will look weird, but they'll at least be there.
I should get a new layout.

Probably won't, though.
Rykon, seriously, stop bugging about this. I'll convert soon or later that patch. If you keep bugging in the threads about converting X or Y the staff team will ban you.

--------------------
GitHub - Twitter - YouTube - SnesLab Discord
I installed what you said and it worked too! yay

Also... will you implemente .stim support? it would be great and it will be compatible with some L3 BGs on the graphics section :P
Imamelia said something earlier in the thread that I was also wondering about since it could possibly mess things up (unless its actually unused of course)

Originally posted by imamelia
- Why is the Layer 3 ExGFX patch in there? That version of the patch already includes it.
Originally posted by Pinci
I installed what you said and it worked too! yay

Also... will you implemente .stim support? it would be great and it will be compatible with some L3 BGs on the graphics section :P


I'm so glad this is working for some people at least.

And yes, I will probably add that at some point. There should be documentation on the wiki I can use.

Originally posted by mario90
Imamelia said something earlier in the thread that I was also wondering about since it could possibly mess things up (unless its actually unused of course)


Yeah, that was put in there by mistake, but it shouldn't cause any harm. It's definitely gone now, at any rate.
I should get a new layout.

Probably won't, though.
Originally posted by Jonesy47
Even though vcredist_arm.exe didnt install, x86 and x64 did AND, bingo-bango, IT WORKS. AWESOME. SOOOOOOO AWESOME.
Weird because I could have sworn I'd installed those long ago but, apparently not...oh well! WORKS!

May I ask where the x64/x86 version is? I can't seem to find it anywhere.

--------------------
Want progress on 100 Rooms of Enemies: The Nightmare Edition? Go here to see.

Are you a sample porter and wanna help with 100 Rooms of Enemies: The Nightmare Edition? Private Message me or Mellonpizza for details. Expect trading "resources" in exchange. 4 more left.




Originally posted by Daizo Dee Von
May I ask where the x64/x86 version is? I can't seem to find it anywhere.


When you click the download button, it should give you a choice to download for ARM, x86, or x64. If you're not getting that window, try a different browser or make sure JavaScript is enabled.
I should get a new layout.

Probably won't, though.
Wow nice! Except for uberASM it works :) the latest update was definitely the best.

Kipernal really deserves a Award for this.
Errrr I have a problem


Those glitched graphics are supossed to be a waterfall exanimation, what happened? :P
Originally posted by Pinci
what happened? :P

Taking a shot in the dark here, but one of the patches is probably sharing a hijack with Lunar Magic.

That or a gnome came in and messed up your graphics. They have a tendency of doing that, it's a bit bothersome.

--------------------
Originally posted by Pinci
Errrr I have a problem


Those glitched graphics are supossed to be a waterfall exanimation, what happened? :P


Interesting. I think I know exactly what's going on there, but fixing it is a little tricky.

Basically, Lunar Magic decompresses your animated tile graphics into RAM. Then at some point a little later on while the level is loading the patch comes in and decompresses its layer 3 tilemap over the same spot, overwriting your graphics with tilemap data. So they're out of order, basically--the tilemap should be decompressed first, then the animated graphics. I'll see what I can do.


Also: For anyone still having troubles, please see the first post! The tool has been updated a couple of times since its release and what seems to be the most common cause of troubles is explained up at the top along with what it takes to get everything running smoothly. Thank you.
I should get a new layout.

Probably won't, though.
Originally posted by Pinci
Those glitched graphics are supossed to be a waterfall exanimation, what happened? :P

Not kip's fault.
Check the layer 3 customizer files.

layer3hack.asm:


The readme note:


--------------------
Originally posted by Magiluigi
Originally posted by Pinci
Those glitched graphics are supossed to be a waterfall exanimation, what happened? :P

Not kip's fault.
Check the layer 3 customizer files.

layer3hack.asm:


The readme note:
Originally posted by Kipernal
Interesting. I think I know exactly what's going on there, but fixing it is a little tricky.

Basically, Lunar Magic decompresses your animated tile graphics into RAM. Then at some point a little later on while the level is loading the patch comes in and decompresses its layer 3 tilemap over the same spot, overwriting your graphics with tilemap data. So they're out of order, basically--the tilemap should be decompressed first, then the animated graphics. I'll see what I can do.


Also: For anyone still having troubles, please see the first post! The tool has been updated a couple of times since its release and what seems to be the most common cause of troubles is explained up at the top along with what it takes to get everything running smoothly. Thank you.

Thank you Magiluigi, I'll give it a try.
Now that I notice, the layer 3 is slightly translucent (take a look at the image I posted above) and that shouldn't happen :P



EDIT*

Almost done!

The status bar is the only problem I have now :P


EDIT2*


btw, when too many coin-sparkles sprites or score sprites are shown in screen the BG gets fucked up for like two or three frames, but I think it has something to do with Sprite status bar since the readme says something about that :P
Also, that 0x1B00 should probably be 0x1000...I forgot at the time that Layer 3 tilemaps aren't the size of ExAnimation files anyway, so $7F2000 should work just as well. But...technicalities.
Okay, so I fiddled around with the L3 editor a bit, and I got (read: kinda got) the background to appear correctly. Now the only problem is the bad palette, which I can't seem to fix for the life of me...
Very nice. Truly is a game changer. This unleashes limitless possibilities. I mean for example instead of turning to "third party" programs, they can be implemented right in Lunar Magic!
Plus it's very easily customisable, you just have to add to the userbars.txt
Code
LM_NEWIMAGE "Addons/music/icon.bmp"
***START***
"Addons/music/Addmusic.exe" "%1" "%2\" "%7"
1,Edit this level's music
LM_NOTIFY_ON_NEW_ROM LM_NOTIFY_ON_NEW_LEVEL LM_USEIMAGE_LIST
***END***




Like that, just make a little music note or something for the icon and (theoretically) can add custom music right through Lunar Magic. Plus you can do this for sprites, blocks, and even am4,brr,spc players directly in Lunar Magic, very well done. And I did get mine to work after installing the Visual C++.

Another example (video this time) of just how easy it is to implement.
Video
Blocktool as a toolbar in Lunar Magic.

--------------------

Someone with far more coding knowledge than myself should write plugins for ALLLL the major tools that have been released for Super Mario World hacking so they are integrated seemlessly into Lunar Magic, *cough, hack*POWERTOOL*sniffle,cough*...god, I wish I could figure out how that works...

But seriously, if all the major tools had Lunar Magic Plugins, that would be crazy.

This is an awesome step in the direction of that glorious, easy to use future.
Pages: « 1 2 3 4 5 6 7 » Link
Forum Index - Sunken Ghost Ship - C3 Museum - Summer 2014 - [Tool] LM "Addons": Layer 3 Background Editor, Visual Graphics Selector, UberASM Editor

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks