Banner
Views: 859,496,422
Time:
19 users online: Agatha, AnisSaouliBH, autisticsceptile1993, Dark Prince, DeppySlide,  E-man38, Epic_Manky, Evernn, FrozenQuills, Gammed Z, Infinity, josee_544, le4che, MassPunishment, Mr. MS, quietmason, Swaguy14256, Thiago678, WMS95 - Guests: 115 - Bots: 77 Users: 47,502 (2,201 active)
Latest: Markgabriel01
Tip: Do not set the music bypass to 00 in a level with a P-switch/star; the music will endlessly loop.Not logged in.
Sound Effect Echo?
Forum Index - SMW Hacking - SMW Hacking Help - Sound Effect Echo?
Pages: « 1 »
I've been working on my SMW hack, and i don't know how to make Sounds echo (for exmple in underground levels)

I use AddmusicK, by the way (since it's the only Addmusic i find)

lel first post lel


EDIT: I read the readme, i just don't know where too look. (im dumb k)
DOUBLE EDIT: Nvm it worked :D yay echo.
Originally posted by AMK's readme

My sound effects aren't echoing correctly!


By default AddmusicK disables echo for sound effects. This is so that, for example, if you're using a song in a sky level, and that song uses an echo effect, your sound effects won't also echo and sound weird. To turn echo on, here is what you do:
  1. Download uberASM from SMWCentral's patches section.
  2. In the "code" folder, open up "level_init_code.asm"
  3. You should see a bunch of labels that look like "levelinit0", "levelinit1", etc. Go to the label that corresponds to the level you want echoey sound effects in. For example, for level 105 you'd go to "levelinit105".
  4. Insert this code after the label but before the RTS:
    LDA #$06
    STA $1DFA


    So all in all, that part of the file should look like this (if we're using level 105):
    levelinit105:
            LDA #$06
            STA $1DFA
            RTS
    levelinit106:
            RTS

    (etc.)

  5. And that's it! Patch uberASM to your hack, and just repeat steps 2 - 5 for any level in which you want sound effects to echo.

Next time, read the read me when you ask questions about AMK. ;)

--------------------
Okay, my layout looks ugly.
Thanks...
Now the rom is pretty messed up..
I think it's either Xkas' fault or mine but i did everything right..
I also tried Asar but it had some errors.




The sound did echo though ;)
The xkas version of uberASM is pretty glitchy. The readme states that the asar version is strongly recommended, did you read the whole thing?
Originally posted by MercuryPenny
The xkas version of uberASM is pretty glitchy. The readme states that the asar version is strongly recommended, did you read the whole thing?


Yea, i tried Asar too and i had to do some stuff to make it work.
Did you have patched the xkas version and then the asar version in the same rom? If so, then restore the hack or if you made a backup, use that and just patch the asar version.

--------------------
Okay, my layout looks ugly.
Originally posted by MarioFanGamer
Did you have patched the xkas version and then the asar version in the same rom? If so, then restore the hack or if you made a backup, use that and just patch the asar version.

No, i had a backup of my rom, and i tried them differently
Originally posted by Leo
Yea, i tried Asar too and i had to do some stuff to make it work.

What exactly, then? Can you show us what it said to do, and what you did?

--------------------


 
Originally posted by WhiteYoshiEgg
Originally posted by Leo
Yea, i tried Asar too and i had to do some stuff to make it work.

What exactly, then? Can you show us what it said to do, and what you did?

..try a newer version :P
I had a really old one.
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Sound Effect Echo?

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy