Banner
Views: 838,275,824
Time:
20 users online: BrownBuddy, buggy789, Eminus, gabizeh41e3luigi, HaruMKT, Hat Kid, Ice Man, idealiter, mario90, Matheus2653, Mau, ModernKiwi, Sancles, shaoshao, SimFan96, StarWolf3000,  Telinc1, TheBiob, TheInsanity115,  xHF01x - Guests: 75 - Bots: 66 Users: 45,869 (3,416 active)
Latest: nonomannn
Not logged in.
Small Snes9x 1.43 issue
Forum Index - SMW Hacking - Works in Progress - Kaizo Hacks - Small Snes9x 1.43 issue
Pages: « 1 »
Hello, some of you may know me as a small time pit hack TASer/creator. Long story short, I got a new laptop and I have re-downloaded Snes9x and other files, however I've encountered a problem.

When I'm playing with slowdown and I use the "Pause" feature (like frame advance), if I want to save, I need to press my save button twice for it to register; same with loading.

Anyone had this problem? I'm using "Snes9x Rerecording 1.43 v18".

Thanks in advance, I'll take down this thread once the problem has been resolved.
Hey! Good to see you back!

Isn't there a snes9x-rr 1.53? If so, use that.

Maybe it just has to do with the kind of keyboard that the laptop comes with. Beyond that I have no clue.

P.S. - Any hack projects from you lately?


Originally posted by SuperAgentYoshi
Isn't there a snes9x-rr 1.53? If so, use that.

No, there isn't. Partly because 1.53 isn't very well made, so most TASers prefer to use either 1.43 or 1.51.

Anyway, it sounds like it's probably a keyboard issue. Because of the way keyboards work, if you try holding down certain keys together, it will "ghost" (not register) some of the keys. For instance, on my keyboard, if I press the left, down, and right arrow keys together, whichever one I press third gets ghosted.

If that seems like the problem you're having, then you might want to rearrange your control setup to work around it. If you can, try to avoid using keys in the same row or column.

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Are you back to SMW? If yes, nice!

Anyway, you probably should use Snes9x 1.51 or 1.52 / BizHawk / lsnes. Those emulators have pretty much the same amount of lag during the same gameplay, but version 1.43 under-emulates it. No wonder why it's banned at TASVideos.

BTW, if you have the partial smv of my Item Abuse TAS (done with 1.43, oh the irony!), can you PM it to me?

--------------------

SMW TAS'er. My pages:
New TAS blog - old SMW Blog, Youtube - Twitter
Edit: Just retried, when I have paused I still have to press my save button twice for it to save, even when I'm holding down no other buttons. I'll try BizHawk.

I'm afraid I have no data of anything whatsoever, new laptop. My university has started up a Retro Games Society, and there has been some interest in the rom hacking scene, so I decided to redownload everything and try stuff out. If I can solve my button-based problems, and if there are any recent (decent) Kaizo/Pit hacks out, recommend them to me and I might give them a go =P

As far as making hacks go, I'm incredibly technologically inept (as you may have noticed) so I may indulge in some creative concepts if I can collaborate with someone capable of adding custom stuff. But this is thinking very far ahead...

Thanks for all your help :)
Pages: « 1 »
Forum Index - SMW Hacking - Works in Progress - Kaizo Hacks - Small Snes9x 1.43 issue

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy