Banner
Views: 958,969,231
Time:
29 users online: AbeLinkn, AppleBoy54321, ASSATAKKU, Aurel509,  Ayami, bd90492, Big Brawler, buggy789, Children's Digest 1950-2009,  Doctor No, DooTCraft, ECS.98, Fettin, FYRE150, GigaCrash, Koopster, LadiesMan217, Lmao, LMPuny, MarioriaM, melvin_r, mmBeefStew, ModernKiwi, Natsuz2,  Ninja Boy,  NopeContest,  Segment1Zone2, Sixcorby, The_Uber_Camper - Guests: 85 - Bots: 72 Users: 53,109 (2,253 active)
Latest: Jolle457
Not logged in.
Intro Level is looping forever
Forum Index - SMW Hacking - SMW Hacking Help - Intro Level is looping forever
Pages: « 1 » Link
Like the Title sais: The intro-Level is looping forever and you dont get to the Overworld. This appeared random. I dont know, what could make that happen. I already tried, removing the "Display Message1" Generator and place a normal Exit in the Level, but i also loops. I have no clue. Someone had a similar Problem?

How does it look like? An often problem occurs when the player dies in the intro level.
@AlwaysANoob: I guess, he doesn't mean the intro demo title screen but that level after you selected a new file.
Originally posted by MarioFanGamer
@AlwaysANoob: I guess, he doesn't mean the intro demo but that level after you selected a new file.


The intro demo? I'd call that more the "Title screen level" or "Title screen demo" and call that level after you selected a new file the intro demo indeed... Or intro level.

I'm sorry to not contribute more than to discuss word usage. It's bothering me. :o)

--------------------


Originally posted by MarioFanGamer
@AlwaysANoob: I guess, he doesn't mean the intro demo but that level after you selected a new file.


Now I look like a right idiot...

--------------------
( ͡° ͜ʖ ͡°)( ͡° ͜ʖ ͡°)( ͡° ͜ʖ ͡°)( ͡° ͜ʖ ͡°)( ͡° ͜ʖ ͡°)
Current Project: Vanilla Rendezvous, my project. Click here to see the C3 thread.

Finally back and more active than ever!

Quest on Full Moon Island 2

Go watch GamingWithDrew at http://www.twitch.tv/gamingwithdrew

My Backloggery

Yes, i mean the level, when you start a new file.
When the text-box appears, it loads the level again and loops forever. Looks like,when the Game is supposed to load the Overworld, it loads the Level instead. Does anyone know, how to fix that?

What patches did you applied? When ever there are weird problems nothing related to custom sprites, blocks, etc. there might be a problem about an inserted patch.

@Niamek: Okay, changed the word.
I didnt apply a patch. I made some Custom Blocks, BUT they worked before. I have no idea. I just began with a new Level and when i wanted to test it, that happend ...

Is your ROM clean? If not, then I'm not sure.

--------------------
100% Orange Juice Playthrough:
https://www.youtube.com/playlist?list=PLf1kPWkjcurtA3xPP3TybfqSiEn1AcX2A

VLDC9 Playthrough:
https://www.youtube.com/playlist?list=PLf1kPWkjcurtiP5de_-e6q0hSVrY37RB-.


I remember this happening to me after inserting some sprites. Did you insert any?
@MarkD
No. Like i said, i edited the Rom. (Levels, Map16, ...)
@S.R.H.
Nope. I didnt insert any Sprites.
I just edited: Map16 , Palettes, Levels, Overworld some Graphics and added some blockreactor-made-blocks with btsd.
And like i said, all i edited , worked before. Just happend, when i started editing a new Level.

Should i upload the File, so someone can look into it? :(

Yeah upload a file or a video so people can see what's actually happening.
There are a handful of things that might cause this. A video of your intro level in its entirety would be great, yeah.

If you did anything fancy in the intro level (as opposed to leaving it mostly identical to Welcome to Dinosaur Land), then some things could screw with the level settings it's expected to have.
Here you can download the ips.
http://loewenpower.flow4.com/smwtest.ips

http://loewenpower.flow4.com/smwtest.ips

Except for maybe changing something in the ROM that you shouldn't have I have no idea.

I'd say port over to a new rom and insert all your blocks and everything else 1 thing at a time to see if it breaks again.
Ok. I try that tomorrow. :)

Is this still an issue? If it is, you could fix this issue (and potentially introduce others related to switch palaces) by using a hex editor and changing thee three bytes at 0x1BE4C to EA EA EA.

You should be concerned however with how and why there is code executing there, as in a stock LM ROM, there is nothing there.
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - Intro Level is looping forever

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks