Banner
Views: 843,835,026
Time:
24 users online: Amine Retro, AnasMario130, brickblock369, BWGLite, chickaDEE Magazine, DasFueller, Green Jerry, Hayashi Neru, JanitoGamer21,  KevinM, KiloMinimo, LeaderAngelo, Light, Lotica, Mario and yoshi,  Maxodex, Miku, muztvarxiv, Nowieso, Raymondsze, SuperHack64,  Telinc1,  Teows, Zidan3 - Guests: 77 - Bots: 86 Users: 46,378 (2,817 active)
Latest: RandomBlox47
Tip: Use the Iggy/Larry Battle Tools to edit Iggy/Larry's platform.Not logged in.
Custom Powerups v3.4.2 - Improvements galore part 1
Forum Index - SMW Hacking - Resource & Tool Releases - Custom Powerups v3.4.2 - Improvements galore part 1
Pages: « 1 219 20 21 22 23 24 25 26 27 28 29 »
Never Eat Shredded Wheat.

Lx5, I don't know how you coded the coon, but I have been working on perfecting the cape into the racoon tail (close to smb3 as possible.). To do this I've used the better raccoon patch and thomas's mario physics modifyer patch. Obviously the patches wont help you much, but the modifyed numbers might. So if you want them just let me know.
I'm inserting the blocks through GPS and I get an error message at this part in the hammer_suit file:
Code
SpriteShared:
	%sprite_block_position()

and the error message is a "broken macro usage."
How can I fix this?
uhhhhhh
im making smb3 styled gfx for this
I am the leader of a group of weeaboos at school, send help.
Updating your GPS to the latest release might fix your problem.

Also thanks for your comment ShoeKuribo, but if you're making graphics, we would appreciate seeing progress on those graphics instead of you just posting that you're making them.
alright but im still in the porting process of bringing the 16x8 graphics to 32x32
I am the leader of a group of weeaboos at school, send help.
I have a issue, whenever Mario goes up on the worldmap, his graphics glitch out like crazy, but when he goes left, right, down and his climbing animation works pretty fine. Do you know the issue to this?

--------------------
To reach the question, you must address the answer.
It's due to the 32x32 graphics, if you have a "ow_mario.asm" file then patch it to the ROM.
I am the leader of a group of weeaboos at school, send help.
Originally posted by Westretroman
I have a issue, whenever Mario goes up on the worldmap, his graphics glitch out like crazy, but when he goes left, right, down and his climbing animation works pretty fine. Do you know the issue to this?


Here's a more specific answer for anyone else having this issue - thanks ShoeKuribo for putting me on the right track.

You need to download the 32x32 tilemap kit patch from here: https://www.smwcentral.net/?p=section&a=details&id=11308

In the ZIP is the ow_mario.asm patch you need to apply, it doesn't require any freespace so just go ahead and apply it.

Lastly, you just need to apply the Mario-taking-a-step 16x16 tiles from tile 0x20 and paste them over tile 0x4C (the unused bluebird graphic) in graphics file GFX10 (or your overworld SP1 of choice). You can do this easily in the 8x8 graphics editor in LM by setting one of the graphics entries to be GFX10 in the Super GFX Bypass menu, or just use a tile editor like YYCHR.

Edit: I went ahead and uploaded a GFX10 with the fixes for the Mario walking up and level reveal starburst graphics. You still need to apply that ow_mario.asm patch first though!
https://bin.smwcentral.net/u/33/GFX10.bin
Oh yeah, I was also working on smb3 mario graphics for this patch but kinda forgot about it.



Download

Its not finished and Im not gonna finish it, but if anyone wants then go ahead.

--------------------




So can we be expecting a GIEPY version to come out soon?

Also, does your power-ups still allow for MarioExGFX and stuff? Like using UberASM to change player graphics on a per level basis like the previous versions?
Hmm, been following the readme for the latest version of this patch, and it works really well on a non SA-1. However, on an SA-1 ROM, I seem to get the following errors when trying to apply the patch with ASAR:

Code
powerups_files/main_engine.asm:14: error: Define !ducking_flag not found
powerups_files/main_engine.asm:15: error: Define !slide_flag not found
powerups_files/powerup_main_code/powerup_06.asm:38 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_06.asm:53 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_06.asm:71 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_06.asm:94 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_06.asm:115 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:39 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:54 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:72 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:95 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:116 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:125 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:137 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:140 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:147 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:156 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:164 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:166 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:181 (called from powerup.asm:167): error: Define !power_ram not found
powerups_files/powerup_main_code/powerup_07.asm:184 (called from powerup.asm:167): error: Define !power_ram not found


Do you know why this might happen, or what hasn't been set up properly to cause the issue?

Because I'd really like to use this on my current project, but SA-1 compatibility is a must.

--------------------
For gaming news and Wario discussions, check out Gaming Reinvented and Wario Forums respectively.

As for Mario's Nightmare Quest? Well, it's currently on Fusion Gameworks, ROM Hacking.net or the GCN at the moment.
Is this SA-1 compatible?
I am the leader of a group of weeaboos at school, send help.
v3.x.x versions aren't compatible with SA-1, at least not fully compatible. I haven't tested the compatibility at all.

Also, expect an update Soon.
Finally an update!

This one adds several powerups, tweaks and fixes, making it a big release.
This version also needs to be applied to a CLEAN ROM, otherwise some bad things may happen!

The update includes:
- SA-1 Support, requires asar 1.60 or newer.
- Ice, Bubble and Cloud flowers.
- Several graphical fixes (mostly OW fixes).
- Several minor optimizations to the core files.
- Minor tweaking to some powerups.
- Information about the powerups added to the readme.
- UberASM Tool codes.

Known issues:
- The water splash effect is misaligned for Mini and Frog Mario.
- Frog Mario still has weird physics to some people.
- The wallrunning poses are misaligned.
- Items spawned from Yoshi eggs doesn't load their GFX.

I've included two different .bps files in this release, one of them uses Fast ROM addressing and the other one uses SA-1 Pack 1.26.
When playing either of the bps files, you can change the current powerup in the OW with L/R. Note that it's experimental and may crash/not work correctly.

There's a playlist containing videos for each powerup here.

Also, this is the last update where I include new powerups made by me, I'll still update the pack with fixes, tweaks and powerups made by other people whenever I have time.
There are two missing files in the patch that will be included in the next version, meanwhile you can download them here:

SolidSprite.asm, goes in PIXI's routines folder.
GFX10.bin
defines.asm, it should replace GPS's defines.asm file.
Originally posted by LX5
Frog Mario still has weird physics to some people.

I know Frog Mario has some strange physics but it’s the same power up from bio’s Powertool.

Look at this video Frog Mario has the same weird physics. I like him with more longer run hopping with new SFX on land and better swimming moves with no diagonal movement exactly like in SNB3.
Nice to see fine tuning this. The videos are impressive!
So, I'm still using PowerUp Pack v2.1.0. I just don't want to port all of my tilemaps to 32x32 format because I had enough trouble making these fit in 16x32 :P

With this version, there are some issues when using Cape Mario. Regardless if Mario dies using Raccoon/Tanooki/Cape Suit, small Mario appears that glitched cape in death pose and overworld border until he enters a level again.



Can someone please tell me how do I fix that glitch? I heard that this happens because there is some cape reset code missing somewhere.
I don't want to sound like a douchebag, but I asked LX5 for support via PM, first time almost 1 month ago, then I asked him via PM and via forums almost 1 week ago, and so far not a single reply.

I know that people are busy with life stuff, but I guess it wouldn't hurt if I could at least get an answer (yes/no/perhaps). Am I asking too much if there's a way to fix that annoying glitch?

I think that instead of implementing more and more features, it would be a good idea to fix what has been done before jumping into new stuff, just saying... #tb{>:(}
I stopped giving support on 2.x.x versions once 3.y.y versions were released, I believe I mentioned that somewhere in SMWC (either here or in a C3 thread.

Anyway, that glitch might be possible to fix in 2.x.x versions by hiding the cape OAM tile when Mario is dying.

Code
	lda #$F0
	sta $0321


To fix the ow issue would be the same thing, but only for small Mario or any other Mario form.

Code
gamemode_0E:		;maybe sticking it to other ow gamemode codes would work?
	ldx $19
	lda cant_show_cape,x
	lsr
	bcc +
	lda #$F0
	sta $0321
+	
	rts

can_show_cape:
	db $01,$01,$00,$01,$00,$00,$00,$01
	db $01,$00,$00,$00,$00,$00,$00,$00


A similar code can be used for in level code:

Code
gamemode_14:
	lda $71
	cmp #$09
	beq +
	lda $13E0
	and #$3E
	bne ++
+	
	lda #$F0
	sta $0321
++	
	rts


I can't guarantee that it will be 100% fixed with these codes. Also, there should be a better way to do this, but I'm not going to go back to an older version and fix that issue. You might want to change !cape_settings in these codes instead of the hide cape tile code if the issue isn't fixed.

Originally posted by Yan
I think that instead of implementing more and more features, it would be a good idea to fix what has been done before jumping into new stuff, just saying... #tb{>:(}


Of course I fixed it in 3.y.y, except I had to redo the code in order to have full control over the cape to be able to implement powerups like the small cloud when using the Cloud Powerup and the Propeller Suit small propeller.
Pages: « 1 219 20 21 22 23 24 25 26 27 28 29 »
Forum Index - SMW Hacking - Resource & Tool Releases - Custom Powerups v3.4.2 - Improvements galore part 1

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy