Banner
Views: 828,615,142
Time:
32 users online: 7 up, Alex No, Anorakun,  Atari2.0, brokedog523, chickaDEE Magazine, ExONightZ, expgst, Fermín Acosta Jr., fliksn, FrozenQuills, Ice Man, imamelia,  Linkdeadx2,  MarioFanGamer, Minish Yoshi, Mr. MS, NathanWarford, Nowieso, OnyxFusion, OrangeBronzeDaisy, qantuum, Redwykelz, Serge2122,  Sinc-X, StackDino, Stivi, succo,  Tahixham, TheMorganah, YinYarn, yoshii - Guests: 86 - Bots: 109 Users: 44,388 (2,540 active)
Latest: br1ck4
Tip: Don't put levels in overworlds that don't match (like a snowy level in a desert).Not logged in.
Effect Tool 2.0.1 (redownload recomended)
Forum Index - SMW Hacking - Resource & Tool Releases - Effect Tool 2.0.1 (redownload recomended)
Pages: « 1 2 »
That's the right image then. And that's what I tried at first too, still black screen.
e: I tried again, once on a map (which is what I really want) and once on a level. Results: map - level. None of those are right, as you can see. #tb{:(}
Parallax Scrolling is not working for me, yet i'm sure i'm doing it right...

Here's the code. I've JSR'd "GrassParallax" if that helps. This all goes in level_init_code.asm, right? I don't want to get all mixed up with this.

--------------------
What-A-Blast! - My WIP Super Mario World hack
**Layout by Erik557


Originally posted by Ruberjig
Parallax Scrolling is not working for me, yet i'm sure i'm doing it right...

Here's the code. I've JSR'd "GrassParallax" if that helps. This all goes in level_init_code.asm, right? I don't want to get all mixed up with this.


Quote
;IMPORTANT! Please edit the JMP command below for the level you use this on


Also, no it does not all go to init.
.InitCode goes in init and .level105MainCode: goes in main (possibly after editing the name.)
That said, why does it use sublabels if you jump there? That's odd. Try also to remove the '.' in front of the level105MainCode for both, the label and the JMP

Originally posted by Berkay
That's the right image then. And that's what I tried at first too, still black screen.
e: I tried again, once on a map (which is what I really want) and once on a level. Results: map - level. None of those are right, as you can see. #tb{:(}

I'll look into it once I find the time (and motivation), for now, do you have any other uber/level asm going on there? Like maybe other HDMA on the same channel or freeRAM?

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
Originally posted by JackTheSpades
Do you have any other uber/level asm going on there? Like maybe other HDMA on the same channel or freeRAM?
No, I tried it on a clean ROM with nothing but uberASM and the windowing code.
Originally posted by JackTheSpades
Originally posted by Ruberjig
Parallax Scrolling is not working for me, yet i'm sure i'm doing it right...

Here's the code. I've JSR'd "GrassParallax" if that helps. This all goes in level_init_code.asm, right? I don't want to get all mixed up with this.


Quote
;IMPORTANT! Please edit the JMP command below for the level you use this on


Also, no it does not all go to init.
.InitCode goes in init and .level105MainCode: goes in main (possibly after editing the name.)
That said, why does it use sublabels if you jump there? That's odd. Try also to remove the '.' in front of the level105MainCode for both, the label and the JMP

Originally posted by Berkay
That's the right image then. And that's what I tried at first too, still black screen.
e: I tried again, once on a map (which is what I really want) and once on a level. Results: map - level. None of those are right, as you can see. #tb{:(}

I'll look into it once I find the time (and motivation), for now, do you have any other uber/level asm going on there? Like maybe other HDMA on the same channel or freeRAM?


still not workin...

--------------------
What-A-Blast! - My WIP Super Mario World hack
**Layout by Erik557


Have you ever thought of open sourcing this app on GitHub? I'm sure a few people would like to explore this code, myself included.
Unfortunately Effect​Tool Crashing many times when I selected Window and select any layer... It crashes.
Testing I'm with my Windows XP and installed NET Framework 4
Try .NET 4.5 and make sure the .dll files are in the same location as the .exe

--------------------
Anime statistic on MyAnimeList:
400 animes completed ✓
6000 episodes completed ✓
100 Days completed ✓
... what even am I doing with my life?
I'm using .NET 4.1 for Windows XP SP3
.NET Framework 4.5 Doesn't support Windows XP SP3.

I'll be try Windows 7 or higher. It works fine!
Would it be okay if you could, y'know, update this so that it can generate codes for uberASM Tool so that we WON'T have to change the RTS to RTL every time? Would be nice.

And where's the circle tab? I don't see it anywhere.

--------------------
My Mode 0 guide.

My Discord server. It has a lot of archived ASM stuff, so check that out!

Would be nice to have an update for this by now, eh?

--------------------
Are you an ASM coder and want a boost on your Steam, Switch, PS4, or Xbox One accounts? Private Message me for details.
(I also offer SMW Custom Songs in exchange for ASM! I don't do ports though unless it's to remix.)

Want progress on 100 Rooms of Enemies: The Nightmare Edition? Go here to see.

Are you a sample porter and wanna help with 100 Rooms of Enemies: The Nightmare Edition? Private Message me or Mellonpizza for details. Expect trading or boosting in exchange. 4 more left.




Hello. I tried to use this tool to insert BG Gradient. But BG Gradient Window is strange on my PC.

The rest of the tabs are fine but BG Gradient is the only problem.
Can I find a solution?? Thank you.
This seems like a window scale issue, try going into your window's display settings and changing the scale to 100%
Originally posted by MM102
This seems like a window scale issue, try going into your window's display settings and changing the scale to 100%

Thanks for giving me a solution. I changed the scale to 100% and then restarted the program. But it has the same problem like this.
The letters have only gotten smaller as you can see.
Originally posted by scratch
I changed the scale to 100% and then restarted the program. But it has the same problem like this.

Sometimes changes to the scaling won't take effect until you log out of your computer and then log in again. Have you tried that?

--------------------


 
Originally posted by WhiteYoshiEgg
Originally posted by scratch
I changed the scale to 100% and then restarted the program. But it has the same problem like this.

Sometimes changes to the scaling won't take effect until you log out of your computer and then log in again. Have you tried that?

Oh, I forgot to write it down. I definitely restarted my PC.
Also, I tried it on another computer which is always 100% scale. But the result was same.
Is this tool supported Windows 10? All the captures up there is on Windows 7.
Pages: « 1 2 »
Forum Index - SMW Hacking - Resource & Tool Releases - Effect Tool 2.0.1 (redownload recomended)

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 16

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy