Banner
Views: 932,215,736
Time:
15 users online:  1UPdudes,  Amethyst, Daizo Dee Von, Desert, edgar, Geno7, Golden Yoshi, Gulaschko, hendog30_, Kitikuchan, MegaSonic1999, Parahax, RPG Hacker, spooonsss, WhiteYoshiEgg - Guests: 78 - Bots: 315 Users: 52,038 (2,101 active)
Latest: riverrunner836
Tip: Make a backup of your hack before using any external tools on it so you can revert to a previous version should anything go wrong.
Not logged in.
hdma mosaic issues with zsnes
Forum Index - Non-SMW Hacking - Misc. ROM Hacking - hdma mosaic issues with zsnes
Pages: « 1 » Link
Hi there,

I have troubles making a hdma mosaic effect bugfree with zsnes. It is for LoZ, but I hope that people can help me with it nevertheless:


It works great with bsnes/snes9x:


But zsnes seem to not like that mosaic effect


Can somebody help me with it? Here's the patch:
http://www.filedropper.com/mosaic
Just patch a "Legond of Zelda - A Link to the Past (USA)" without header with this patch and cheat with 7e009b-F0 to enable the mosaic effect

The original author is MathOnNapkins, and I have this code sniplet, in case it helps:

Code
    !mosaic1 = $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12
    !mosaic2 = $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02
    !mosaic3 = $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02
    !mosaic4 = $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02, $02, $02, $12, $02

Chan4TableAddrs:

	dw Chan4Table0, Chan4Table0, Chan4Table0, Chan4Table0
	dw Chan4Table1, Chan4Table1, Chan4Table1, Chan4Table1
	dw Chan4Table2, Chan4Table2, Chan4Table2, Chan4Table2
	dw Chan4Table3, Chan4Table3, Chan4Table3, Chan4Table3
	dw Chan4Table0, Chan4Table0, Chan4Table0, Chan4Table0
	dw Chan4Table1, Chan4Table1, Chan4Table1, Chan4Table1
	dw Chan4Table2, Chan4Table2, Chan4Table2, Chan4Table2
	dw Chan4Table3, Chan4Table3, Chan4Table3, Chan4Table3
    
Chan4Table0:

	db $F0
	db !mosaic1, !mosaic1, !mosaic1, !mosaic1
	db !mosaic1, !mosaic1, !mosaic1
	db $F0
	db !mosaic1, !mosaic1, !mosaic1, !mosaic1
	db !mosaic1, !mosaic1, !mosaic1

	db $00

Chan4Table1:

	db $F0
	db !mosaic2, !mosaic2, !mosaic2, !mosaic2
	db !mosaic2, !mosaic2, !mosaic2
	db $F0
	db !mosaic2, !mosaic2, !mosaic2, !mosaic2
	db !mosaic2, !mosaic2, !mosaic2

	db $00

Chan4Table2:

	db $F0
	db !mosaic3, !mosaic3, !mosaic3, !mosaic3
	db !mosaic3, !mosaic3, !mosaic3
	db $F0
	db !mosaic3, !mosaic3, !mosaic3, !mosaic3
	db !mosaic3, !mosaic3, !mosaic3

	db $00

Chan4Table3:

	db $F0
	db !mosaic4, !mosaic4, !mosaic4, !mosaic4
	db !mosaic4, !mosaic4, !mosaic4
	db $F0
	db !mosaic4, !mosaic4, !mosaic4, !mosaic4
	db !mosaic4, !mosaic4, !mosaic4

	db $00
The problem appears to be that ZSNES is an inaccurate emulator, and some code that works for it won't work for accurate emulators like bsnes, and vice versa.
thx to e r i k for layout
Yes... I was hoping that somebody with experience with hdma could give some advice how to make it work with zsnes, it is not so that zsnes can't emulate hdma.

Like, a register must be reset, some bytes rewritten, or any other workaround. The effect also works to 50% in zsnes, only some tiles make troubles.

I hope somebody can find the issue :)
Ah, Euclid solved it:
Zsnes -> config -> options -> uncheck "use new gfx engine"

Then it works flawlessly :)
Pages: « 1 » Link
Forum Index - Non-SMW Hacking - Misc. ROM Hacking - hdma mosaic issues with zsnes

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2021 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks