Banner
Views: 992,614,633
Time:
9 users online:  Anorakun,  Ayami, Lost_Kiddo, marksands, Paperdomo101, RainbowLuigi281, SF - The Dark Warrior, ShadowBoxer_Sandshrew, Yoshi Master - Guests: 64 - Bots: 165 Users: 54,445 (2,086 active)
Latest: sdpo123
Tip: ExAnimation also works on sprites!
Not logged in.
Official German Thread (Deutsche SMW-Ecke)
Forum Index - SMW Hacking - SMW Hacking Help - Official German Thread (Deutsche SMW-Ecke)
Pages: « 1 2 3 4 529 30 » Link - Thread Closed
Hm, bei den Hammer Bros. kann ich mir nur vorstellen, dass du die tilemap in der .asm Datei ändern musst. Welche ExGFX hast du denn dazu runtergeladen? Dann könnte ich dir mehr helfen.
Ich glaube, beim Hammer Bruder musst du den Tilemap in SP4 einfügen, der Autor muss da einen Fehler gemacht haben.
Ne, Hammer Bros. kommmen immer in SP3. SP4 ist für Sledge Bro, Giant Koopa/Spiny/Goomba/Piranha und andere Sprites, aber die Bros. wie z.B. Boomerang, Fire, Hammer, Shell kommen in SP3^^
Naja, bei mir haben die in SP4 funktioniert. :/

Kann aber auch sein das ich die von Cory's Tutorial benutzt habe. >_<
Da haben wa es. :P Cory's Tutorial is wohl anders, weil wenn du in Sprite Tool's "tilemap" Ordner guckst, siehst du das hier:

hammer_bros (SP3).bin^^
Hi, Leute ich hab da mal ne Frage.

Wie macht man es dass mario durch eine Rohre geht,
und in nen andren Level geht wie bei SMW wo er dann aus der Röhre schiest
Ok, ich hab jetzt die Grafiken von Brutal Mario genommen, da die Einwandfrei funktionieren ;)
hab schon einen Tread von dem Spiel "Koopa revenge" erstellt ;)

@Mamamia games:


einfach Shoot from slanted pipe right auswählen
Danke aba ich weiß nicht wie ichs anstelle?

Also:

In Yoshi´s Iland 1 (Level bei SMW)
muss mario ein paar blöcke mit nem spin jump zerbrechen dann is da so ne röhre in die kann man rein. und dass is mein problem.
wie mario in eine röhre gerade reinkommt dann in ein unterirdisches Level oder änliches kommt un am Ende dieses kleinen zwischen Levels ne röhre wieder an die oberfläche kommt.

DASS IST MEIN PROPLEM
Das hier hab ich jemand anderem in einer Youtube-Nachricht geschrieben, aber das gilt auch für dich.

Originally posted by WhiteYoshiEgg
Wenn du willst, dass eine Röhre in einen anderen Bereich desselben Levels (oder eines anderen, das ist egal) führt, drückst du erstmal F1, um das Level in Screens zu unterteilen. Platziere eine "Exit-enabled"-Röhre im Level und klicke auf den ersten Tür-Button in der Toolbar. Wähle dann den Screen aus, auf dem die Röhre steht. Im Feld darunter gibst du irgendeine Nummer ein, völlig egal welche (sagen wir mal 15). Dann hakst du das Feld darunter ab (Use the above value...) Dann folgt wieder ein Klick auf OK. Drücke jetzt am besten F2. Als Nächstes musst du auf den Tür-Button mit der 2 darauf klicken. Im obersten Menü wählst du die Nummer aus, die du eben eingegeben hast (also 15). Im Feld darunter gibst du ein, zu welchem Level die Röhre führen soll. Im nächten Feld musst du eingeben, zu welchem Screen im Ziel-Level die Röhre führen soll. Dann markierst du das Feld (Set X/Y Position...) Jeder Screen ist, wenn du F2 gedrückst hast, in Top und Bottom unterteilt. Wähle dann im Menü rechts in der Mitte entweder "Top" oder "Bottom" aus, je nachdem, wo man am Ende rauskommen soll. Die genaue Position kannst du festlegen, wenn du mit den beiden anderen Menüs X und Y veränderst und ein bisschen rumprobierst. Das Ergebnis siehst du, wenn du auf OK klickst (und, falls nötig, das Level aufrufst, in dem man rauskommt). Im Menü ganz unten im Fenster kannst du übrigens einstellen, wie Mario erscheinen soll, in deinem Fall wählst du da "Shoot from slanted pipe right". Sollte das Bild nach oben oder unten scrollen, wenn Mario erscheint (was nicht so schön aussieht), probiere andere Einstellungen im Menü aus, wo "FG" steht.


--------------------


 
hoho, letztens habe ich auch rausgefunden, wie das mit den Röhren funktioniert. Mein Problem aber ist, dass der Hintergrund total (sagen wirs mal so) verglitcht, wenn Mario aus dem Rohr rauskommt. Wie krieg ich das wieder in Ordnung?

zur info: Ich hab level 1CA (ist ein Untergrund level) mit level 105 verlinkt.

--------------------
so yeah, hoho





www.youtube.com/gvirusg
www.dailymotion.com/G-Virusg
Probiere mal andere Einstellungen im "BG Initial Position"-Menü aus.

--------------------


 
Habs grad eben versucht und jetzt ist wieder alles in Ordnung. :)
Danke.

--------------------
so yeah, hoho





www.youtube.com/gvirusg
www.dailymotion.com/G-Virusg
so, jetzt hab ich wieder eine Frage ^^ :

Ich hab jetzt den Deathweight_bros runtergeladen,
hab beide bei sprites.txt hinzugefügt, also
3D deadweight_bro.cfg
3E deadweight_weight.cfg

aber was ich jetzt nicht verstehe, ist:



wenn ich das gewicht Manuell einfüge, dann erscheint es ganz normal,
aber wenn dieser Typ sie wirft, dann hat das gewicht
1.falsche Grafik
2. falsche Funktion (schwebt einen schritt links, dann pause, dann wieder einen schitt rechts rum)...

ich find einfach den fehler ned, beim einfügen hab ich das Gewicht als nächstes Sprite in der Liste hinzugefügt...
hat jemand eine Idee?
Gruß Maxderdachs
Hmmm... Das einzige, was mir dazu einfällt, ist, dass das Extra-Bit falsch ist. Es könnte auch sein, dass du Sprite 3E schon in der Sprites-Liste hast.

--------------------


 
Extra bite ist no, also benutz ich 2.
Ich hab jetzt den bruder und das Gewicht an einer andern Stelle, bei 40 und 41 nochmal hinzugefügt, aber das ergebnis ist das gleiche...
:(
Dann würde ich vorschlagen, du stellst die Frage in einem anderen Forum, wo dir mehr Leute helfen können ;)

--------------------


 
Ich hatte das selbe Problem, versuche mal den Deadweight Bro neu runterzuladen und nochmal einzufügen.
Erstens: Guter Hack CargoOfDarkness! Aber das Ghost House ist frustrierend ( Sogar mit Savestates :-( )
Zweitens: Mein erster Hack ist fast fertig, aber ich bind zu plöde den unsichtbaren 1-UP Block zu finden... Wo versteckt der sich?
hab ich... hab zu versuchszwecken mal ein anderes Sprite nach deadweight_bro einzufügen, das wird gespammt von dem Typen...

also muss es am Gewicht liegen, das aber wenn man es normal im Spiel hinzufügt so ist wie es sein soll...
so ein Mist ich check ned was falsch ist :(
Originally posted by Lupinius
Mein erster Hack ist fast fertig, aber ich bind zu plöde den unsichtbaren 1-UP Block zu finden... Wo versteckt der sich?


Hier dürfte er sein:

(Blöcke füge ich fast nur noch über Direct Map16 Access ein :P)


--------------------


 
Pages: « 1 2 3 4 529 30 » Link - Thread Closed
Forum Index - SMW Hacking - SMW Hacking Help - Official German Thread (Deutsche SMW-Ecke)

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks