Banner
The Base Rom Level Design Contest has begun! Visit its contest subforum to learn more!
Views: 771,410,041
Time:
17 users online: August77, Aurora, BlueZy, DKR_02, ECS.98, ExONightZ, izaguirrefermin28, luanshn, MORC,  Nameless, Pereira, qa-,  Sinc-X, sinseiga, TheZ, Yung Gotenks, Yuzu - Guests: 41 - Bots: 86Users: 40,525 (1,860 active)
Latest: XCB
Tip: You can draw more event tiles under the default Layer 2 Event tiles on the overworld for custom use!Not logged in.
HELP ME!!!! I can't get this to work!!!! SM64 Editor problem
Forum Index - Non-SMW Hacking - Super Mario 64 Hacking - HELP ME!!!! I can't get this to work!!!! SM64 Editor problem
Pages: « 1 »
I'm trying to import a level via SM64 Editor, but it never works! It always comes out as this:

--------------------
I would appreciate it if someone could help me ASAP, I’m still kind of a noob at this stuff.

--------------------
Your image is just a giant empty space with a minus sign in the middle. You might want to host that elsewhere.

--------------------
Your layout has been removed.
Look here: https://mobile.twitter.com/Minelog23/status/936723215061204992
Google photos sucks :P

--------------------
No one? Am I the only one with this problem?

--------------------
Here's something to check: Is your model made up of triangles, or is it made up of rectangles? In my experience, in order to work properly, your model must consist solely of tris, kind of like this:

Code
__________
|\       |
| \      |
|  \     |
|   \    |
|    \   |
|     \  |
|      \ |
|       \|
----------



And not quads, like this:

Code
__________
|        |
|        |
|        |
|        |
|        |
|        |
|        |
|        |
----------



(Sorry about the crude ASCII art, I'm too lazy to take screenshots. #tb{;)})

Your OBJ Exporter should have an option to automatically triangulate your model.

I hope this helps. #tb{:)}
A word fitly spoken is like apples of gold in pictures of silver.
--Proverbs 25:11
Originally posted by J_128
Here's something to check: Is your model made up of triangles, or is it made up of rectangles? In my experience, in order to work properly, your model must consist solely of tris, kind of like this:

Code
__________
|\       |
| \      |
|  \     |
|   \    |
|    \   |
|     \  |
|      \ |
|       \|
----------



And not quads, like this:

Code
__________
|        |
|        |
|        |
|        |
|        |
|        |
|        |
|        |
----------



(Sorry about the crude ASCII art, I'm too lazy to take screenshots. #tb{;)})

Your OBJ Exporter should have an option to automatically triangulate your model.

I hope this helps. #tb{:)}


Stll not working. This time worse. I'm using Sketchup, tried to triangulate in options, didn't get a good result.

--------------------
Have you made sure that the faces are oriented properly?

Make sure that the white side of the face is facing up. Imagine a flat rectangle floor. You need to have the white side face up and the dark side be on the bottom, where no one can see it.

To do this, right click the face(s) that are wrong and select "Reverse Faces" :)

--------------------
we just don't know
Originally posted by ProRevolution128
Have you made sure that the faces are oriented properly?

Make sure that the white side of the face is facing up. Imagine a flat rectangle floor. You need to have the white side face up and the dark side be on the bottom, where no one can see it.

To do this, right click the face(s) that are wrong and select "Reverse Faces" :)


I have to say, i'm extremely new to this stuff, just look at this pic and tell me what's wrong, if you could. :) https://twitter.com/Minelog23/status/938843275842093056

--------------------
Just right-click and select reverse faces:




Also, when you export your model, select options, and make sure they look like this:

Originally posted by Quote
Just right-click and select reverse faces:




Also, when you export your model, select options, and make sure they look like this:



Mkay. So like this?

--------------------
Yes. But if your model have grey parts, do the first step
Originally posted by Quote
Yes. But if your model have grey parts, do the first step


Don't worry, I figured it out. I just had a bad model.

--------------------
Pages: « 1 »
Forum Index - Non-SMW Hacking - Super Mario 64 Hacking - HELP ME!!!! I can't get this to work!!!! SM64 Editor problem

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2019 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 9

Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Talkhaus
  • SMBX Community
  • GTx0
  • Super Luigi Bros
  • ROMhacking.net
  • MFGG
  • Gaming Reinvented