Banner
C3 is "Over", but stay tuned for voting.
Views: 659,470,844
Time:
7 users online: Alucard648, Eminus, Final Theory, Io_Cqxz, randombot999, Schieber1234, VilelaBot - Guests: 45 - Bots: 554Users: 35,354 (1,224 active)
Latest: suman11
SMWC3 Content Spotlight
Blind Devil's ASM Showcase!
Not logged in.
Blind Devil has some ASM releases
Forum Index - Important - C3 Summer 2018 - Blind Devil has some ASM releases
Pages: « 1 2 »
In love with absolutely everything in this thread. So looking forward to that cutscene thing!!

--------------------
Twitter
Can i just say, THANK YOU SO MUCH FOR THE VERTICAL FIX. That vertical scrolling has screwed me over SO many times in my hack, so i am so glad that someone finally fixed it.

--------------------
Current Projects:
Super Kekcroc World
I'm enjoying the falling leaf sprite in the hack I am creating, Blind Devil, but I am having problems with the Bumper Sprite. I can't seem to get it to follow a line guide no matter how much I try. I have placed it above, below, beside, and on the line, but either this happens or it falls off screen:

https://bin.smwcentral.net/u/32624/bumper.gif
https://bin.smwcentral.net/u/32624/bumper2.gif

Aside from modifying the tilemap, I am using your provided .asm and .cfg files in Pixi. I insert my sprite as bit 2, and I set the extension to 03. Other line guided sprites follow my line guides so I don't think they are the problem. If it matters I am also using the Line Guide Acts-Like Fix Patch because my lines are not on the vanilla Map16 page.

Any idea what might be causing this? Have I overlooked something?
Not Blind Devil, but I think I can tell the issue is caused by the line guide fix patch. The patch rewrites the "follow line guides" code for all of SMW's sprites, but has no way of affecting custom sprites. For them, you'll have to rewrite the code yourself.

If I recall correctly, what you can do is look for this piece of code:

Code
PHA
LDA $05
AND #$07
TAY
PLA
AND BitTable,y


and replace it with this:

Code
-	XBA
	LDA $1693
	REP #$30
	ASL
	ADC $06F624
	STA $0D
	SEP #$20
	LDA $06F626
	STA $0F
	REP #$20
	LDA [$0D]
	SEP #$30
	STA $1693
	XBA
	CMP #$02
	BCS -
	CMP #$00


--------------------


 
WhiteYoshiEgg, that fix worked flawlessly! I'll be sure to save your post for any potential future line-guide related problems. Thank you very much :)
These are some really neat things! I like the falling leaves and the bouncer the most.

Check out Extra Mario World!
so many comments-- I mean, thanks everybody for the kind comments! Now it's time for me to reply to some stuff, though firstly I apologize for not being able to reply to all posts as I originally wanted to.

Originally posted by TLMB
Minor suggestion, maybe add a spin to the rising portion of the SMB2 charge jump. Something to make it look different than the regular jump.


I can add an option/define so when the player does a charged jump, the contact (a.k.a. enemy stomp) effect is displayed.

Originally posted by ft029
The bumper uses SP3, not SP4 as indicated by the name of the ExGFX file.


My bad. Will fix this for when it's submitted to the Sprites section. Thanks for noting.

Originally posted by ft029
I'm also not sure how the extension byte works. It seems that no matter what I put, if there's only 1 bumper in the level, then it will move at a slow speed; if I put multiple ones in the level, one might just not show up, and other strange things happen. (could be an issue with other patches in the rom I'm using)


As for the Extension byte, I've configured like this:
00 = bumper is stationary and doesn't require line guide.
01 = line-guided bumper, moves at slow speed.
02 = line-guided bumper, moves at medium speed.
03 = line-guided bumper, moves at fast speed.
04 = line-guided bumper, moves at very fast speed.
05+ = bumper is stationary but falls a bit when spawned.

Regarding some bumpers not showing up, I have run into this in an SA-1 ROM, but that mysteriously happened only once or twice and everything worked most of the time. So if you're using SA-1, this might be related but I assume it's something with PIXI (assuming you're using it) - I'd blame it and call it a day. I'll be sure to revise the sprite code anyways. I didn't test any sprites on Giepy yet so if you're using Giepy I'm completely clueless.

Originally posted by Knight of Time
Though in regards to the hypothermia code, if I use it in any of the levels in my ice world, will it work alongside an air meter sprite (e.g. mikeyk's air meter, which I converted to PIXI) if I edit the patch so that water cannot hurt or kill Mario?


It should work, assuming there's no free RAM address conflicting with each other. If something strange happens, be sure to look into it and change one of them.

Originally posted by Knight of Time
It would be great to know how to disable the hypothermia effect while Mario is underwater, so if you know a way to do that Blind Devil, please let me know, and thanks.


Easiest, quickest one is placing this in main:

Code
BRA init


...right after these lines:
Code
LDA $75			;load player is swimming flag
BEQ .notswimming	;if not swimming, skip ahead.


This way, the code will always reset the temp timer when the player is in water (untested so if it doesn't work i'll provide another option and yep lol kill me).

Originally posted by Keiko_
If I could suggest one minor addition for your Hypothermia UberASM; would it be possible to have mario's palette turn shades of blue when he stands still to indicate he is freezing? Perhaps using the blue palette of his overalls on his skin and shirt? I think it would add a nice effect.


It is possible, but it's not very practical. Messing with palettes by directly messing with CGRAM is pretty tricky, and also hacky if trying to do so in an SA-1 ROM. Another workaround would be using sprite tiles like the blush used in Bowser battle, after the princess kisses Mario. But that wouldn't help much, too, because there are lots of other poses to take in account, like facing the camera while spinjumping and so on.

With the Custom Mario Palettes patch, though, these problems don't exist. However, you'll have to configure palette tables manually, taking powerups in account, and adding specific checks to the hypothermia code itself. That's why any of the solutions aren't very practical.

Originally posted by Keiko_

Originally posted by WhiteYoshiEgg
fix for custom line-guided sprite code


I didn't test the sprite with the patch applied but I thought it'd be related to the code within line-guided sprite disassemblies. It's probably a good idea to add this code and a maybe a define (or some 'if readXX' if applicable) for people that uses this patch. Thanks, WYE!

Lastly, I'm from mobile so I am still unable to upload stuff to sections yet.

--------------------
MK2TDS
Pages: « 1 2 »
Forum Index - Important - C3 Summer 2018 - Blind Devil has some ASM releases

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2018 - SMW Central
Legal Information - Privacy Policy - Link To Us


Total queries: 23

Menu

Follow Us On

  • Facebook
  • Twitter
  • YouTube

Affiliates

  • Talkhaus
  • SMBX Community
  • GTx0
  • Super Luigi Bros
  • ROMhacking.net
  • MFGG
  • Gaming Reinvented