Banner
Views: 864,404,408
Time:
25 users online: Ahrion, Alucard648, AmperSam, Anko, Cheolpeoduck, chickaDEE Magazine, eskayelle, Ezek.The Square Remixer, FLIO, Funkymario, Infinity, jardeson01, JX444444, KatMakes,  KevinM,  Lazy, Pancake001, SammmUuU, Segment1Zone2, SimFan96,  Stivi,  Teows, TruffledToad, WhiteYoshiEgg,  xHF01x - Guests: 53 - Bots: 116 Users: 47,859 (2,076 active)
Latest: Sim2Lin
Tip: If you're using the wall-running purple triangles in your hack, remember to add tile 1EB (or a tile that acts like tile 1EB) underneath it. Extended object 44/45 will include this tile for you.Not logged in.
Music randomly not working
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Music randomly not working
Pages: « 1 »
Hi

I have a 3-part level, with 3 different rooms, the last one being a Big Boo fight.
I have a custom music for the first 2 rooms, and an other music (original music, Bowser Scene 2) for the boss.

A few times, when I entered the boss room, I got no music. Instead, there was nothing, eventually some noise here and there (so it wasn't like I selected no music at all).
As there is a checkpoint when you enter the room (Retry System checkpoint), I tried exiting the level after a death, re-entering it, and sometimes it fixed the music, sometimes not.
I'm not too sure if the music can break when I hit "Retry" though. I think it did once, but I did so many tries I can't exactly remember.

I tried to replicate the problem, sometimes hitting "retry", sometimes exiting and re-entering, moving on the map and re-entering,... and my conclusion is that... it's completely random. Nothing seems to be a sure trigger, nothing seems to be a sure way of not having it.
What's frustrating is that I never got it for a long time, then I got it a few times, when trying to replicate it, then later I tried replicating it again and I never got it in like 60-70 tries.
So I'm like "it seems ok, maybe the probability is extremely low and maybe I even did something without noticing it and it won't happen to players" but at the same time I can't accept to release something where I know the music can break.

My poor knowledge tells me that maybe I have too much stuff in that room? But it sure doesn't feel like it. I have a Big Boo, a custom sprite and throwing blocks (note that the glitch doesn't necessarily happen when I grab a throw block, in guess you're wondering).
The custom sprite I have is also in the previous room, with a few other custom sprites (sometimes with 3 others on screen) and I never ever got a problem.

So as said, the music I use for the boss isn't custom. I tried downloading it and importing it (therefor having a custom music instead), and I still got the issue.

I'm lost. I'm losing will to continue and release the hack to be honest... I have no idea what causes that and how to fix it.
And the inability to replicate it makes it hard to try to change stuff and see if it gets fixed.

Any idea?

Thanks

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
When it happens, is it just the music that mutes, or all the sound effects as well? And what's the custom track? If it's an original, what's the download or did you make it yourself?

Does it still happen if you change either track to something else? Maybe give it a thousand tries.

Alternatively, something in the custom track may be gumming things up somewhere, especially if it makes an unusual hardware call (like Tales of Phantasia apparently does). I have the Wall Jump patch in my current project and sometimes the jump sound glitches, so it could be something similar to that. It could happen if you switch music on a certain frame of the previous track, who knows...

Unfortunately, that's all I can really do to help...

--------------------
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel
Originally posted by Wiimeiser
When it happens, is it just the music that mutes, or all the sound effects as well?

Hmmm... I've seen it yet I can't say for sure...

Originally posted by Wiimeiser
And what's the custom track? If it's an original, what's the download or did you make it yourself?

I did no music.
The custom music of the 2 first room is from Super Mario All-Star soundtrack (so I think it has a pretty good history, it's not an obscure music nobody has used).
The boss is original SMW, and I tried by downloading the SMW soundtrack and re-inserting it.

Originally posted by Wiimeiser
Does it still happen if you change either track to something else?

I tried a Super Mario All-Star music for the boss, and the music was glitched. It was there, but sounded weird (I had forgotten about that, I should have mentioned it in the original thread)

Originally posted by Wiimeiser
Maybe give it a thousand tries.

I think today I'll give more time to tries (I'll try to record the "no music" too so you can here).
Problem is, with a thousand tries, given the probability the problem seems to happen at, I won't be more able to pinpoint the cause

Originally posted by Wiimeiser
Alternatively, something in the custom track may be gumming things up somewhere, especially if it makes an unusual hardware call (like Tales of Phantasia apparently does). I have the Wall Jump patch in my current project and sometimes the jump sound glitches, so it could be something similar to that. It could happen if you switch music on a certain frame of the previous track, who knows...

True, could be something like that. The use of a music from an overused sountrack probably lowers the chances of that being the cause, but it could be. That's the problem: it can be the smallest thing, and I don't really have a way of knowing, especially if when I try to recreate the issue, I don't get it more than I did so far.

Originally posted by Wiimeiser
Unfortunately, that's all I can really do to help...

That's nice of you to answer and try to help anyway.
I think today I'll try again. I kind of lost my will the past few days.
I'll try to record the problem too so y'all can really know what it's like

EDIT
Ok, I got it first try.

So here is the sound. I amplified it quite a bit so you can hear. (video is over 40 seconds but 5 seconds will give you all it is).

https://youtu.be/trGddiYvIlg

So:
- I have no music, no sound effects.
- I died and hit 'retry' 10 times (which restarts me in the boss room), it didn't fix the music. Which can be expected since retry system keeps the music going.
- I exited the level via the 'exit' option of the retry, and the map music was completely glitched (https://youtu.be/roQkiJiLvDM) (if I change submap music is fine and when I come back music is fine too).
- I re-entered the level 10 times and the music of the boss room was always fine, and every time I exited, the map music was fine too.

So far I've only tested once, so to see if map music glitched everytime I used savestates (and exited the level at different moments). So it might not be representative but I wanted to put the update ASAP.

EDIT: 2nd try did it again after reseting the game. (I entered the boss room at a different part of the music from the 2 previous rooms)

For 3rd attempt I switch to original music, because right now I was on the custom version of the music for the boss. First attempt in those conditions: same problem.
I started on a fresh file, in case, still the same. First time: glitched music.

Next step: changing music from 1st rooms, and then separating the levels... I want none of those 2, but I don't have a choice

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
Did 2 new tests: taking off the "credit music after Wendy fight" patch for AddMusick, still the same.

But then I switched the music of the first 2 rooms to original SMW castle music, and I got music. Glitched music, but still music (and normal sound effects)
https://youtu.be/gXwzVlTSJIU

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
Does it only happen in the one level? What other stuff do you have installed, like sprites and patches? Sounds like something could be overwriting the sound engine in RAM, but I might be wrong.

--------------------
Let's milk Sunny Milk. Then she'll have enough money to fund Sunny Milk Real Estate.
Everypony's digging with a shovel
Originally posted by Wiimeiser
Does it only happen in the one level? What other stuff do you have installed, like sprites and patches? Sounds like something could be overwriting the sound engine in RAM, but I might be wrong.


It only happens in that one level. At least, I never ever heard it in an other.
I have a bunch of sprites, patches and all that. Is there a way to know is there is a RAM overwriting, like a small software or something?

Advancement: I was separating the 2 rooms (which means re-doing overworld), and I thought of trying something: having a room between the first 2 and the the boss with no music (well, empty music). To see if it's the music swap that kills it (since I get no issues when I entered directly with the midaway)
Need to try that today.

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
Ok so I tried having a room inbetween.
I still got issues. Like, 3 out of 10 tries.
I can hear a small sound when I leave the previous room (a bit like in the first video-sound I posted), and then I'm in my no-music room, but I don't have sound effects (indicating that there is still the glitch).

So this confirms that the problem comes from room 2.

So the way I leave it, I realised I potentially had 3 sounds effects starting at the same time (a spin on enemy, a thwomp landing and a pipe entering.
So I changed the end of the room to see if I could get something that would overload in sounds effects, but no, still the same.

I think I'm gonna try without room 2, and if it works, I'll just go that way. It's annoying, but probably less than becoming insane because of that music issue.

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
Doesn't work

Last thing I'll try is separate the 2 levels. Then I freaking give-up because I'm fed-up with that s***

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
So separating the rooms seems to work.

But while re-playing the game for a last check, I found some other sound issues. Way less dramatic (far far less even), but still annoying to me, so I just give up.
I have neither the knowledge nor the competences to understand what's happening or fix it, so there's no point.

Thankx anyway for the help.

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
Hello,
I have the same problem with my hack! Seems impossible to solve! Clearly, the problem seems to come from the "Retry system" patch for me... Everything is fine without the patch, everything goes randomly shit with the patch! Are you using the "Retry system" of Worldpeace too?!
In my hack, the music only glitches (kind of randomly) in the Overworld and in sub-levels!
Originally posted by Tony.Metcalfe
Hello,
I have the same problem with my hack! Seems impossible to solve! Clearly, the problem seems to come from the "Retry system" patch for me... Everything is fine without the patch, everything goes randomly shit with the patch! Are you using the "Retry system" of Worldpeace too?!
In my hack, the music only glitches (kind of randomly) in the Overworld and in sub-levels!

You know what? I get the same feeling about the retry system. I'm using it and after testing and testing, I feel like it's the issue.
Problem is, I don't really want my hack to not feature it...

Do you know which version of the retry system you have?
Did you try using Patch Manager to check for conflicts amongst your patchs?
Do you happen to have any of those patchs in your hack:
Block Duplication Fix ; Balloon Cloud Clipping Fix ; Custom Mario Palettes ; Sprite initial facing fix
(those were the patchs that were said to have a conflict with the retry system by Patch Manager for me)

EDIT
#smw{o_O?} I just got a sound issue without the retry system. Not sure what to make of that.
EDIT2: ok, 99% sure it was the music, probably too big

--------------------
Super Mario Pants World
Luigi's Lost Levels
New Super Mario Pants World
VLDC12 - 72HoKaizo#1
fast retry is gimped out in lunar 2.53, use 2.52
Hello,
Sorry for my late response Romano, I was in vacations! :D

Here's my response to your questions:

- "Do you know which version of the retry system you have?"
I have the latest one I think (Retry system V2.03). [For Lunar Magic, I'm using 2.43 version]

- "Did you try using Patch Manager to check for conflicts amongst your patchs?"
No... I didn't know this thing existed!

- "Do you happen to have any of those patchs in your hack: Block Duplication Fix ; Balloon Cloud Clipping Fix ; Custom Mario Palettes ; Sprite initial facing fix ; (those were the patchs that were said to have a conflict with the retry system by Patch Manager for me)?"
No, I have no other patch in my hack. The two only other things I apply with ASM to my hack are : Disable midway point powers & Disable losing lives.

Hope this will help you!
Now that I'm back home, I will probably try some things in the next few days... I'll keep you inform if I find something!
Hey Romano!
On Worldpeace's page (''My Files'' section of Worldpeace), I found out that he made a 2.04 version of his Retry System... and I was using the 2.03 version. So, I tried it and it seems to work!!! I'm 100% sure that my hack's music is now working absolutely fine!
If you were using V2.03, I suggest you to try the V2.04
you can find it here: https://www.smwcentral.net/?p=files&u=1250&sort=date&order=desc

Hope this will help you! #smrpg{y}
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Music randomly not working

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy