Banner
Views: 858,659,368
Time:
13 users online: Darolac, eltiolavara9, Got, Infinity,  KevinM, Krizis,  MarioFanGamer, mio, MrDeePay, OEO6, omegazeroINFI, underway, Zeldara109 - Guests: 33 - Bots: 74 Users: 47,452 (2,248 active)
Latest: PixelUwU
Tip: Use palettes that don't burn the eyes. A blazing bright yellow and a night-black are not pleasant.Not logged in.
[Please Close] SOLVED Fixes.asm in GHB+FuSoYa's SMB3 screen scrolling pipes break SMW's Ending Sequence
Forum Index - SMW Hacking - SMW Hacking Help - [Please Close] SOLVED Fixes.asm in GHB+FuSoYa's SMB3 screen scrolling pipes break SMW's Ending Sequence
Pages: « 1 »
Hello everyone!

I'm working on fixing a broken Super Mario World hack (Super Sig World 10) to be console compatible as a side-project. So far I've gotten to the point where everything in the hack is perfectly re-created and runs perfectly on accurate emulators and ZSNES except for the final boss fight. Whenever I'd beat Bowser everything seems fine for a moment, the Peach message is shown and fireworks are displayed but then.... nothing. It's locked on that screen indefinitely. I've looked everywhere to figure out how to fix this and kept running into dead-ends.

EDIT: So I narrowed it down after testing and I applied the GPS FuSoYa pipes to a clean, unmodified ROM. Tested the final boss on the original Bowser's Castle, and no credits appeared and it was stuck at the same screen. What could cause this? Would this be an UberASM issue, GM14, GPS, or new Lunar Magic issue with these pipes conflicting with the games original credit fade-out, and more importantly can I use these pipes in the game and have the credits at the end? Here's a link to the blocks I used.

If anybody could help me out or has any other questions, feel free to let me know. Thank you and have a wonderful day!
Has anybody else had this issue happen or anybody solve it? I'm not sure what to do to resolve this issue and this is the only thing I need in order to finish fixing this hack or create any hack in general that would use these pipes. Would there be a simple hex edit or UberASM code in order to fix the End Game Sequence and have these pipes in the game at the same time? I can also post an IPS patch if needed of the clean, unmodified SMW game with the pipes (every step of the Readme for the pipes has been completed).


First things first, try with this one instead and see if that also has the issue.

As for fixing it, it's kinda hard to say exactly where the issue might be, so your best bet would be to try running a debugger on the ROM and checking around where it breaks. Snes9x (or at least Snes9x-rr) features a trace logger which you can use to log all ASM code run during a set of frames. Run the trace on the couple of frames around where the credits break, then open it up in a text editor and look for where the break most likely occurs (generally BRK opcodes are a good starting point). From there it's a matter of following the code up to where the issue originates (most likely either a stack issue or unhandled situation), and figuring out how to fix that issue.
(that might be kinda hard if you're not experienced in ASM obviously, but it's the best advice I can give right now)

Professional frame-by-frame time wizard. YouTube - Twitter - SMW Glitch List - SMW Randomizer
Thank you for your response, Thomas! I just tested the GHB Screen Scrolling Pipes you linked as well. It appears it also breaks the Bowser Credit Screen unfortunately. Thank you for the suggestion about the SNES9x-rr! It's hard to pin-point when the game "breaks" as it is frozen after the fireworks display, although it could've possibly been broken before then, or anytime after Bowser is defeated. I only have some basic experience in ASM (created a basic block through ASM and have edited sprites as well, but nothing too experienced but am willing to learn more.)

Thanks again for your reply! I'll keep looking to find a solution for this issue.

Also, if anybody is interested I've uploaded an IPS file of the original SMW game with the pipes installed. And an SRM file so you can go straight to Bowser's Castle to test the credits in case anybody wanted to see this glitch firsthand.

Edit: After more testing I can narrow down the problem even more now. It's not the pipes themselves that break the End sequence, however ironically the Fixes.asm patch included in the pipe pack that breaks the ending sequence. Does anyone know if there's any way to modify the code to keep the ending sequence intact?

Edit 2: Issue is officially fixed, the credits plays fine now thanks to GreenHammerBro for fixing the issue which was stated would be included in a future update. This thread can be closed.
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - [Please Close] SOLVED Fixes.asm in GHB+FuSoYa's SMB3 screen scrolling pipes break SMW's Ending Sequence

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy