Summer C3 2020 begins in:
Views: 836,104,575
28 users online: AJ1Ayrton, chickaDEE Magazine, crocodileman94, Dark Mario Bros, Dispace, Dominicentek,  E-man38, Eduard, h.carrell,  JamesD28,  KevinM, KiloMinimo, LOLRyan2006 the Goombud, Lunch Lunch, lx5, Medic, Mgraymallio,  Ninja Boy, Ryrir, SammmUuU, Samuel Zuccati, shaoshao, Snessy The Duck,  Stivi, Superdjsteve54,  Teows, The Snootster, toad64 - Guests: 57 - Bots: 294 Users: 45,604 (3,255 active)
Latest: k8747t
Tip: Read all of the tips by looking here.Not logged in.
GPS says rom has an error
Forum Index - SMW Hacking - SMW Hacking Help - GPS says rom has an error
Pages: « 1 »
Hello. My rom appears to be perfectly fine in terms of functionality in Lunar Magic and other programs, yet when I attempt to add blocks with GPS, I'm given an error. Specifically "Error on line 29: Missing space or acts like seperator."

My rom managed to survive in the midst of an external program deleting a bunch of crap, but it was unmodified and wasn't deleted, so no data should be modified. What's going on? Is there a repair I can do?

Using the debug option in command prompt gave the following information.
ROM Information:
SA-1: 0
ROM Size: 0x400000
Header Size: 0x200

Error on line 29: Missing space or acts like seperator.
The issue lies presumably in list.txt. Can you post it here?

Okay, my layout looks ugly.
Sure, absolutely. There are no duplicate numbers, and there are no missing spaces that I can see.

The line that would be in question would be "41B:130 solidpswitch.asm" though anything I put in its place also has the same error.
I'm pretty sure you're not supposed to have those : symbols without an actual acts like number. Try removing them if you use the default acts likes.
Huh. I'll try that right now. I'm not really sure what gave me the idea in the first place, but it always seemed to work beforehand.

Edit: This worked! Thank you for the help! Somewhere along the way I must have gotten things mixed up, as I'm unsure what led for me to do this before. Everything worked perfectly. #tb{:>}
Pages: « 1 »
Forum Index - SMW Hacking - SMW Hacking Help - GPS says rom has an error

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2020 - SMW Central
Legal Information - Privacy Policy - Link To Us


Follow Us On

  • YouTube
  • Twitch
  • Twitter


  • Super Mario Bros. X Community
  • Mario Fan Games Galaxy