Banner
VLDC #13 ends in
5 DAYS, 9 HOURS, 18 MINUTES AND 45 SECONDS
Views: 994,690,896
Time:
14 users online: ASMagician Maks, AutoAttack RON, Azula16, Infinity, Jordan, Kusrry, mae_86, norwegianboyee, orka-bln, Panik FLDV, PiyoPiyori, RollingRigatonis, Superwan, TheRealConsole - Guests: 42 - Bots: 226 Users: 54,533 (2,085 active)
Latest: SnowingMilk666
Tip: Before asking for help on the forums, make sure you've tried to figure out the problem on your own first.
Not logged in.
Music doesn't play and cancels out all sound effects
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Music doesn't play and cancels out all sound effects
Pages: « 1 » Link
Hello!

I'm trying to add music to my Super Mario World hack, but all it does is make everything silent, including the sound effects.
The tutorial I used was from 3 years ago, so if it might be because of the version changes in AddmusicK, please leave a comment of tutorials later than 2016.

Thank you!

Did you use an old music tool before using AddmusicK? Like, AddmusicM or Addmusic4?

--------------------
niðer in sċræfe, mæġen iċ næbbe
Originally posted by FailSandwich
Did you use an old music tool before using AddmusicK? Like, AddmusicM or Addmusic4?


I downloaded the latest version of AddmusicK.

Ok. So, did you apply any patches that might have changed something music-related? Is it an issue with your emulator?

--------------------
niðer in sċræfe, mæġen iċ næbbe
I also have a similar issue. I'm brand new to custom music so it might be an obvious solution but i can't find anything online about it. When I load my ROM or even a new ROM that just has a header and expanded RAM, I am told that asar found an error before i even add any music and the temp log reports it as:

"asm/snes/temppatch.asm:56: error: (E5053): Function 'read($05D8E6)' wasn't found. [if read($05D8E6) == $22]"

If I go on and add a txt file and select the related number as the level's music the entire level is completely silent, sound effects and all. I assume this is what happens if i set an unused music slot as the level music and Addmusick just isn't affecting the ROM at all due to the initial error. I just have no clue what the error is. Again I'm brand new to this so it might be an obvious solution. I happened to see this thread and it sounded similar to my issue so maybe they are related.
EDIT: I got it working, not sure what i did wrong. Reinstalled AddmusicK and created a new folder and it ended up working, I guess I must have deleted or messed with something before without realizing it.
Pages: « 1 » Link
Forum Index - SMW Hacking - SMW Hacking Help - Custom Music - Music doesn't play and cancels out all sound effects

The purpose of this site is not to distribute copyrighted material, but to honor one of our favourite games.

Copyright © 2005 - 2022 - SMW Central
Legal Information - Privacy Policy - Link To Us


Menu

Follow Us On

  • YouTube
  • Twitch
  • Twitter

Affiliates

  • Super Mario Bros. X Community
  • ROMhacking.net
  • Mario Fan Games Galaxy
  • sm64romhacks